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TIBCO SPOTFIRE S+ BOOKS

Note about Naming

Throughout the documentation, we have attempted to distinguish between the language
(S-PLUS) and the product (Spotfire S+).

*  “S-PLUS” refers to the engine, the language, and its constituents (that is objects, functions,
expressions, and so forth).

*  “Spotfire S+” refers to all and any parts of the product beyond the language, including the
product user interfaces, libraries, and documentation, as well as general product and
language behavior.

The TIBCO Spotfire S+® documentation includes books to address
your focus and knowledge level. Review the following table to help
you choose the Spotfire S+ book that meets your needs. These books
are available in PDF format in the following locations:

+ In your Spotfire S+ installation directory (SHOME\help on
Windows, SHOME/doc on UNIX/Linux).

* In the Spotfire S+ Workbench, from the Help » Spotfire S+
Manuals menu item.

+  In Microsoft® Windows®, in the Spotfire S+ GUI, from the
Help » Online Manuals menu item.

Spotfire S+ documentation.

Information you need if you... See the...

Must install or configure your current installation | Installtion and
of Spotfire S+; review system requirements. Administration Guide

Want to review the third-party products included | Licenses
in Spotfire S+, along with their legal notices and
licenses.
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TIBCO Spotfire S+ Books

Spotfire S+ documentation. (Continued)

Information you need if you... See the...
Are new to the S language and the Spotfire S+ | Getting Started
GUI and you want an introduction to importing | Guide

data, producing simple graphs, applying statistical

models, and viewing data in Microsoft Excel®.

Are a new Spotfire S+ user and need how to use
Spotfire S+, primarily through the GUIL

User’s Guide

Are familiar with the S language and Spotfire S+,
and you want to use the Spotfire S+ plug-in, or
customization, of the Eclipse Integrated
Development Environment (IDE).

Spotfire S+ Workbench
User’s Guide

Have used the S language and Spotfire S+, and
you want to know how to write, debug, and
program functions from the Commands window.

Programmer’s Guide

Are familiar with the S language and Spotfire S+,
and you want to extend its functionality in your
own application or within Spotfire S+.

Application
Developer’s Guide

Are familiar with the S language and Spotfire S+,
and you are looking for information about creating
or editing graphics, either from a Commands
window or the Windows GUI, or using Spotfire
S+ supported graphics devices.

Guide to Graphics

Are familiar with the S language and Spotfire S+,
and you want to use the Big Data library to import
and manipulate very large data sets.

Big Data
User’s Guide

Want to download or create Spotfire S+ packages
for submission to the Comprehensive S-PLUS
Archive Network (CSAN) site, and need to know
the steps.

Guide to Packages
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Spotfire S+ documentation. (Continued)

Information you need if you...

See the...

Are looking for categorized information about
individual S-PLUS functions.

Function Guide

If you are familiar with the S language and
Spotfire S+, and you need a reference for the
range of statistical modelling and analysis
techniques in Spotfire S+. Volume 1 includes
information on specifying models in Spotfire S+,
on probability, on estimation and inference, on
regression and smoothing, and on analysis of
variance.

Guide to Statistics,
Vol. 7

If you are familiar with the S language and
Spotfire S+, and you need a reference for the
range of statistical modelling and analysis
techniques in Spotfire S+. Volume 2 includes
information on multivariate techniques, time series
analysis, survival analysis, resampling techniques,
and mathematical computing in Spotfire S+.

Guide to Statistics,
Vol. 2
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Chapter T Introduction

WELCOME TO SPOTFIRE S+!

Spotfire S+ is based on the latest version of the powerful, object-
oriented S language originally developed at Lucent Technologies. S is
a rich environment designed for interactive data discovery and is the
only language created specifically for data visualization and
exploration, statistical modeling, and programming with data.

Spotfire S+ continues to be the premier solution for your data
analysis and technical graphing needs. The Microsoft Office-
compatible user interface gives you point-and-click access to data
manipulation, graphing, and statistics. With Spotfire S+, you can
program interactively using the S-PLUS programming language.

In a typical Spotfire S+ session, you can:
* Import data from virtually any source.
* View and edit your data in a convenient Data window.
*  Create plots with the click of a button.

+  Control every detail of your graphics and produce stunning,
professional-looking output for export to your report
document.

*  Perform statistical analyses from convenient dialogs in the
menu system.

*  Run analysis functions one at a time at the command line or
in batches using the Script window.

*  Create your own functions.

+  Completely customize your user interface.

System For a list of system requirements, see the file INSTALL.TXT in the
Requirements installation directory.
Note

Spotfire S+ does not support Win32s (that is, Windows 3.1x), nor does it support Windows NT

3.51.




Running
Spotfire S+

Welcome to Spotfire S+!

Super VGA, or most other Windows-compatible graphics
cards and monitors with a resolution of 800x600 or better.

Microsoft mouse or other Windows-compatible pointing
device.

Windows-compatible printer (optional).

A connection to the Internet, including a Web browser.

The following list describes the ways that you can launch Spotfire S+
in Windows:

Start the Spotfire S+ for Windows Graphical User Interface
(GUI) from the Start menu.

Start the Spotfire S+ Workbench from the Start menu.
Start the Windows Console from the Start menu.

Start the Windows Console from a DOS command line for
interactive use.

Run the Console version from a Windows batch file using
"Sqpe infile outfile".

Run the Spotfire S+ GUI version from a Windows batch file
using "Spotfire S+ BATCH".

Run the Spotfire S+ GUI version from Automation via the
Excel add-in, SPSS add-in, or a custom Automation

application such as from PharSight®.
Run the Spotfire S+ GUI version via DDE.

Run the Console version via Connect/C++ or Connect/Java.

You can run Spotfire S+ for 32-bit Windows on a 64-bit Windows
computer.
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Important

Spotfire S+ for 64-bit Windows :

* Includes support for Spotfire S+ Batch, the Spotfire S+ Console and the Spotfire S+
Workbench. It does not include the Spotfire S+ GUL

*  Works only on computers running a 64-bit Windows operating systems. It does not work
on computers running 32-bit Windows.




Help, Support, and Learning Resources

HELP, SUPPORT, AND LEARNING RESOURCES

Online Help

HTML Help

There are a variety of ways to accelerate your progress with Spotfire
S+. This section describes the learning and support resources
available to Spotfire S+ users.

Spotfire S+ offers an online HTML Help system to make learning
and using Spotfire S+ easier. Under the Help menu, you will find
help on how to use the Spotfire S+ graphical user interface. In
addition, an extensive Language Reference provides detailed help on
each function in the S-PLUS language. The Language Reference help
can also be accessed through the Commands window by typing
help() at the S-PLUS language prompt.

Context-sensitive help is available by clicking the Help button in
dialogs or the context-sensitive Help button on toolbars, as well as by
pressing the F1 key while Spotfire S+ is active.

HTML Help in Spotfire S+ is based on Microsoft Internet Explorer
and uses an HTML window to display the help files. To access
HTML Help, do one of the following:

*  From the main menu, choose Help P Available Help »
TIBCO Spotfire S+ Help for help on the GUI.

* From the main menu, choose Help P Available Help »
Language Reference for help on the S-PLUS programming

language.
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As shown in Figure 1.1, the HTML help window has three main
areas: the toolbar, the left pane, and the right pane.

E? 5-PLUS Help =1 E3

L E I B

Hide Back  Forward Refresh  Print Options

LCantents | Index I §earch| =

Formatting Panels on a Multipanel Graph
Importing and Exporting Data ;I g p p

g E:Icnhga:mh?nubDIEbC';EtZDJ\z{:[DtherA liatic YWhenever a plot is placed on a multipanel graph, a plot panel object is
@ Crestin gagﬁ[a Ih kP created for each panel. The panels are contained by the plot in the Object
@ Graph ga"ew o Explorer and their properties can be changed by right-clicking on their

+ @ Wworking with Trellis Graphics ieon.
=-{[) Formatting a Graph . . . .
_____ [2] Formatting a Graph Sheet These panel objects have display attributes of their own that can be used to

3 Fomatting the Graph Area overr_ide the plot's display attrihutgs. Faor gxample, you might want to set

. [2] Fomatting the Plat Avea the line color of the plot to green in the third panel, and to blue in the rest of
----- [2][Formatting Panels on a Multipanel Graph] the panels.

----- 2] H%matting 20 Axes
- [2] Formatting 2D Avis Labels To edit plots in individual panels
j Formatting and Raotating 30 Axes
- [2) Formatting 30 Awis Labels

2] Fomatting 30 I 1.In the left pane of the Object Explorer, select Graphs.
ormatiing anes
Fotati 30 Graph . o
] maing g 2. Expand the branches until you see the plot panels appear as individual
j Dizplayig 30 Multipanel Graphs bi p ¥ plot p pp
- [2) Formatting Palar xes objects.
----- [2] Adding Multi-Line Text ) ] ) ) )
..... 2] Adding Special Characters and Fam. 3. Double-click on the panel you wish to edit to open its property dialog.

1 ' |

..... 2] Adding Titles and Legends _ILI Make the desired changes and click OK.
=4 0 e ~m PR
»

Figure 1.1: The Spotfire S+ help window.

Using the toolbar

Table 1.1 lists the four main buttons on the help window toolbar (in
some cases, you may see more).

Table 1.1: Help window toolbar buttons.

Button Name Description

Hide (or Show) If the button is labeled Hide, it hides the
left pane, expanding the right pane to the
full width of the help window. If the button
is labeled Show, it shows the left pane and
partitions the help window accordingly.

Back Returns to previously viewed help topic.

Forward Moves to next help topic.
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Table 1.1: Help window toolbar buttons. (Continued)

Button Name Description

Print Prints the current help topic.

Using the left pane

Like the help window itself, the left pane is divided into three parts:
the Contents tab, the Index tab, and the Search tab:

* The Contents tab organizes help topics by category so that
related help files can be found easily. These categories appear
as small book icons, labeled with the name of the category. To
open a category, double-click the icon or label. To select a
topic within the category, double-click its question-mark icon
or the topic title.

* The Index tab lists available help topics by keyword.
Keywords are typically function names for S-PLUS language
functions and topic names for graphical user interface topics.
Simply type in a keyword and HTML Help will find the
keyword that most closely matches it. Click Display (or
double-click the selected title) to display the help topic.

* The Search tab provides a full-text search for the entire help
system. Simply type in a keyword, and all the help files
containing that keyword are listed in a list box. Select the
desired topic and click Display (or double-click the selected
title) to display the help topic.

Using the right pane

The right pane is where the help information actually appears. It
usually appears with both vertical and horizontal scrollbars, but you
can expand the HTML Help window to increase the width of the
right pane. Many help files are too long to be fully displayed in a
single screen, so choose a convenient height for your HTML Help
window and then use the vertical scrollbars to scroll through the text.
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The right pane contains a search-in-topic feature. To use it:

1. Type CTRL-F to open the Find dialog (this dialog is a feature
of HTML Help inherited from Internet Explorer).

2 Find HE

Find what: I Eitid i eqt |

™ Match whole word only [:_IIECtIDnr Cancel |
™ Match case Le @ e

2. Type your search string in the text field labeled Find what.
3. Click Find Next.

Help in the When working in the Commands window, you can get help for any
Commands and  command by using the ? or help function. For example, to open the
Script Windows help file for anova, simply type:

> help(anova)

or

> ?anova

To get help for a command when working in a Script window, simply
highlight the command and press F1.

Online Manuals For a list of available manuals, see the section TIBCO Spotfire S+
Books on page iv. To view a manual online, choose Help » Online
Manuals from the main menu and select the desired title.

Note: Online versions of the documentation

The online manuals are viewed using Adobe Acrobat Reader, which can be installed as an
option during the installation of Spotfire S+. It is generally useful to turn on bookmarks (under the
View entry of the menu bar) while using Acrobat Reader, rather than rely on the contents at the
start of the manuals. Bookmarks are always visible and can be expanded and collapsed to show
just chapter titles or to include section headings.




Tip of the Day

Spotfire S+ on
the Web

Training
Courses

Help, Support, and Learning Resources

To help speed your progress in Spotfire S+, a handy Tip of the Day
appears by default each time you start the program. (See Figure 1.2.)

Tip of the Day x|

Did you know...

*Y'ou can open an Excel worksheet inzide 5-PLUS. Choose
"Open' from the File menu, and set "Files of Type'' to "Excel
Wworksheets".

¥ Show tips on statup Previous tip Mext tip LS

Figure 1.2: A Tip of the Day.

You can also access the Spotfire S+ Tips of the Day at any time by
choosing Help » Tip of the Day from the main menu. If you prefer
to turn off this feature, simply clear the Show tips on startup check
box in the dialog.

You can find Spotfire S+ on the TIBCO Web site at www.tibco.com.
In these pages, you will find a variety of information, including:

+  FAQ pages.

* The most recent service packs.
* Training course information.

*  Product information.

e Information on classroom use and related educational
materials.

TIBCO Spotfire Educational Services offers a number of courses
designed to quickly make you efficient and effective at analyzing data
with Spotfire S+. The courses are taught by professional statisticians
and leaders in statistical fields. Courses feature a hands-on approach
to learning, dividing class time between lecture and online exercises.
All participants receive the educational materials used in the course,
including lecture notes, supplementary materials, and exercise data
on diskette.
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Technical
Support

Books Using
Spotfire S+
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TYPOGRAPHIC CONVENTIONS

Throughout this User’s Guide, the following typographic conventions
are used:

* This font is used for S-PLUS expressions and code samples.

+ This font is used for elements of the Spotfire S+ user
interface, for operating system files and commands, and for
user input in dialog fields.

*  This font is used for emphasis and book titles.

*  CAP/SMALLCAP letters are used for key names. For example,
the Shift key appears as SHIFT.

*  When more than one key must be pressed simultaneously, the
two key names appear with a hyphen (-) between them. For
example, the key combination of SHIFT and F1 appears as
SHIFT-F1.

*  Menu selections are shown in an abbreviated form using the
arrow symbol () to indicate a selection within a menu, as in
File » New.

12
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Chapter 2 Working With Data

INTRODUCTION

In Spotfire S+, the primary tool for viewing, editing, formatting, and
manipulating data is the Data window. It is similar to a spreadsheet
except that it is column-oriented rather than cell-oriented.

Figure 2.1 below shows the sample data set air displayed in a Data

window.
1 2 3 4 5 3‘
0Zone radiation emperature]  wind

1 34 190.00 &67.00 7.40

2 3.30 118.00 72.00 2.00

3 2.29 149,00 74.00 12.60

4 2.62 313.00 62,00 11.50

5 2.84 299.00 65.00 8.60

5] 2.67 99,00 59.00 13.80

7 2.00 19.00 61.00 20.10

8 2.52 256.00 £59.00 9.70

gl 2.22 290.00 66.00) 9.20
iLI oA 7FA 0N [=t=Nplnl A0 0 5 /

Figure 2.1: Sample data displayed in a Data window.

Note

Spotfire S+ ships with a number of sample data sets stored in internal databases. These data sets
are provided for your convenience while you are familiarizing yourself with Spotfire S+. To see
these sample data objects, do the following:

1. Open the Object Explorer by clicking the Object Explorer button k=] on the
Standard toolbar.

2. In the left pane of the Object Explorer, click the “+” sign to the left of the SearchPath
object to display the names of the databases in the search path.

3. Click the icon to the left of a database name (for example, data) to display all the objects
contained in that database in the right pane.

For a complete discussion of the Object Explorer, see Chapter 7, Working With Objects and
Databases.

14
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You can open any number of Data windows simultaneously to

display different data sets or to create concurrent views of a single
data set.

When you open a Data window, the Data window toolbar is
automatically displayed. The toolbar, shown in Figure 2.2, contains
buttons for quickly performing many frequently used editing

commands.
Remove
Remove Increase current link
Column Width Spotfire S+
Align  Align Decrease Insert Insert Clear Sort to Excel
Left Right  Precision Column Row Row Descending link wizard

B === | -mmni==s 2 2 EBOE G% &[splusBookl.Shi~
l l l | | I | I | | I
Convert Center Increase Change Clear Remove  Sort Decrease Active Link
to Data Precision  Data Column Row Ascending Width
Frame Type [Column Width to Update
Type Fit Data current link

Selector]

Figure 2.2: The Data window toolbar.

Note

For a complete discussion of the Excel section of the Data window toolbar, see Using the
Spotfire S+ to Excel Link Wizard on page 491.

In the following sections, we introduce the main features of the Data

window and provide step-by-step procedures for performing the most
common editing tasks.

15
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ENTERING, EDITING, AND SAVING DATA

Creating a
Data Set

16

There are a number of methods you can use to get data into Spotfire
S+. The easiest way is to import the data from another source, such as
Excel, Lotus, or SAS. The Data menu also provides a number of
options for generating data. For example, the Transform option
allows you to perform a series of operations on one column in a data
set and place the results in another column. The Commands window
is another powerful tool for generating data. By writing an expression
in the S-PLUS programming language, you can, for example, add two
columns together and place the results in a third column.

The most fundamental way to get data into Spotfire S+, of course, is
to simply type them in from the keyboard, the focus of this section.

To create a new data set, first open a new Data window by doing one
of the following:

«  Click the New Data Set button I3 on the Standard toolbar.

«  Click the New button L) on the Standard toolbar or choose
File » New from the main menu. In the New dialog, select
Data Set and click OK.

As shown in Figure 2.3, a new, empty Data window opens, named by
default SDFx (where x is a sequential number).

1 2 3 4 5 >
1
2
3
4
5
5]
7
8
gl
10 =
| ol

Figure 2.3: A new, empty Data window.
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To give your new data set a more appropriate name, do the following:
1. Double-click the top shaded cell in the upper left-hand corner
of the Data window. The Data Frame dialog opens, as
shown in Figure 2.4.

Data Frame [1] M= E
Mame: ISDF‘I Colar: I MGk v l

Default Col Type: Idouble =] T Bod
FEont: ITahoma 'l ™ Italics
Size: I‘ID

QK I Eancell Applyl I<| >| current Help |

Figure 2.4: The Data Frame dialog.

2. 'Type a new name in the Name text box and click OK.

Note

Valid data set names may include letters, numbers, and periods but must not start with a
number. Extended ASCII characters are not permitted.

You can also create a new data set and rename it at the same time by

using the Data menu:
From the main menu, choose Data P Select Data. The

1.
Select Data dialog opens, as shown in Figure 2.5.
Select Data M= EI
Source Existing D ata
& Existing Data lrﬂame: lﬁ
© Mew Data

Mew Data
" Impaort Fils ’7 =
[dame; I

[~ Show Dialog on Startup

QK I Eancell Applyl I<| >| current Help |

Figure 2.5: The Select Data dialog.

2. In the Source group, click the New Data radio button.

3. Inthe New Data group, type a name for the new data set in
the Name text box and click OK.

17
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Entering and
Editing Data

Typing data into a Data window is easy—just do the following:
1. Click the cell in which you want to enter a data value.
2. 'Type the value.
3. Press ENTER or an arrow key to enter the data in the cell.

Pressing ENTER enters the value in the cell and moves the cursor to
the next cell; the Spotfire S+ “smart cursor” feature moves the cursor
in the direction of the last movement. If you press an arrow key after
typing a data value, the cursor moves in the direction of the arrow.

Note

Spotfire S+ requires the columns of a data set to be of equal length and thus pads any shorter
columns it encounters with NAs.

18

When you enter data into a new, empty column, Spotfire S+ assigns
the column a type that most closely matches the type of data you
enter. The default column type for new columns is double (for
floating-point, double-precision real numbers). If you type character
data into an empty column, Spotfire S+ creates a factor column (for
categorical data).

To change the default column type for character data from factor to
character, do the following:

1. From the main menu, choose Options » General Settings
to open the General Settings dialog.

2. Click the Data tab to display the Data page of the dialog.



Undoing Actions

Entering, Editing, and Saving Data

3. Inthe Data Options group, select character from the
Default Text Col. dropdown list and click OK.

General Settings M= E
General | [rata | Startup | Computations |
—DataOptions——————— ~ ASCIl Import/Export Options
¥ Show Auto Created Data in View Import Delimiter: I
¥ Autoload Data Sets Export Defimiter: I

F#' Enable DataTips V' Show Imported Data in Yiew

v . .
F# Enable Smat (G 7 Prompt on import avenarite

[+ Buifer Data Entry — Dated/Time [nput

Doate format: IM.-"d.-"yyyy - l
Time format: Ih:mm:ss It VI

Drefault Text Col

— Excel Link
¥ Save link information —Date/Time Output—————————————
[+ Erompt on ovenwite Date format: IM".l‘:i".l‘i'l‘i'l"'l‘|r| jv

V¥ Bemove data on doc close Time format: Ih:mm:ss tt jv

¥ Eemove data on link close

™ Selection includes col names

™ Selection includes row names

Eancell Help |

Figure 2.6: Changing the default column type for character data.

After entering some values in a Data window, you may need to edit
them. To edit a value in a cell, do the following:

1. Click in the cell containing the value you want to edit.

2. Either press ENTER to go into edit mode or just start typing to
overwrite the current data.

To abandon your changes while typing, press ESC.
There are two levels of “undo” for the edits you make in a Data

window. You can either undo your most recent action or restore the
data set to its original state at the beginning of the session.

To undo your most recent action, do one of the following:

*  Press CTRL-Z or click the Undo button ¥ on the Standard
toolbar.

*  From the main menu, choose Edit » Undo.

19
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To restore a data set to its initial state, do the following:

1. Click the Restore Data Objects button ¥ on the Standard
toolbar or choose Edit » Restore Data Objects from the
main menu. The Restore Data Objects dialog opens, as
shown in Figure 2.7.

Restore Data Objects x|
Select objects to restore. Choose whether ta restore ta the

previous state or ko the initial state.
Click OF. to accept changes or CAMCEL to do nathing. Cancel |

[created)
[removed
[modified]

Deselect All Select All

For selected objects. ..

* Restore to Previous State = Restore to |nitial State

Figure 2.7: The Restore Data Objects dialog.

2. Select the data set from the list of objects displayed in the
dialog.

3. Click the Restore to Initial State radio button and then click
OK.

Note

You can also perform a single undo using the Restore Data Objects dialog. Simply select the
data set, click the Restore to Previous State radio button, and click OK.

To redo an undo, just perform one of the above procedures again.

Saving Data By saving your data in a special internal database, Spotfire S+
safeguards your data with no intervention required on your part. This
database, called the working data, is the database in which all the data
objects you create and modify, as well as all the functions you write in
the S-PLUS language, are automatically, and transparently, saved.

20
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You can easily view all the objects stored in your working data by
using the Object Explorer. For a complete discussion of the working
data and how to use the Object Explorer, see Chapter 7, Working
With Objects and Databases.

If you prefer more control over which new and modified data objects
you want Spotfire S+ to save, you can instruct Spotfire S+ to prompt
you with a dialog that gives you the opportunity to specify which
changes to keep and which to discard. This dialog appears when you
end your Spotfire S+ session.

To set this preference, do the following:

L.

General Settings

| o] x|

General | [rata | Startup | Computations |

— Prompts Closing Documents
V' Prompt to Save Graph Sheets

™ Prompt to Save Data Files

Bemove Data from Database

I Mever Remove l

— Automation
[V Echo ExecuteStingl]

¥ | Show ErecuteStingl] output

IV Send Missings as%T_ERROR

DDE Server Support
V¥ BRespond to DDE Requests

™ 0ld Format for DDE Fequest

V¥ Enable ToolTips
V' Color Toolbar
™ Large Buttons

¥ Enable Graph DataTips

Cancel |

Help |

Figure 2.8: The General page of the General Settings dialog.

From the main menu, choose Options » General Settings
to open the General Settings dialog.

In the Prompts Closing Documents group on the General
page of the dialog, select the Show Commit Dialog on Exit
check box and click OK.
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Setting this preference causes Spotfire S+ to automatically open the
Save Database Changes dialog, shown in Figure 2.9, whenever you
end a session in which you have created or modified any data objects.

Save Database Changes x|

The follawing database ohjects have been created or modified
during this zezzion. Current versions of selected objects will be —

zaved in the database. Cancel |

Deselect All Select All

¥ Display Dialog On Exit

Figure 2.9: The Save Database Changes dialog.

By default, all the data objects created or modified during the current
session are selected in the Save Database Changes dialog. For each
data set in the list, do one of the following and then click OK:

+ To save a new data set or a changed version of an existing
data set, leave its name highlighted.

* To discard a new data set or any changes made to an existing
data set, CTRL-click its name to deselect it.

Note

After setting this option in the General Settings dialog, you can later disable it by clearing the
Display Dialog On Exit check box in the Save Database Changes dialog.

Saving Your Data
in External Files

22

Of course, you can remove a data object from your working data at
any time during a session by using the Object Explorer. For
complete details on using the Object Explorer, see Chapter 7.

The easiest and most efficient way to save your data sets is to let
Spotfire S+ save them for you, as discussed above. Allowing Spotfire
S+ to store your data objects in the working data puts all the power of
the Object Explorer at your disposal.
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However, as with other standard Windows products, Spotfire S+ does
allow you to save your data sets in external (*.sdd) files by using the
File menu. Although we do not recommend this approach, if you
prefer to manage your data this way, you will need to reset some
option defaults, as follows:

1. Open the General Settings dialog to the General page, as
described above.

2. In the Prompts Closing Documents group, do the
following:

*  Select the Prompt to Save Data Files check box.

* In the Remove Data from Database dropdown list,
select Always Remove Data.

3. Click OK.

Setting these preferences causes Spotfire S+ to prompt you with the
following message whenever you close a Data window displaying a
new or modified data set:

5-PLUS B3

& Save changes to SDFT in a file?

Mo | Cancel |

Clicking Yes in the dialog opens the Save Data Set As dialog. To
save your data in a file, simply name the data set, navigate to the
desired folder, and click Save.
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VIEWING AND FORMATTING DATA

Displaying a
Data Set

As mentioned earlier, Spotfire S+ ships with a large number of
sample data sets for your use in exploring Spotfire S+. You can
display any of these data sets, as well as any of your own data sets
stored in the working data, by using the Select Data dialog.

To display a data set stored in an S-PLUS database, do the following:
1. From the main menu, choose Data P Select Data. The
Select Data dialog opens, as shown in Figure 2.10.

Select Data M= EI

Source Existing D ata
& Existing Data lrﬂame: I 'l

© Mew Data
Mew Data

" Impaort Fils ’7 =
[dame; I

[~ Show Dialog on Startup

QK I Eancell Applyl I<| >| current Help |

Figure 2.10: The Select Data dialog.

In the Source group, the Existing Data radio button is
selected by default.

2. Inthe Name field of the Existing Data group, either type the
name of the data set you want to open or select its name from
the dropdown list and click OK.

Hint

Databases.

You can also display a data set by double-clicking its name in the Object Explorer. For a
detailed discussion of the Object Explorer, see Chapter 7, Working With Objects and
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The data set last opened in a Data window (or last selected in the
Object Explorer) is referred to as the current data set. To change the
current data set, click in the Data window of the data set you want to
make current or select it from the list at the bottom of the Window
menu. When no data set is explicitly referenced in an operation, the
current data set is the default.
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Opening For large data sets, it is often convenient to display several different
Concurrent Views views of the data in separate Data windows.

of a Data Set To open concurrent views of a data set, do the following:

1. Use the Select Data dialog to display the data in a Data
window.

2. From the main menu, choose Window » New Window.

Note

You can edit your data in the original or any replicated Data window. Any changes you make
are immediately reflected in all the Data windows.

The name of the data set, as it appears in the title bar of the original
Data window, becomes temporarily appended with :1. In the second
Data window, the name is appended with :2. This temporary naming
convention continues as additional windows are opened. However,
when you close the replicated windows, the original name of the data
set is restored.

Navigating a Data Spotfire S+ provides a number of useful keyboard and mouse

Window shortcuts for quickly navigating a Data window. These shortcuts are
listed in Table 2.1 below.

Table 2.1: Keyboard and mouse shortcuts for navigating a Data window.

Action Keyboard Mouse

Moves the screen left. CTRL-LEFT ARROW Click left scroll bar arrow.
Moves the screen right. CTRL-RIGHT ARROW Click right scroll bar arrow.
Moves to first column, first row. CTRL-HOME Drag sliders to top and left

arrows and click the cell.

Moves to last column, last row. CTRL-END Drag sliders to bottom and
right arrows and click the
cell.

25
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Table 2.1: Keyboard and mouse shortcuts for navigating a Data window. (Continued)

Action Keyboard Mouse

Moves to first column, same row. HOME Drag horizontal slider to left
arrow and click the cell.

Moves to last column, same row. END Drag horizontal slider to

right arrow and click the
cell.

Moves to first row, current column.

CTRL-PAGE UP

Drag vertical slider to top
arrow and click the cell.

Moves to last row, current column.

CTRL-PAGE DOWN

Drag vertical slider to
bottom arrow and click the
cell.

Selects a column.

CTRL-SPACEBAR

Click the column header.

Selects a row.

SHIFT-SPACEBAR

Click the row header.

Selects the entire Data window.

CTRL-SHIFT-SPACEBAR
or CTRL-A

Click the top cell in the
upper left-hand corner of the
Data window.

Puts cursor in selection mode and
moves cursor to make block
selection.

SHIFT-ARROW KEYS

Click and drag the mouse
across cells.

Displays online help.

F1

Click the Help button &2
on the Standard toolbar
and then click in the Data
window.

Displays the Go To Cell dialog.

F5

From the main menu,
choose View » Go To Cell.

Puts cursor in edit mode to edit the
column name.

F9

Double-click the name box
of the column header.

26
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The Go To Cell dialog makes it easy to jump to a specific cell
location in a Data window.

1. Press F5 or choose View P Go To Cell from the main menu.
The Go To Cell dialog opens, as shown in Figure 2.11.

Go To Cell x|
Colurnm: IEUF!F!ENT| VI
Row: IEUHHENT vl

QK I Eancell Help |

Figure 2.11: The Go To Cell dialog.

2. Select the column name and enter the row number of the cell
you want to jump to. To go to the last column/last row
position, type or select the special key word END in the
Column and Row fields.

3. Click OK.

The Go To Cell dialog is also useful for extending a cell selection. To
extend a selection from the active cell to the location specified in the
dialog, simply hold down the SHIFT key while clicking OK. For
example, if column 1, row 5 is the active cell and you specify column
5, row 5 in the Go To Cell dialog and press SHIFT-OK, the selection
is extended from column 1, row 5 to column 5, row 5.

Customizing a You can customize a Data window to fit your formatting preferences
Data Window by using the Data Frame dialog, as shown in Figure 2.12. To open
the dialog, do one of the following:

*  Double-click the top shaded cell in the upper left-hand corner
of the Data window.
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Setting Your
Preferred
Defaults

Selecting Data

28

*  With the Data window in focus, choose Format P Sheet
from the main menu.

Data Frame [1] M= E
Mame: ISDF‘I Colar: I MGk v l

Default Col Type: Idouble =] T Bod
FEont: ITahoma 'l ™ Italics
Size: I‘ID

QK I Eancell Applyl I<| >| current Help |

Figure 2.12: The Data Frame dialog.

You can use this dialog to rename your data set, to change the default
type for new columns, or to specify the font, font size, and other
formatting characteristics of the Data window.

When you open a new, empty Data window, its formatting is based
on a set of defaults. For example, the default type for new columns is
doubTle, a type of numeric data. By using the Data Frame dialog, you
can change these default settings so that any new Data windows you
open will reflect your particular formatting preferences.

To set new defaults, first make any desired changes in the Data
Frame dialog for an open Data window and click OK to accept the
changes. Then do one of the following:

* From the main menu, choose Options » Save Window
Size/Properties as Default.

* Right-click the top shaded cell in the upper left-hand corner
of the Data window and select Save Data Frame as default.

In order to format or manipulate data, you must first select the data
on which to operate. You can select a single cell, a block of cells, or
one or more columns or rows. By first selecting your data in a Data
window, you can also limit the scope of some menu options.
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Selecting Cells To select a single cell, click in the cell you want to select.
and Blocks

To select a block of cells, do one of the following:

*  Press and hold down the mouse button in the cell where you
want to begin the block selection and then drag the cursor to
increase or decrease the size of the highlighted block. When
the desired area is highlighted, release the mouse button.

*  Click in the cell where you want to begin the block selection
and then SHIFT-click in the cell whose column and row
positions describe the block you want to select.

Hint

You can extend a cell selection by holding down the SHIFT key while pressing one of the arrow
keys.

To select all the cells in a Data window, click in the empty, shaded
area in the upper left-hand corner of the Data window.

Selecting To select a single column or row, click in the column or row header.
Columns and

R To select a block of contiguous columns or rows, do one of the
OowS

following:

*  Click in the column or row header of the first column or row
to begin the selection and then SHIFT-click in the column or
row header of the last column or row describing the block you
want to select.

*  Press and hold down the mouse button in the column or row
header of the first column or row to begin the selection and
then drag the cursor across the columns or rows you want to
select and release the mouse button.

To select a group of noncontiguous columns or rows, or to select a
group of columns or rows in a special order, do the following:

*  CTRL-click in the header of each column or row you want to
select in the order in which you want to make the selection.
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Special note

The key characteristic of CTRL-click selection is that it imposes order on the selection process. By
contrast, when dragging the cursor or using SHIFT-click, the order of selection is interpreted by
default as left to right for columns or top to bottom for rows, no matter how the action itself is
actually performed. Therefore, when using these methods to select data, keep the following

points in mind:

*  You must use CTRL-click when you need to select noncontiguous columns or rows, but
be conscious of the order in which you make your selections.

*  You must use CTRL-click when you need to select a group of columns or rows in a
specific order even if the columns or rows are contiguous.

*  You can drag the cursor or use SHIFT-click to select blocks of contiguous columns or
rows as long as a left-to-right or top-to-bottom selection order is what you intend.

Formatting
Columns

Changing a
Column Name

30

A column in a data set is a vertical group of cells that typically
contains the data for a given variable. Because Spotfire S+ is column-
oriented, formatting and data manipulation tools operate on a column
as a unit.

Spotfire S+ automatically numbers each column in a data set. The
column number is displayed in the column header and indicates the
column’s position in the Data window.

As soon as you enter a data value in an empty column, Spotfire S+
automatically gives the column a default name (Vx, where x is a
sequential number), which is displayed in the header beneath the
column number. You can use the default names to refer to your
columns, but it is usually better to replace them with names that are
more descriptive.

Tips for naming your columns
*  Column names must be unique within a data set.

*  Column names must start with a letter and may contain any
combination of letters, numbers, and periods. However,
column names may not include extended ASCII characters,
such as E.
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« S-PLUS function names and other reserved words cannot be
used as column names.

While you can refer to columns by either their names or their
numbers, referring to them by name is often easier since some
operations cause columns to be renumbered. For example, if you
insert a column between columns 5 and 6, all columns to the right of
column 5 are renumbered. If you use numbers to refer to your
columns, you must remember to use the new numbers in subsequent
operations.

To change a column name in place, do the following:

1. Double-click in the name box of the column header or, with
any cell in the column active, press F9.

2. 'Type a new column name or edit the existing name.

3. Press ENTER or click elsewhere in the Data window to accept
the changes.

To change a column name by using its properties dialog, do the
following:

1. Double-click in the number box of the column header or click
in the column and choose Format P> Selected Object from
the main menu. The column properties dialog opens, as
shown in Figure 2.13.

Double Precizion Column [1] M= E
Mame: ] FEormat Type: I Decimal - l
width: |1 2 FPrecision: |2

Justification: I Right = l

Description: I

QK I Eancell Applyl I<| >| current Help |

Figure 2.13: The Double Precision Column dialog.

2. In the Name text box, type a new column name or edit the
existing name and click OK.
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Note

columns, etc.

The name of a properties dialog, as it appears in the dialog’s title bar, is determined by the type
of object selected when you open the dialog. For example, the Double Precision Column
dialog opens for double precision columns, the Character Column dialog opens for character

Adding or Editing In addition to numbers and names, columns can also have

a Column
Description

Creating a
Column List

32

descriptions. If you specify a description for a column, the description
is used as the default axis title and legend text in graphs. If no
description is specified, the column name is used instead.

Tips for specifying column descriptions
*  Column descriptions can contain up to 75 characters.

*  Column descriptions can be any combination of letters,
numbers, symbols, and spaces.

To add or edit a column description, do the following:

*  Open the column properties dialog as discussed on page 31.
In the Description text box, type a new column description
or edit the existing description and click OK.

If you pause your mouse cursor over the name box in the column
header, a DataTip displays the column description, as shown in
Figure 2.14.

ﬁ fuel frame H=]1E3
1 2 3 4 5 6 =
Weight Disp. Mileage §  Fuel Type

1 Eagle Summit 4 2560.0 97.00 33.0{Miles Per Gallon/Highway}nall

2 Ford Escort 4 2343.00 114.00 23.00 3.03 Srnall

3 Ford Festiva 4 1845.00 £81.00 27.00 2,70 Srnall
Dlmimd = Shim A S o I alnl R lnl oA e 1| hd
KNS ol

Figure 2.14: A DataTip displays the column description.

A column list is a list of column names or numbers in a dialog field
specifying a group or sequence of columns on which to operate. For
example, selecting the column names Weight and Type produces the

column list Weight,Type.
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To create a column list, simply select the column names (using CTRL-
click if necessary) from the dialog field’s dropdown list.

Note

Dialog fields display only column names, not column numbers.

You can also create a column list in a dialog field by typing the
column numbers separated by commas. For example, 1,3,4 refers to
columns 1, 3, and 4. To specify a sequence of columns, type the
beginning and ending column names or numbers separated by a
colon. For example, 3:7 refers to columns 3 through 7. To specify all
columns in a data set, select the special key word <ALL>.

Changing the To increase or decrease a column’s width by visual inspection, you
Column Width can either drag the cursor or use a toolbar button.
To change the column width by dragging, do the following:

1. Position the cursor on the vertical line to the right of the
column heading. The mouse pointer becomes a resize tool.

1 2

wieight < Disp.
2560.0 97.00
2345.00 114.00

2. Drag the resize tool to the right to increase the width of the
column (or to the left to decrease the width).

To change the column width using a toolbar button, do the following:

1. Click in the column.

9. Click the Increase Width button &3 or the Decrease Width

button & on the Data window toolbar. Each click increases
or decreases the column width by one character.

To adjust the column width to fit the widest cell in the column, do the
following:

1. Click in the column.

9. Click the Width to Fit Data button B on the Data window
toolbar.

33



Chapter 2 Working With Data

Changing the
Data Type
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If you need to set an exact column width, open the column properties
dialog and specify the width you want in terms of the number of
characters in the default font and point size.

A column’s data type determines the type of data you can enter in
that column. For example, a column of type character accepts only
character data, while a column of type integer accepts only integer
data.

The S-PLUS data types are character, complex, double, factor,
integer, Togical, single, and timeDate. The two most commonly
used data types are double (for floating-point, double-precision real
numbers) and factor (for categorical data). For a detailed discussion
of the S-PLUS data types, see the Programmer’s Guide.

To change the data type of a column, do the following:
1. Click in the column and then click the Change Data Type

button ¥ on the Data window toolbar or choose Data, P
Change Data Type from the main menu. The Change Data
Type dialog opens, as shown in Figure 2.15.

Change Data Type M= E
Fraom Type

Data Set: ISDF‘I VI Current Type: Idouble
Lolumns: al - Hew Type: I VI

QK I Eancell Applyl I<| >| current Help |

Figure 2.15: The Change Data Type dialog.

2. In the Type group, select a new data type from the New
Type dropdown list and click OK.
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Format Type

Changing the
Display Precision
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Preferred
Defaults
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If you pause your mouse cursor over the number box in the column
header, a DataTip displays the column type, as shown in Figure 2.16.

ﬁ fuel frame H=]1E3

1 2 3 4 5 6 =

Weight Disp. Mileage Fuel Type Lfactor
1 Eagle Summit 4 2360.0 oF.00 33.00 3.03 Srmall
2 Ford Escort 4 2345.00 114.00 33.00 3.03 Srmall
3 Ford Festiva 4 1845.00 81.00 37.00 2.70 Srmall
VlmamA = i A STIE O i [nk Ml Eala il R Kl (a1 | il
KNS ol

Figure 2.16: A DataTip displays the column type.

Spotfire S+ uses the standard Windows format types for columns
containing numeric data: Mixed, Number, Decimal, Scientific,
Currency, Financial, Date, Date&Time, Time, and
Elapsed_H:M:S.

To change the format type of a column, do the following:

*  Open the column properties dialog as discussed on page 31.
Select a different format type from the Format Type
dropdown list and click OK.

A column’s display precision affects only the way numbers are
displayed; it has no effect on internal computations, which always use
the maximum precision available.

To change the display precision of a column, do one of the following:
+ To increase or decrease the display precision, click in the
+.0
column and then click the Increase Precision button i or

the Decrease Precision button 4, respectively, on the Data
window toolbar.

*  Open the column properties dialog as discussed on page 31.
In the Precision text box, type the desired number of digits to
be displayed after the decimal (the maximum number

allowed is 17) and click OK.

You can change your column default settings for justification,
precision, width, etc. to reflect your formatting preferences. For
example, you might prefer to have a different default width for
character columns than for numeric columns.
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Formatting
Rows

Adding or
Changing a Row
Name

Creating a Row
List
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To set your preferred column defaults, do the following:
1. Open the column properties dialog as discussed on page 31.

2. Make any changes that you want to retain as your new default
settings and click OK.

3. Right-click in the column and select Save [Column Type]
Column as default from the shortcut menu.

Spotfire S+ automatically numbers each row in a data set. The row
number is displayed in the row header and indicates the row’s
position in the Data window. Because Spotfire S+ is column-oriented,
most formatting options apply only to columns. You can, however,
add names to your rows.

When used, row names are displayed in the header to the right of the
row numbers.

To add or change a row name, do the following:
1. Double-click in the name box of the row header.
2. 'Type a row name or edit the existing name.

3. Press ENTER or click elsewhere in the Data window to accept
the changes.

A row list is a list of row numbers in a dialog field specifying a group
or sequence of rows on which to operate. To create a row list, type the
row numbers separated by commas. For example, 1,3,4 refers to rows
1, 3, and 4. To specify a sequence of rows, type the beginning and
ending row numbers separated by a colon. For example, 3:7 refers to
rows 3 through 7. To specify all rows in a data set, type the special key
word <ALL>.
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MANIPULATING DATA

Spotfire S+ provides a wide assortment of data manipulation tools.
Buttons on the Data window toolbar are convenient for performing
the most common tasks, but many more options are available
through the Data menu.

Moving and You can move or copy data within a Data window or between

Copying Data different Data windows by using a variety of techniques, discussed
below.

Moving and To move or copy a cell or block of cells by dragging, do the

Copying Cells and following:

Blocks 1. Select the cell or block of cells you want to move or copy.

2. Position the cursor within the selected cell or block. The
cursor becomes an arrow, as shown in Figure 2.17.

ﬁelhanol H=]1E3
1 2 3 4 S
MO © E

1 374 12,00 0.91

2 2.2 12,00 0.76

3 12,00 1.11

4 12,00 1.02

5 0.76 12,00 1.19

il 3.12 9.00 1.00

7 0.64 9.00 1.23 -

<I I 3 4

Figure 2.17: Selecting a block of cells in a Data window.
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3. Drag the selected cell or block to the new location. To move
the cell or block, simply release the mouse button. To copy
the cell or block, press and hold down the CTRL key while
releasing the mouse button. See Figure 2.18.

Note

Moving or copying data to a target location that already contains data overwrites the existing
data. Also note that when you move a block of cells, Spotfire S+ fills the empty cells in the old
location with NAs, which denote missing values.

il ethanol 1 =] il ethanol =]
1 2 E] 4 B E 1 2 3 4 = E
NOx c E MO C E

1 3.74 12,00 CET N 1 3.74 12,00 N

2 2.2 12.00 076 2 2.2 12.00 07e e

3 12.00 111 3 12.00 111

4 12,00 1.02 4 12,00 1.02

5 0.76 12,00 119 5 0.76 12,00 119

& ERE 5.00 1.00 & ERE 5.00 1.00

7 0.64 5.00 1.23 - 7 0.64 .00 1.23 -

K| H 4 K| 0

Figure 2.18: Moving (above lefi) and copying (above right) a block of cells in a Data window.

Hint

When you use drag-and-drop to move or copy data between Data windows, be sure to arrange
your windows so that you can see both the source and the target cell locations.

To move or copy a cell or block of cells using Cut, Copy, and Paste,
do the following:

1. Select the cell or block of cells you want to move or copy.
2. Do one of the following:
* To move the cell or block, press CTRL-X, or click the Cut

button & on the Standard toolbar, or choose Cut from
the Edit or shortcut menu.
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* To copy the cell or block, press CTRL-C, or click the

Copy button 5= on the Standard toolbar, or choose
Copy from the Edit or shortcut menu.

3. Click the mouse in the new location in the Data window.

4. Press CTRL-V, or click the Paste button B2 on the Standard
toolbar, or choose Paste from the Edit or shortcut menu.

To move or copy a cell or block of cells using the Data menu, do the
following:

1. From the main menu, choose Data » Move P Block to
move the cell or block or Data » Copy P Block to copy the
cell or block. Depending upon your selection, either the
Move Block or Copy Block dialog opens, as shown in

Figure 2.19.
Move Block !E Copy Block !E
Fram Tao Fram Tao
Data Set: Iethanol 'I [rata Set: Iethano\ - Data Set: Iethanol 'I [rata Set: Iethano\ -
Colurnns: MNO= - Calurnns: |<END> - Colurnns: MNO= - Calurnns: |<END> -
Rows: |2 4 Rows: IW 3 Rows: |2 4 Rows: IW 3
Cancel | apply |1 >l curtent Help Cancel | dpply | 1< >l curtent Help

Figure 2.19: The Move Block and Copy Block dialogs.

2. In the Columns and Rows fields of the From group, specify
by column and row positions the cell or block of cells you
want to move or copy.

3. In the Columns and Rows fields of the To group, specify the
target location by column and row positions and click OK.

Hint

To move or copy the cell or block to another data set, select its name from the Data Set
dropdown list of the To group. To create a target data set, type a new name in this field.

Moving and The procedures for moving and copying columns and rows are the
Copying Columns same as those outlined above for moving and copying cells and
and Rows blocks, with the following additional comments.
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Move Columns

When you move or copy a column or row by dragging, note the
following:

To drag a column or row, position the cursor within the
selected column or row, not within the column or row header.

Spotfire S+ moves or copies the whole column or row as a
unit, including the name. Names of copied columns and rows
are appended with . 1.

Moving or copying data to a target location that already
contains data overwrites the existing data.

When you move or copy a column or row using Cut, Copy, and
Paste, note the following:

Spotfire S+ moves or copies only the data values in the
column or row to the new location.

Moving or copying data to a target location that already
contains data overwrites the existing data.

As shown in Figure 2.20, the Data menu dialogs for moving and
copying columns and rows are very similar to those for cells and

blocks.

From
Data Set
Columns:

NOx ~

Ta
Iethannl vl ’7Da_ta Set:

Columns:

v Dverwiite

Eancell Apply ¢} >l curment

Move Rows

Fram
Data Set
BRows:

Tao
Iethannl vI ’7Da_ta Set:

e —

Rows:

v Dverwiite

Eancell Apply ¢} >l curment

M= Copy Columns M=
From Ta
Iethann\ - Data Set Iethannl vl Drata Set: Iethann\ -
|<END> - Columns: MNO= - Columns: |<END> -
v Dvenwrite:
Help Cancel | Apply 2] >l curent Help
M= Copy Rows M=
Fram Tao
Iethann\ - Data Set Iethannl vI Data Set Iethann\ -
|<END> BRows: IT Rows: |<END>
v Dvenwrite:
Help Cancel | Apply 2] >l curent Help

Figure 2.20: The Move Columns, Copy Columns, Move Rows, and Copy Rows dialogs.
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the following:
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* Spotfire S+ moves or copies the whole column or row as a
unit, including the name. Names of copied columns and rows
are appended with . 1.

* By default, moving or copying data to a target location that
already contains data overwrites the existing data. However,
you can avoid overwriting your existing data by clearing the
Overwrite check box at the bottom of the dialogs. When you
clear this check box, Spotfire S+ shifts existing columns to the
right or existing rows down to make room for the moved or
copied data.

Hint

You can copy row names into and out of the shaded row names column in a Data window by
using the Copy Columns dialog—simply select the special key word <KROWNAMES> from the
Columns dropdown list in either the From or To group.

Inserting Data When you insert a cell, block, column, or row in a Data window,
Spotfire S+ shifts existing cells down and/or to the right, as
appropriate, to make room for the new cells.

Inserting Cells To insert a cell or block of cells, do the following:

and Blocks *  From the main menu, choose Insert » Block. The Insert

Block dialog opens, as shown in Figure 2.21.

Ingert Block M= EI
To
[rata Set: Iethanol VI
Columms: MOx -

Flows: |2:4
QK I Eancell Applyl I<| >| current Help |

Figure 2.21: The Insert Block dialog.

In the Columns and Rows fields, specify by column and row
positions the cell or block of cells you want to insert and click

OK.
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Inserting To insert a column, do one of the following:

Columns *  Click in the column you want to have shifted to the right to

make room for the new column. To insert a new column of
the default type, or of the same type as the last new column

inserted, click the Insert Column button W 61 the Data
window toolbar. To insert a new column of a specific type,
click the column type selector arrow located to the right of the
Insert Column button (see Figure 2.22) and select the type of
column you want to insert.

=]
b L ) LR e 21 %) | B B3 BI| G = % [No Active Link =~
character

complex
v double

factar
integer
logical
single
timel) ate:

Figure 2.22: Inserting a column of a specific type.

*  From the main menu, choose Insert » Column. The Insert
Columns dialog opens, as shown in Figure 2.23.

Insert Columns 5] x|

Mame(z] IHesuIts

Fill Expression: I

Start Column: MOx - Count: |1
[rata Set: Iethanol VI Column Type: Idouble VI

QK I Eancell Applyl I<| >| current Help |

Figure 2.23: The Insert Columns dialog.
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Select the column you want to have shifted to the right to
make room for the new column from the Start Column
dropdown list. Type a name for the new column in the
Name(s) text box and click OK.

Hint

You can also use the Insert Columns dialog to insert multiple columns. Simply type the number
of columns you want to insert in the Count text box and a comma-delimited list of names in the
Names(s) text box.

Inserting Rows  To insert a row, do one of the following:
+  Click in the row you want to have shifted down to make room

for the new row and then click the Insert Row button == on
the Data window toolbar.

*  From the main menu, choose Insert » Row. The Insert
Rows dialog opens, as shown in Figure 2.24.

Insert Rows M= EI
[rata Set: Iethanol VI Start Fow: |3
Count: |1

QK I Eancell Applyl I<| >| current Help |

Figure 2.24: The Insert Rows dialog.

In the Start Row text box, type the row number of the row
you want to have shifted down to make room for the new row

and click OK.

Hint

You can also use the Insert Rows dialog to insert multiple rows. Simply type the number of
rows you want to insert in the Count text box.
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Deleting Data  When deleting data in a Data window, you can either clear the data
values, leaving the cells intact, or you can remove both the cells and
their contents and shrink the size of the data set. Note that when you
clear data, Spotfire S+ replaces the values in the cells with NAs, which
denote missing values.

Note

When you clear a cell, block, column, or row by pressing the DELETE key or by choosing Clear
from the Edit or shortcut menu, the data are not placed in the clipboard. To erase the data and
place them in the clipboard, choose Cut instead.

Clearing and To clear a cell or block of cells, do one of the following:

Removing Cells Select the cell or block of cells and choose Clear from the

and Blocks Edit or shortcut menu.
*  From the main menu, choose Data » Clear » Block. The
Clear Block dialog opens, as shown in Figure 2.25.
Clear Block M= EI
From
Data Set: lm
Lolumns: MOx -
Blows: |24—
QK I Cancel | Apply | I<| >| current Help |
Figure 2.25: The Clear Block dialog.
In the Columns and Rows fields, specify by column and row
positions the cell or block of cells you want to clear and click
OK.
Hint

To clear all the data in a Data window, click in the empty, shaded area in the upper left-hand
corner of the Data window to select all the data in the data set and then choose Clear from the
Edit or shortcut menu.

To remove a cell or block of cells, do one of the following:
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Select the cell or block of cells and then press the DELETE key
or choose Cut from the Edit or shortcut menu.

From the main menu, choose Data » Remove P Block. The
Remove Block dialog opens, as shown in Figure 2.26.

Remove Block
From

Data Set:
Lolumns:

Blows:

Iethanol - l

MHOx -

—

| o] x|

ak. I Eancell Applyl I<| >| cLment

Help |

Figure 2.26: The Remove Block dialog.

Clearing and
Removing
Columns

In the Columns and Rows fields, specify by column and row
positions the cell or block of cells you want to remove and

click OK.

Clearing a column deletes the data in the column but otherwise
leaves the column’s position, name, and formatting information

intact.

To clear a column, do one of the following:

Click in the column and then click the Clear Column button

i on the Data window toolbar.

Select the column and choose Clear from the Edit or shortcut
menu.

From the main menu, choose Data P Clear » Column. The
Clear Columns dialog opens, as shown in Figure 2.27.

Clear Columns

From
Data Set: Iethanol - l
Lolumns: MOx -

| o] x|

ak. I Eancell Applyl I<| >| cLment

Help |

Figure 2.27: The Clear Columns dialog.

Select the column you want to clear from the Columns

dropdown list and click OK.
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Removing a column deletes the entire column and shrinks the size of
the data set.

To remove a column, do one of the following:
e Click in the column and then click the Remove Column
button Il on the Data window toolbar.

*  Select the column and then press the DELETE key or choose
Cut from the Edit or shortcut menu.

*  From the main menu, choose Data » Remove » Column.
The Remove Columns dialog opens, as shown in Figure

Remove Columns M= EI
From
Data Set: Iethanol VI
Lolumns: MOx -

QK I Eancell Applyl I<| >| current Help |

Figure 2.28: The Remove Columns dialog.

Select the column you want to remove from the Columns
dropdown list and click OK.

Clearing and Clearing a row deletes the data in the row but otherwise leaves the
Removing Rows  row’s position and name, if any, intact.
To clear a row, do one of the following:
*  Click in the row and then click the Clear Row button = on
the Data window toolbar.

e  Select the row and choose Clear from the Edit or shortcut
menu.
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*  From the main menu, choose Data P Clear » Row. The
Clear Rows dialog opens, as shown in Figure 2.29.

Clear Rows =10 =]
From
Data Set: Iethanol VI
Blows: |3
ak. I Eancell Apply | I<| >| cLment Help |

Figure 2.29: The Clear Rows dialog.
Type the row number of the row you want to clear in the
Rows text box and click OK.

Removing a row deletes the entire row and shrinks the size of the data
set.

To remove a row, do one of the following:
*  Click in the row and then click the Remove Row button =
on the Data window toolbar.

*  Select the row and then press the DELETE key or choose Cut
from the Edit or shortcut menu.

*  From the main menu, choose Data » Remove » Row. The
Remove Rows dialog opens, as shown in Figure 2.30.

Remove Rows 5] x|
From
Data Set: Iethanol VI
Blows: |3
ak. I Eancell Apply | I<| >| cLment Help |

Figure 2.30: The Remove Rows dialog.

Type the row number of the row you want to remove in the
Rows text box and click OK.

Spotfire S+ provides toolbar buttons for performing quick sorts on
whole data sets, as well as a dialog that allows you to customize your
sorting parameters.
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Quick Sorts To quickly sort all the columns of a data set in place by the column
containing the active cell, do the following:

*  Click in the column you want to sort by and then click the
Sort Ascending button 2} or the Sort Descending button

z
Al, as appropriate, on the Data window toolbar.

Customized Sorts For greater control in specifying your sorting parameters, use the Sort
Columns dialog available through the Data menu. The dialog allows
you to:

*  Specify whether to sort the entire data set or a subset of its
columns.

* Select more than one column to sort by. When specifying
multiple columns to sort by, the data are first ranked
according to the first column selected. Then, in the case of
equivalent data, the column next selected determines the
ranking, and so on.

+  Specify a different data set or column(s) in which to store the
sort results if you want to avoid overwriting your original
data.

To perform a customized sort, do the following:

1. From the main menu, choose Data » Restructure » Sort.
The Sort Columns dialog opens, as shown in Figure 2.31.

Sort Columns ==
From To

Data Set: Iethanol VI [rata Set: Iethanol VI
Lolumns: |<ALL> - l Columms: |<ALL> - l
Sort By Columns: INDH,E VI I Ioescenting

QK I Eancell Applyl I<| >| current Help |

Figure 2.31: The Sort Columns dialog.

2. In the From group, select the columns you want to sort from
the Columns dropdown list. To sort all the columns in the
data set, select the special key word <ALL>.
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3. Select one or more columns to sort by from the Sort By
Columns dropdown list. To sort by more than one column,
CTRL-click to select the columns in the desired ranking order.

4. In the To group, specify a target destination for the sort
results:

+ To sort in place, select the same data set and columns
from the Data Set and Columns dropdown lists,
respectively, as you selected in the corresponding From

group fields.

Caution

Mismatched columns may result when sorting in place with fewer than <ALL> columns selected
in the Columns fields.

* To send the sort results to a different data set, select a data
set from the Data Set dropdown list (or type a new name
in this field to create a data set) and select the desired
columns from the Columns dropdown list.

Note

The number of columns selected in the To group must match the number of columns selected in
the From group. Note also that existing data in target columns will be overwritten.

5. By default, columns are sorted in ascending order. To sort in
descending order, select the Descending check box.

6. Click OK.

Other Data In addition to the basic tools discussed so far, the Data menu
Manipulation provides many more useful data manipulation options. What follows
is a brief description of those not already covered. Chapter 6 gives
examples using the Random Numbers, Distribution Functions,
Tabulate, and Random Sample tools. For details on using all the
data manipulation dialogs, see the online help.

Options

49



Chapter 2 Working With Data

Transpose

Exchange

Restructure

Fill

Recode

Transform

Create Categories

Random Numbers

50

The Transpose Columns and Transpose Rows dialogs allow you
to convert columns to rows and vice versa. Use the Transpose Block
dialog to transpose a block of text (that is, turn the block on its side).

The Exchange Columns and Exchange Rows dialogs let you trade
the positions of columns or rows between different data sets.
Append

The Append Columns dialog can be used to append a column of
data to the end of another column.

Pack

The Pack Columns dialog allows you to delete missing values in a
column and shift the remaining values up to close the space.

Stack

The Stack Columns dialog lets you stack separate columns of data
into a single column, with the values in the other columns replicated
as necessary.

Unstack

The Unstack Columns dialog can be used to break up a single
column into several columns of specified lengths.

The Fill Numeric Columns dialog allows you to fill columns in a
data set with NAs or with a series of generated numbers.

The Recode dialog lets you recode all occurrences of a specific value
in specified columns to a new value.

The Transform dialog can be used to create a new variable based on
a transformation of other variables.

The Create Categories dialog allows you to create new categorical
variables from numeric (continuous) variables or to redefine existing
categorical variables by renaming or combining groups.

The Random Numbers dialog lets you generate random numbers
from a specified distribution.
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The Distribution Functions dialog can be used to compute density
values, cumulative probabilities, and quantiles from a specified
distribution.

The Split Data by Group dialog allows you to split a data set into
multiple new data sets based on the values of a splitting variable.

The Subset dialog lets you create a subset of a data set based on a
subsetting expression. While the dialog provides tools for helping you
write this expression, some knowledge of S-PLUS language syntax is
required.

The Merge Two Data Sets dialog can be used to combine data from
two data sets into a single data set.

The Tabulate dialog allows you to create a tabular summary of data
from a data set. Selected columns of the data set are identified as
variables, and the count of each combination of variable values is
returned. Numeric variables can be binned before the counting
occurs.

The table of the counts can be printed and also returned in a data set
suitable for multipanel conditioning plots. For statistics and other
summary information, choose Statistics » Data Summaries »
Crosstabulations.

The Expand Grid dialog lets you create a new data set containing all
combinations of sets of values in an existing data set. Each set of
values may be either all unique values in a column or a specified
number of equispaced values covering the range of values in a
column. This dialog is useful for producing columns representing a
grid of values over which to evaluate a function or obtain predictions
from a model.

The Random Sample of Rows dialog can be used to generate
random samples or permute the observations in a data set.
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LIBRARIES INCLUDED WITH SPOTFIRE S+

All data sets in Spotfire S+ are stored in libraries. When we speak of
“S-PLUS,” however, we usually mean the executable program and
the objects in the libraries that are attached automatically at startup.
The Spotfire S+ distribution contains additional libraries. To see a list
and a description of each, at the command prompt, type

Tibrary()

Your default text editor opens and displays the information.

You can attach a library from the main menu by clicking File »
Load Library, or by using the library() function from the
Commands window (see Chapter 8). Many of these libraries,
including the robust library and the libraries contributed by Frank
Harrell and Brian Ripley, include graphical user interfaces. Others,
such as the examples and example5 directories, contain simple
command-line functions.

Note

In addition to loading libraries from the menu or from the Commands window, you can find
and download packages. From the main menu, click File P Find Packages, select the
repository (URL or local file path), and then from the list, select the package to download. You
can also get the latest versions of packages you have downloaded using the File » Update
Packages menu command. See the Guide to Packages for more information about using packages.
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As an example of what you can do with these libraries, attach the
maps library and try a few of its commands in the Commands
window:

library(maps)

map("county”™, "Washington™) # Create a map of Washington
map() # Create a map of the USA with state boundaries
graphsheet()

usa() ## Create a different map of the USA--compare

vV VvV V VvV

(The USA map created by map is superior to that created by usa.)
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INTRODUCTION

54

In this chapter, we discuss the concept of exploratory data analysis
and introduce you to a variety of plot types for examining the
structure of your data. Our discussion here is devoted exclusively to
the use of plotting techniques as a means of examining your data.
However, Spotfire S+ also offers a wide assortment of options for
fully customizing your plots and transforming them into presentation-
quality graphics. These procedures are documented in the Guide to
Graphics, available from the Help » Online Manuals menu in
Windows, or as graphics.pdf in your SHOME\help directory.
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VISUALIZING ONE-DIMENSIONAL DATA

The Michelson
Data

A one-dimensional data object is sometimes referred to as a (single)
data sample, a set of univariate observations, or simply a batch of
data. In this section, we examine a number of basic plot types useful
for exploring the shape of the distribution of a one-dimensional data
object.

These visualization plots are simple but powerful exploratory data
analysis tools that can help you quickly grasp the nature of the
distribution of your data. Such an understanding can help you avoid
the misuse of statistical inference methods, such as using a method
appropriate only for a normal (Gaussian) distribution when the
distribution is strongly non-normal.

The first step in creating a plot is creating or locating the data of
interest. For large data sets, you may prefer to store the data in a
database or a spreadsheet, such as Microsoft Excel. For smaller data
sets, it is convenient to directly enter the data into a Data window.
We begin this section by creating an example data set, the Michelson
data (exmichel).

In 1876, the French physicist Cornu reported a value of 299,990 km/
sec for ¢, the speed of light. In 1879, the American physicist A.A.
Michelson carried out several experiments to verify and improve on
Cornu’s value.

Michelson obtained the following 20 measurements of the speed of
light:

850 740 900 1070 930 850 950 980 980 880

1000 980 930 650 760 810 1000 1000 960 960

To obtain Michelson’s actual measurements in km/sec, add 299,000
km/sec to each of the above values.

The 20 observations can be thought of as observed values of 20
random variables with a common but unknown mean-value location
. If the experimental setup for measuring the speed of light is free of
bias, then it is reasonable to assume that w is the true speed of light.
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In this and subsequent sections, we examine the distribution of these
observations. In Chapter 6, Statistics, we pose some questions
regarding the mean of the data and perform various statistical tests to
answer the questions.

The data form a single, ordered set of observations, so they are
appropriately described as a data set with one variable. We will use a
Data window to create a new data set containing the 20 observations
listed above.

1. From the main menu, choose Data P Select Data to display
the Select Data dialog.

2. In the Source group, click the New Data radio button to
select it.

3. Inthe New Data group, type exmichel in the Name field
and click OK.

4. Now enter the 20 data points in the first column.

5. Change the column (or variable) name from the default V1 by
double-clicking V1 and typing speed. Press ENTER or click
elsewhere in the Data window to accept the change.

Exploratory To obtain a useful exploratory view of the Michelson data, create the

Plots following plots: a box plot, a histogram/density plot, and a QQ
normal plot.

1100

1000

900

speed

800

700

600

Figure 3.1: A box plot of the Michelson data.
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The box plot indicates that the median has a value of about 950 and
that the distribution is probably a bit skewed toward the smaller
values. It also indicates a possible outlier with a value of about 650.
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0.004

0.003

0.002

0.001

0.000
600 700 800 900 1000 1100
speed

Figure 3.2: Density estimate with histogram of the Michelson data.

The data points in the QQ normal plot, shown in Figure 3.3, do not
fall particularly close to the straight line provided in the plot, which
suggests that the data may not be normally distributed.

1100 7

1000 °c °

800

700

600 T T T T T

Normal Distribution

Figure 3.3: QQ normal plot with reference line for the Michelson data.
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Exploring QQ plots for other distributions

1. Try making QQ plots for other distributions. Right-click any
data point to display the shortcut menu. From the shortcut
menu, select Distribution to display the QQ Plot dialog
opened at the Distribution page.

Data to Plat...
Line/Symbal...
F00
o Wary Symbols...

Smooth/Sort...
G00

2 -1 Save QO Plot as default
MNaormal Help

2. Select t in the Function combo box, type 5 in the df 1
(degrees of freedom) box, and click OK.

Q0 Plot [1] BIET ES
Data ta Plat | Line/Symbol | Distribution | Wary Symbals | Smooth/Sort |
Distribution Ling———————————— Fiates I‘I
Style: I jv I

Tdeat 0
Lalor: I I Black jv I
Size 1
Wwieight: I‘I jv I
Std ey 1
Functior: t j' [rdes; IU
Shiape 1k m I
SHiapEilE Mormal Range Skewness: 0
) Stable
SiEpEie: it ID
Lacation: Unifarm
(e e weibul A asimun: |1
Siales Kt N
2=l T Wzern Functor: I
df1: |5 Other Argurnents: I
df 2 |D Dutput Object: |
oK I Cancel | Apply | |<| >| current ﬂl

Figure 3.4: The Distribution page of the QQ Plot dialog.

Does your t-distribution QQ plot look any more linear? Try
QQ plots for some other distributions, such as Uniform.

Keep in mind that the sample size is very small, and you may wonder
about the intrinsic variability of a normal QQ plot from sample to
sample. A useful exercise is to simulate samples of normal random
numbers with each sample having the same length as your data (20 in
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the case of exmichel), compute a QQ plot for each simulated normal
random vector, and observe the variability in the QQ plots.
Simulating random numbers is described in Chapter 6.
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VISUALIZING TWO-DIMENSIONAL DATA

The Main Gain
Data

60

In the previous section, you learned how to make several types of
plots that provide quick, visual insight into the shape of the
distribution of one-dimensional data. In this section, you expand your
toolkit of visual exploratory data analysis tools by learning how to
make scatter plots, line plots, and some other types of plots of two-
dimensional data (2D plots).

Two-dimensional data are often called bivariate data, and the
individual, one-dimensional components of the data are often
referred to as variables. Two-dimensional plots help you quickly
grasp the nature of the relationship between the two variables that
constitute bivariate data. For example, is the relationship linear or
nonlinear? Are the variables highly correlated? Are there any
outliers? Are there any distinct clusters? When you couple 2D plot
visualization of your bivariate data with one-dimensional
visualizations of the distribution of each of the two variables (for
example, using box plots or histograms), you gain a thorough
understanding of your data.

The “main gain” data in Table 3.1 present the relationship between
the number of housing starts and the number of new main telephone
extensions. The first column, “New Housing Starts,” is the change in
new housing starts from one year to the next in a geographic area
around New York City, in “sanitized” units (for confidentiality). The
second column, “Gain in Main Residential Telephone Extensions,” is
the increase in main residential telephone extensions in the same
geographic area, again in sanitized units. In this section, we explore
the relationship between these two variables.

Table 3.1: Main gain data.

Gain in Main Residential
New Housing Starts Telephone Extensions
0.06 1.135
0.13 1.075
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Table 3.1: Main gain data. (Continued)

Gain in Main Residential
New Housing Starts Telephone Extensions
0.14 1.496
-0.07 1.611
-0.05 1.654
-0.31 1.573
0.12 1.689
0.23 1.850
-0.05 1.587
-0.03 1.493
0.62 2.049
0.29 1.942
-0.32 1.482
-0.71 1.382

The data are best represented as a data set with two variables:

1. Click the New Data Set button I3 on the Standard toolbar.

2. Enter the 14 observations listed above. Change the column
(variable) names from the default V1 and V2 to diff.hstart
and tel.gain, respectively (double-click V1 and V2 to change
the variable names).

3. Rename the data set by double-clicking the top shaded cell in
the upper left-hand corner of the Data window, typing
exmain in the Name field, and clicking OK.
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Scatter Plots
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If you are responsible for planning how many new residence
extensions you need to install next year, and you can get an estimate
of new housing starts for next year, then you will naturally be
interested in whether or not there is a strong relationship between
diff.hstart (the increase in new housing starts each year) and
tel.gain (the increase in residence telephone extensions each year),
that is, whether or not you can use diff.hstart to predict tel.gain.
As a first step in assessing whether or not there appears to be a strong
relationship between these two variables, we make a scatter plot, as
shown in Figure 3.5.
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Figure 3.5: Scatter plot of tel.gain versus diff.hstart.

The plot immediately reveals two important features in the data: With
the exception of two of the data points, there is a positive and roughly
linear relationship between new housing starts and the increase in
residential telephone extensions. The two exceptional data points are
well detached from the remainder of the data; such data points are
called outliers.
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Move the mouse pointer over one of the outlying points. A DataTip
appears showing the values of the two variables at that point, as
shown in Figure 3.6.

K

1

diff. hstart = 0.06
tel.gain=1.135

-0.35 -0.10 015 040 065
diff hstart

Figure 3.6: DataTip showing variable values at pointer location.

Notice the number that appears on the first line of the DataTip. This
number identifies the row number of the data set corresponding to
the point. In Figure 3.6, the DataTip identifies this point as Row 1.
Now move the mouse pointer over the second outlying point. The
DataTip for this point identifies it as Row 2. Thus, the first two
observations in the data set are the outliers.

You can highlight data points in a scatter plot with a color that
distinguishes them from the remainder of the data. Let’s highlight the
two outliers in the scatter plot for the exmain data.

1. Open the Graph Tools palette by clicking the Graph Tools
button ET on the Graph toolbar.
9. Click the Select Data Points button &2 on the Graph Tools

palette. The mouse cursor becomes a cross-hair with a little
rectangle annotation.

o,
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3. Drag arectangle around the two outliers to select them. They
now appear highlighted, in red by default. (You can highlight
additional points by pressing the CTRL key while releasing the
mouse button.)

Note

When you select points in a scatter plot, they are also selected in any Data window in which the
data are displayed.

4. Change the cross-hair mouse pointer back to the regular

mouse pointer by clicking the Select Tool button R on the
Graph Tools palette.

5. Close the Graph Tools palette when you are done. Click a
cell in the Data window to deselect all points.

Scatter Plots  You can fit a straight line to your scatter plot data and superimpose
With Line and the fit with the data. Such a fit helps you visually assess how well the
data conform to a linear relationship between two variables. When
the linear fit seems adequate, the fitted straight line plot provides a
good visual indication of both the slope of bivariate data and the
variation of the data about the straight line fit.

Curve Fits
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Visualizing Two-Dimensional Data

You can fit a straight line to the exmain bivariate data by the method
of least squares and display the result superimposed on a scatter plot
of the data. Proceed as above when making a scatter plot except this

time click the Linear Fit button £ on the Plots 2D palette rather
than the Scatter button. The result is shown in Figure 3.7 below.
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Figure 3.7: Scatter plot with least squares line of tel.gain versus diff.hstart.

Notice in the graph that the two outliers in the data appear to
influence the least squares line fit by pulling the line downward and
reducing its slope relative to the remainder of the data.

The least squares fit of a straight line is not robust in that outliers can
have a large influence on the location of the line. A robust method is
one that is not influenced very much by outliers, no matter how large.
To fit a robust line by a method called least trimmed squares (LTS)
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and display the result, select the data and click the Robust LTS

button B on the Plots 2D palette. The result is shown in Figure 3.8
below. Save your Graph Sheet as exmain.sgr.
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Figure 3.8: Scatter plot of tel.gain versus diff.hstart with robust LTS line.
Compare Figure 3.7 to Figure 3.8 and note how much the two outliers
influenced the least squares line.

Line fits with selected points deleted

Since the least squares line for the exmain data appears to be
influenced by the two outliers, it would be nice to see what the effect
is of making the least squares fit with these two points removed. This
is very easy to do:

1. Make a scatter plot with a least squares line of tel.gain
versus diff.hstart and select the two outliers as you did
before (see Figure 3.9). Remember to change the cursor back
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to its regular form by clicking on the Select Tool button k
on the Graph Tools palette after you have selected the
outlier data points.
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Figure 3.9: Scatter plot with least squares line, outlier points selected.

2. From the main menu, choose Format » Exclude Selected
Points. This results in a new least squares line, which fits the
data without outliers quite well, as shown in Figure 3.10.
Notice that the vertical axis scale has changed and the two
removed outliers do not appear in the plot.
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Figure 3.10: Scatter plot with least squares line, outlier points removed.
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A hallmark of a good robust line fitting method is that it gives a
straight line fit that is close to that obtained with least squares when
the data do not contain outliers. You can check this out for the least
trimmed squares (LTS) robust line fit relative to least squares by
adding the LTS robust line to the graph you just made.

3. With the columns to plot selected, select the graph region,

press the SHIFT key, and click the Robust LTS button E£ on
the Plots 2D palette. The resulting graph, shown in Figure
3.11, reveals that the LS fit with outliers removed and the LTS
fit with outliers included are indeed rather close to one
another. Notice that the scatter plot now displays the original
axis ranges and that the two outliers removed from the LS fit
are displayed with the robust LTS line.
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Figure 3.11: Scatter plot with least squares fit (no outliers) and robust LTS lines.

4. Now that you have the LS fit for the data with the two outliers
excluded, you can easily add the points back in and see how
the line fits change. Just choose Format » Include All Points

68



Scatter Plots
With
Nonparametric
Curve Fits

Visualizing Two-Dimensional Data

from the main menu, and you get the graph shown in Figure
3.12. All existing plots on the graph will be recalculated to
include all points.
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Figure 3.12: Scatter plot with least squares and robust LTS lines, outlier points
included.

In the previous section, we fit linear parametric functions to the
scatter plot data. Frequently, you do not have enough prior
information to determine what kind of parametric function to use. In
such cases, you can fit a nonparametric curve, which does not assume
a particular type of nonlinear relationship.

Nonparametric curve fits are also called smoothers since they attempt
to create a smooth curve showing the general trend in the data. The
simplest smoothers use a running average, where the fit at a particular
x value is calculated as a weighted average of the y values for nearby
points, with the weighting given to each point decreasing as the
distance between its x value and the x value of interest increases. In
the simplest type of running average smoother, all points within a
certain distance (or window) from the point of interest are used in the
average for that point.

The window width is called the bandwidth of the smoother. Making
the bandwidth wider results in a smoother curve fit but may miss
rapidly changing features. Making the bandwidth narrower allows the
smoother to track rapidly changing features more accurately but
results in a rougher curve fit.

69



Chapter 3 Exploring Data

Kernel Smoothers
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More sophisticated smoothers add variations on this approach, such
as using smoothly decreasing weights or local linear fits. However, all
smoothers have some type of smoothness parameter (bandwidth)
controlling the smoothness of the curve.

The issue of good bandwidth selection is complicated and has been
treated in many statistical research papers. You can, however, get a
feeling for the practical consequences of varying the bandwidth by
actually using some smoothers on real data.

This section describes how to use three different types of smoothers—
kernel smoothers, spline smoothers, and loess smoothers—and select
their bandwidths to control the degree of smoothness of your curve fit
(or “smooths” of the data).

We will use the sample data set sensors, which contains the
responses of eight different semiconductor element sensors to varying
levels of nitrous oxide (NOx) in a container of air. The engineers who
design these sensors study the relationship between the responses of
these eight sensors to determine whether using two sensors instead of
one allows a more precise measurement of the concentration of NOx.
Prior investigation has revealed that there may be a nonlinear
relationship between the responses of the two sensors, but not much
is known about the details of the relationship.

A kernel smoother is a generalization of local averaging in which
different weight functions (kernels) may be used to provide a
smoother transition between points than is present in simple local
averaging. The default kernel is a box, which provides the local
averaging approach described in the introduction.

We will make a scatter plot of sensor 5 versus sensor 6 and
experiment with the bandwidth of a simple moving-average smoother
(sometimes called a “boxcar” smoother). We begin by using the 2D
graph capabilities to simultaneously make the scatter plot and
superimpose a moving-average smooth with a default bandwidth
choice.

Boxcar smoother
1. From the main menu, choose Data P Select Data.

2. In the Source group, ensure that Existing Data is selected.
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3. In the Existing Data group, type sensors in the Name field
and click OK.

4. Select columns V5 and V6.

5. From the main menu, choose Graph P 2D Plot to open the
Insert Graph dialog.

6. In the Plot Type list box, select Smoothing - Kernel Plot
and click OK, as shown in Figure 3.13.
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Figure 3.13: The Insert Graph dialog.

This results in the plot shown in Figure 3.14, where a not-so-smooth
curve is produced that fits the data rather poorly. This is because the
smoothing bandwidth is too small for these data.
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Figure 3.14: Sensor 5 versus sensor 6 with a box kernel smoother line.
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Experimenting with the bandwidth

L.

Now right-click one of the points in the scatter plot (or the
curve fit line) and select Smooth/Sort from the shortcut
menu.

On the Smooth/Sort page of the Line/Scatter Plot dialog,
notice the default value for the smoother bandwidth (look in
the Bandwidth box of the Kernel Specs group). Experiment
with various bandwidth choices between 0.1 and 0.6 by
entering different numbers in the Bandwidth box and
clicking Apply (so that the Line/Scatter Plot dialog remains
open). Which bandwidth produces the best “by eyeball”
curve fit? The smoother with bandwidth choice 0.3 is shown
in Figure 3.15.
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Figure 3.15: Sensor 5 versus sensor 6 with a box kernel smoother line using
bandwidth 0.3.

Changing the kernel smoother type to Parzen smoother

72

With the Line/Scatter Plot dialog still open to the Smooth/
Sort page (open the dialog again if you closed it), select
Parzen from the Kernel pull-down list in the Kernel Specs
group and click Apply. (The Parzen kernel is a box
convolved with a triangle.) Experiment again with the choice
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of bandwidth selection. Do you get a nicer smooth curve fit?
The Parzen kernel smoother with bandwidth 0.15 is shown in
Figure 3.16.
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Figure 3.16: Sensor 5 versus sensor 6 with a Parzen kernel smoother line using
bandwidth 0.15.

Cubic smoothing splines are computed by piecing together a
sequence of local cubic polynomials. Smoothness is assured by
having the value, slope, and curvature of neighboring polynomials
match where they meet. The “smoothing” parameter controls the
amount of curvature within the polynomials by governing the trade-
off between the degree of smoothness of the curve fit and fidelity to
the data values. The more accurately the cubic smoothing spline fits
the data values, the rougher the curve is, and conversely.

Spotfire S+ automatically chooses the smoothing parameter using a
theoretically justified technique based on the data values.
Alternatively, you can specify a smoothing parameter value to control
the smoothness of your spline smoother.

Fitting the spline smooth

*  Make a scatter plot of sensor 5 versus sensor 6 with the cubic
smoothing spline based on automatic bandwidth selection
superimposed on the plot. To do so, convert your kernel
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smooth plot to a spline plot by clicking a point in the plot and

then clicking the Spline button [ on the Plots 2D palette.
The resulting plot is shown in Figure 3.17.
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Figure 3.17: Sensor 5 versus sensor 6 with a spline smoother line.

Choosing your own bandwidth

*  From the shortcut menu for the plot, select Smooth/Sort, as
before, to open the Line/Scatter Plot dialog at the Smooth/
Sort page. In the Smoothing Spline Specs group,
experiment with the values available in the Deg. of Freedom
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(degrees of freedom) pull-down list to control the smoothness
of the spline fit. The spline smoother result with 6 degrees of
freedom is shown in Figure 3.18.
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Figure 3.18: Sensor 5 versus sensor 6 with a spline smoother line using 6 degrees of

freedom.
Loess Smoothers The loess smoother, developed by W.S. Cleveland and co-workers at

Bell Laboratories, is a clever approach based on local linear or local
quadratic fits to the data.
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Line Plots and
Time Series
Plots
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Fitting the loess smooth

Click a point in the plot to select the plot and then click the

Loess button ¥ on the Plots 2D palette to make a loess
curve fit to the sensors data and plot the curve fit with the
data. The result is shown in Figure 3.19.
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Figure 3.19: Sensor 5 versus sensor 6 with a loess smoother line using the default
bandwidth.

Varying the bandwidth of the loess smooth

Open the Line/Scatter Plot dialog to the Smooth/Sort
page. In the Loess/Friedman Specs group, notice the three
boxes labeled Span, Degree, and Family. Experiment with
Span values above and below 0.5 (the default value). This
number determines the bandwidth as a fraction of the range
of the x-axis values of the data (in this case, the range of the
sensor 5 values). Experiment also with a Degree box value of
2 instead of the default value of 1. This number determines
whether local linear or local quadratic fits are used.

Scatter plots are useful tools for visualizing the relationship between
any two variables, one against the other, regardless of whether there
is any particular ordering of the horizontal axis variable. On the other
hand, often one of the two variables you want to visualize in a scatter
plot is ordered, from smallest to largest, according to the row
numbers of the data set in which the data are stored.
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Line plots are helpful visualizations of the relationship between two
variables, as we have seen when overlaying the values of a straight
line fit or a nonparametric curve fit on a scatter plot. In these cases, an
ordering of the x-axis values with corresponding y-axis variables is
automatically carried out behind the scenes in overlaying the line or
curve fit.

Another situation in which the ordering of your data is important is
time series data. Here, successive values are measured at successive
instants of time. With ordered data, it is useful to make a line plot in
which the successive values of your data are connected by straight
lines, rather than just making a scatter plot of the data. By using
straight line segments to connect the points, you can see more clearly
the overall trend or shape of your ordered data values.

We return to the variables tel.gain and diff.hstart contained in
the exmain data set introduced earlier in the chapter. Both are time
series of values recorded once per year on the first of January for the
14 years beginning in 1971. We will use these variables to make line
plots and time series plots.

The simple line plot

To make a line plot of the tel.gain variable:

1. Use the Data P Select Data dialog to open exmain or create
the data set as described on page 60.

2. Select the tel.gain column.
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3. Click the Line button L~ on the Plots 2D palette. The
resulting graph is shown in Figure 3.20.
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Figure 3.20: Line plot of tel.gain.

When you select a single variable to plot, Spotfire S+ assumes that
this variable is the y-axis variable and supplies, as the x-axis variable,
the integers 1, 2, ..., n, where 7 is the length of your variable (that is,
the number of values in the variable). You will not get a meaningful
line plot if you select both tel.gain and diff.hstart, as Spotfire S+
then assumes the first variable you selected is the x-axis variable.

Line with points plot
To create a line plot with symbols superimposed:

1. Click the line plot to select it.
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2. Click the Line Scatter button L~ on the Plots 2D palette.
The resulting graph is shown in Figure 3.21.
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Figure 3.21: Line with points plot of tel.gain.

Notice that the gains in new residence telephone extensions were at
their very lowest during the first two years of the 14-year span, that
they rose rapidly in the third year, and that the gain had increasingly
wide up and down swings starting in year 6.

Line with isolated points plot

To see the points more clearly, you can create a line plot with scatter
plot points isolated from the lines. To make this graph:

1. Click any point or line in the plot to select the plot.
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2. Click the Isolated Points button S on the Plots 2D palette.
The resulting graph is shown in Figure 3.22.
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Figure 3.22: Line with isolated points plot of tel.gain.

Multiple line plots

Now that you have seen the time series behavior of tel.gain, you
may be interested in seeing that of diff.hstart as well, with the line
plots for the two time series in the same graph.

You can do this in one of two ways, as follows. The first way is
appropriate if you have already made one of the line plots and want
to add the second. The second way is appropriate if you want to make
both of the line plots at once.

Adding a second line plot

If you have already made the first line plot, as we did above, then you
can just add the second line plot in the usual way:

1. Click inside the graph region (but not on the plot) to select the
existing graph. Eight green boxes appear along the border of
the graph to indicate that the graph is selected.

2. Select the variable diff.hstart in the Data window.
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3. While pressing the SHIFT key, click the Isolated Points

button s on the Plots 2D palette. The resulting graph is
shown in Figure 3.23.
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Figure 3.23: Line with isolated points plots of tel.gain and diff.hstart.

Using the Y Series Lines button

The previous example showed how to add a second line plot to an
existing graph. To create multiple line plots at once, we can use the Y

Series Lines button E2 on the Plots 2D palette:

1. Select tel.gain and diff.hstart (in any order) in the Data
window.
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2. Click the Y Series Lines button & on the Plots 2D palette.
The resulting graph, shown in Figure 3.24 below, is very
similar to Figure 3.23.

Figure 3.24: Y series lines plot of tel.gain and diff.hstart.

Adding titles and legends

To add a main title “Main Gain,” an x-axis title “Year,” and a legend

to the last graph:

1. From the main menu, choose Insert P Titles » Main. Type
Main Gain where @Auto appears in selected form and then
click outside the edit box.

2. Select the x-axis by clicking on a tick mark (not a tick label).

3. From the main menu, choose Insert » Titles » Axis. Type
Year where @Auto appears in selected form and then click
outside the edit box.
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4. Now click the Auto Legend button =l on the Graph
toolbar. A legend is automatically created and placed on your
graph. You can position the legend by selecting it (click just
inside the border of the legend) and dragging it to the desired
location. The resulting graph is shown in Figure 3.25.
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Figure 3.25: Formatted plots of tel.gain and diff.hstart.

Plots in separate panels

Since the two time series are scaled somewhat differently, it is useful
to look at them in separate panels:

1. Click inside the graph region (but not on the plot) to select the
graph. Eight green boxes appear along the border of the
graph to indicate that the graph is selected.

2. Click the Graph Tools button ET on the Graph toolbar.
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3. Click the Separate Panels with Varying Y Axes button
on the Graph Tools palette. See Figure 3.26.
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Figure 3.26: Separate panels with varying Y axes plot.

Interpreting the main gain plots

Making line plots (time series plots) of tel.gain and diff.hstart
versus time is a simple yet powerful complement to making only a
scatter plot of these variables. Using both plot types gives you a more
complete understanding of your data.

Earlier in this chapter, we determined that the outliers were in the
first two rows of the data set. The time series plots reveal that the
values of tel.gain during these first two years were the smallest
during the entire 14-year history. At the same time, the diff.hstart
values during the first two years were near their overall average for
the 14-year interval. Furthermore, notice that, except for the first four
years, there is a striking correlation pattern between the two series;
whenever one increases, so does the other. It appears that the relative
behavior of the two variables is different during the first 2—4 years
from that in the remaining years. This should make you feel more
justified in using either the LS fit with the first two years deleted or the
robust LTS fit as descriptors of the behavior to be expected beyond
year 14.
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Time Series Plots Our line plot of the exmain data would be much nicer if the actual
dates were printed on the x-axis (the time axis), instead of the rather
anonymous labeling using the integers 1, 2, ..., 14. You can do this by
creating a third variable, Year, specifying the year in which each
observation was made.

Creating a dates variable
To create an integer variable named Year:

1. With the exmain Data window in focus, select the third (and
currently empty) column by clicking at the top of the column.

il exmain
1
diff.hstart

1 0.0600

2 0.1300

3 0.1400

4 -0.0700

5 -0.0300 .
il =M 2400 5 A

2. From the main menu, choose Insert » Column to display the
Insert Columns dialog.

3. Type Year in the Name(s) text box and 1971:1984 in the Fill
Expression text box. Select integer as the Column Type
and click OK. (See Figure 3.27.)

Ingert Columns M= EI
Mame(z] IYear
Fill Expression: |1 971:1984

Start Column: I@END VI Count:
[rata Set: Iexmain VI Column Type:

ak. I Eancell Applyl I<| >| cLment

Figure 3.27: The Insert Columns dialog.
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The third column now contains integers specifying years as

shown below.

il exmain 9 =] B
1 2 3 4
diffhstart | tel.gain Year
1 0.0600 1.1350 1971
2 0.1300 1.0750 1972
3 0.1400 1.4960 1973
4 -0.0700 1.6110 1974
5 -0.0500 1.6540 1975
il = el 1 =720 AN7E 5 A
4. Select the Year column. Press the CTRL key and select
tel.gain and diff.hstart (in either order).
5. Click the Isolated Points button I on the Plots 2D palette.

The resulting plot is shown in Figure 3.28.
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Figure 3.28: Yearly time series plot of tel.gain and diff.hstart.
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VISUALIZING MULTIDIMENSIONAL DATA

Scatter Plots
and
Scatterplot
Matrices

The Fuel Data

In the previous sections, we discussed visualizing simple one- and
two-dimensional data sets. With one- and two-dimensional data, all of
the basic information in the data may be easily viewed in a single set
of plots. Different types of plots (scatter plots, box plots, histograms)
provide different types of information, but deciding which plots to use
is fairly straightforward.

With multidimensional data, visualization is more involved. In
addition to one- and two-variable relationships, variables may have
interactions such that the relationship between two variables changes
depending on the values of the other variables. In this section, we
discuss both standard multidimensional visualization techniques and
novel techniques, such as Trellis graphics.

We begin with scatter plots and scatterplot matrices for
multidimensional data. Next, we describe Trellis graphics, which are
particularly useful for discovering higher-dimensional relationships in
data, and then we present plots designed for three-dimensional data.
Finally, we conclude with the brush and spin interactive dynamic
graphics tools.

We can use 2D scatter plots to view multidimensional data by varying
symbol attributes, such as color, style, and size.

Scatterplot matrices are powerful graphical tools that enable you to
quickly visualize multidimensional data. Often, when faced with the
task of analyzing data, the first step is to get familiar with the data.
Generating a scatterplot matrix greatly facilitates this process.

The fuel.frame data set contains information on 60 makes of cars
taken from the April, 1990 issue of Consumer Reports. The variables
are:

* Weight: Automobile weight
* Disp.: Engine displacement (6 liter, 8 liter, etc.)
* Mileage: Mileage in miles per gallon

*  Fuel: 100/mileage

87



Chapter 3 Exploring Data
+ Type: Category of vehicle (Large, Medium, Small, Compact,
Sporty, Van)
How do these variables relate to each other?
Color Plots First, let’s focus on the relationship between automobile weight,

mileage, and type of car. We will begin by generating a scatter plot
with symbol color varying based on type.

Generating a color plot with a legend

1. Use the Select Data dialog to display the fuel.frame data set
in a Data window.

2. Click Weight and then CTRL-click Mileage and Type.
3. Click the Color button = on the Plots 2D palette.

4. Click the Auto Legend button =l on the Graph toolbar.

Varying the symbol style

To further highlight the different categories of vehicle, we can vary
the symbol style:

1. Right-click any of the plot symbols and select Vary Symbols
from the shortcut menu.

2. Change Vary Style By to z Column. (Verify, by looking in
the Data Columns group on the Data to Plot page of the
dialog, that Type has been specified as the z column.)
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3. Click OK. (You can change the defaults for symbol styles and
colors; see Chapter 11, Customizing Your Spotfire S+
Session, for more information.) Figure 3.29 displays the
resulting color and symbol plot.

57 o Compact

v a Large
o Medium

Small
30 v v Sporty
. Van

Mileage

25 - o o

20 e 0v e a

15 =1 T T T T
1700 2200 2700 3200 3700 4200
Weight
Figure 3.29: Color plot of Mileage by Weight with color and symbol style varying
by Type for the fuel. frame data.

Notice that, over all cars, mileage tends to decrease as automobile
weight increases. However, the relationship varies between car types.
For example, Sporty cars have a wide range of weights and mileages.

Scatterplot Next, we will create a scatterplot matrix, viewing the relationships
Matrices between all the variables in the data set simultaneously.
Generating a scatterplot matrix
1. Since we want to plot all the variables in the data set, we select
all the variables by clicking in the upper left-hand corner of
the Data window (every column will turn black).
Note

The order in which you select the data columns determines the order in which they appear on
the scatterplot matrix. In the above case, we did not care about the order, but if we did, we could
CTRL-click the columns and select them in the desired order.
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2. Click the Scatter Matrix button on the Plots 2D palette.
The resulting scatterplot matrix is shown in Figure 3.30.
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Figure 3.30: Scatterplot matrix of the fuel. frame data. A number of strong relationships appears.

Examine the plot. You can immediately see a number of strong linear
relationships. For example, as might be expected, the weight of the
car and its fuel consumption have a positive linear relationship (as
Weight increases, so does Fuel). The scatterplot matrix gives you a
quick and concise overview of the more obvious two-variable
relationships in the data.

Adding histograms

Now let’s add histograms of the five variables displayed in Figure
3.30:

1. Right-click any data point to display the plot’s shortcut menu
and select Line/Histogram.
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2. On the Line/Histogram page of the Scatter Plot Matrix
dialog, select the Draw Histograms check box by clicking it.

Scatter Plot Matrix [1] M= EI
[rata to Plot | Line.-"Histograml Symbaol | Wary Symbols | Smoath |
~Line —Fil

Sityles I ' l Fill Colar: I BBl l
[Eolar I-User2 'l Fill Eattern: IEmpty 'l
W Eiaht |1 ' l Fattern Color: I Cdvellow = l

= Ereak Line — Border
= | at issings Style: I - l

™| &t Symbiols Colar: I | I l
: Wwieight: |1 - l

QK I Eancell Applyl I<| >| current Help |

Figure 3.31: The Line/Histogram page of the Scatter Plot Matrix dialog.

3. Click OK to redraw the scatterplot matrix with histograms.

The histograms provide you with additional useful information. For
example, the variables Weight, Disp., and Fuel seem to have normal
or close-to-normal distributions. In contrast, the variable Mileage is
perhaps not normally distributed. These conjectures would need to
be investigated further before we could draw any conclusions.

Adding least squares lines

Spotfire S+ can fit a variety of lines through our scatter plots. We can
fit least squares, robust, kernel, loess, and smoothing splines through
the matrix plots. For example, to add least squares lines to Figure
3.30, do the following:

1. Right-click any data point to display the plot’s shortcut menu
and select Smooth.
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The Sensors Data

Bubble Color
Plots

92

2. On the Smooth page of the Scatter Plot Matrix dialog,
select Least Squares from the Smoothing Type pull-down

list and click Apply.
Scatter Plot Matrix [1] HIEE3
[rata to Plot | Line.-"Histograml Symbaol | Wary Symbols | Smoath
Smoothing Type: INone 'l {amel Spac:
o prdiidth ID.5
HHutput Bomts: lone
LLoess/Friedman S Robust el Box e

Spar Egﬂﬁt-MM L eerlefined Smzothing
Dagre=: Somtingspine =" |
Eammily: ISymmetric 'l [Hthen Arguments: I
Smoathing Spline Specs

lrgeg. ofi Freedon; |2 VI

QK I Eancell Applyl I<| >| current Help |

Figure 3.32: The Smooth page of the Scatter Plot Matrix dialog.

3. Try experimenting with different types of lines and smoothing
parameters. Click OK to close the dialog when you are
finished and then close all windows.

As you will recall, the sensors data contain the responses of eight
different semiconductors designed to be responsive in different ways
to gases in the air, for example, for pollution monitoring. The data
contain 80 observations. The question is whether additional sensors,
beyond one, really improve pollutant detectability.

We begin by creating a bubble color plot in which we use x value, y
value, symbol size, and symbol color to each display a variable. This
allows us to represent four variables in a single scatter plot.

1. Use the Select Data dialog to display the sensors data in a
Data window.

2. Select the first four columns of the data.



Multiple Plots in
a Graph

Visualizing Multidimensional Data

3. Click the Bubble Color button E£ on the Plots 2D palette.
As in a standard scatter plot, V1 will be used as the x-axis
values and V2 as the y-axis values. The size of the symbols will
vary with the value of V3. Similarly, the symbol color will vary
with the value of V4 (with lighter values when V4 is larger).

4. Now click the Color Scale Legend button B on the Graph
toolbar to add a legend relating the V4 value to the color of
each point. (You can modify symbol size and color ranges on
the Vary Symbols page of the Line/Scatter Plot dialog.)
The resulting plot is shown in Figure 3.33.
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Figure 3.33: Bubble color plot of the sensors data.

In this data set, the four variables V1 through V4 tend to move
together. For example, as we move to the upper right of the plot, the
symbols are larger and lighter.

Another useful way to compare relationships is to create multiple
scatter plots in the same graph. This will plot multiple y variables
sharing the same x variable.

1. Select the first four columns of the sensors data.

9. Click the Scatter button k% on the Plots 2D palette. Three
scatter plots are created on the same graph.
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3. Click the Auto Legend button to add a legend. The
resulting graph is shown in Figure 3.34.
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Figure 3.34: Multiple plots in a graph for the sensors data.

Plots in separate panels

We can also view the three plots in separate panels with a shared
x-axis.

1. Click inside the graph (but not on a point) to select the graph.

2. Open the Graph Tools palette by clicking the Graph Tools
button ET on the Graph toolbar.

3. Click the Separate Panels with Varying Y Axes button =

on the Graph Tools palette. Three scatter plots are created in
separate panels.
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4. Remove the legend by selecting it and pressing the DELETE
key. The resulting graph is shown in Figure 3.35.
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Figure 3.35: Multiple plots in separate panels for the sensors data.

Notice that the relationship between V1 and V4 is very close. The
points fall almost exactly along a straight line. The relationships
between V1 and the other two variables (V2 and V3) show more
variation.

Now we will create a scatterplot matrix to view all of the variables.

1. Select all of the columns in the sensors data by clicking in the
upper left-hand corner of the Data window.
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2. Click the Scatter Matrix button on the Plots 2D palette.
The resulting graph is shown in Figure 3.36.
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Figure 3.36: Scatterplot matrix of eight different pollution sensors.

Examine the plot. If the sensors vary in their ability to detect
pollution, we would expect to see some nonlinear relationships. Look
closely at the relationship between sensors 4 and 5, 5 and 6, 6 and 7,
and 7 and 8. Do you see the nonlinear relationships (the curve in the
lines)? It seems that some of these sensors vary in their ability to
detect gases, so adding more than one sensor may increase
detectability of the gases.

Trellis Graphs Trellis graphs allow you to view relationships between different
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variables in your data set through conditioning. Suppose you have a
data set based on multiple variables and you want to see how plots of
two variables change with variations in a third “conditioning”



The Ethanol Data
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variable. By using Trellis graphics, you can view your data in a series
of panels where each panel contains a subset of the original data
divided into intervals of the conditioning variable.

A wide variety of graphs can be conditioned using Trellis graphics.

The sample data set ethanol contains measurements of pollutants in
automobile exhaust. Data were collected to analyze oxides of
nitrogen in the exhaust. An experiment was done on a one-cylinder
engine fueled by ethanol. Two engine factors were studied: the
equivalence ratio (E), a measure of the richness of the air and fuel
mixture, and the compression ratio to which the engine is set (C).
There were 88 runs of the experiment. Here we will examine the
relationship between the oxides of nitrogen (NOx) and the
compression ratio.

Creating a loess plot

1. Use the Select Data dialog to open the ethanol datain a
Data window.

2. Select the C column. Press the CTRL key and select the NOx

column.

3. Click the Loess button £ on the Plots 2D palette to create a
scatter plot with a loess smooth, as shown in Figure 3.37.
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Figure 3.37: Compression ratio versus nitrogen oxide in the ethanol data set
(default smoothing).
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4. Close all windows other than the current Graph Sheet and
the ethanol Data window. From the main menu, choose
Window P Tile Vertical to display the two windows side by
side.

Adjusting the smoothing parameter

* Right-click any symbol of the plotted loess line to display the
shortcut menu for the plot and select Smooth/Sort. In the
Loess/Friedman Specs group, type 1 in the Span box and
click OK. An increase in the span parameter results in a
smoother line, as shown in Figure 3.38.
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Figure 3.38: Compression ratio versus nitrogen oxide in the ethanol data set (span

of 1).
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Trellis Graphs There appears to be little dependence of the oxides of nitrogen on the
compression ratio. However, hidden from this scatter plot is the fact
that E is varying as we move from point to point. The next step is to
condition the plot on E to further examine the relationship.

1. Select the E column in the Data window. Move the cursor to
the middle of the column. Press and hold the mouse button.
While holding down the button, drag the cursor to the top of
the graph. As the cursor passes over the top of the graph, a
rectangular drop target appears.

2. Release the mouse button when the cursor is within the
rectangle. The graph is redrawn in panels representing the
different levels of E.
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Figure 3.39: Compression ratio versus nitrogen oxide conditioned on equivalence
ratio (defaults).
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Modifying the conditioning rules

By default, the conditioning variable is broken into four disjoint
groups with an equal number of observations per group. We can
break the data into more groups and change other values controlling
the conditioning.

1. Right-click an empty space within the graph to display the
shortcut menu for the graph and select Multipanel.

2. In the Continuous Conditioning group, type 9 for # of
Panels and 0.25 for Frac. Shared Pts.

3. In the Layout group, type 2 for # of Rows.

4. Click the Position/Size tab of the dialog. Type 2.5 for Aspect
Ratio and click OK. The resulting graph is shown in Figure
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Figure 3.40: Compression ratio versus nitrogen oxide conditioned on equivalence
ratio.

The Trellis graph now has nine panels in two rows, and each panel
has an aspect ratio of 2.5. The range of E used for each panel is
determined using the default equal-count method with a 25% overlap.
The algorithm picks interval end points that are values of the data; the
left end point of the lowest interval is the minimum of the data, and
the right end point of the highest interval is the maximum of the data.
The end points are chosen to make the counts of points in the
intervals as nearly equal as possible and the fractions of points shared
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by successive intervals as close to the target fraction as possible.
Overlapping ranges typically provide greater sensitivity in detecting
non-homogeneity than non-overlapping ranges.

The conditioned plot shows a clear positive relationship between the
oxides of nitrogen and the compression ratio for low values of E. For
high values of E, the slope is close to zero. In each panel, the pattern
appears linear.

Changing the plot type

Since the patterns appear to be linear, let’s redraw the Trellis graph
using a least squares fit.

1. Click any point in the plot to select the plot.

2. Click the Linear Fit button £ on the Plots 2D palette. The
graph is redrawn using a linear fit.

The sample data set barley contains data from an agricultural field
trial to study the crop barley. At six sites in Minnesota, ten varieties of
barley were grown in each of two years. The data are the yields for all
combinations of site, variety, and year, so there are 6 x 10 x 2 =120
observations.

The barley experiment was run in the 1930s. The data first appeared
in a 1934 report published by the experimenters. Since then, the data
have been analyzed and re-analyzed. R.A. Fisher presented the data
for five of the sites in his classic book, The Design of Experiments.
Publication in the book made the data famous, and many others
subsequently analyzed them, usually to illustrate a new statistical
method.

In the early 1990s, Bill Cleveland of AT&T (now Lucent
Technologies) analyzed the data again using Trellis graphics. The
result was a big surprise. Through 50 years and many analyses, an
important feature of the data had gone undetected. The basic analysis
is repeated here.
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Trellis Graphs

102

We are interested in exploring how barley yield varies based on
combinations of the other variables. Trellis is particularly useful for
displaying the effects of covariates and their interactions. We will use
a color plot with conditioning to display the fourth and fifth variables.

L.

Use the Select Data dialog to display the barley datain a
Data window.

Select the yield column. Then press the CTRL key and select
variety, year, and site. The order of the variables selected
determines how they will be used in the color plot. The first
variable (yield) will be used as x, the second (variety) as y,
and the third (year) to determine the color of the symbols.
The last variable (site) will be used as the conditioning
variable.

Now open the Plots 2D palette. Turn conditioning mode on

by clicking the Set Conditioning Mode button EH on the
Standard toolbar. (The small yellow bars at the top of each of
the icons on the Plots 2D palette indicate that conditioning
mode is on.)

4. Ensure that # of Conditioning Columns is set to 1.

& el ¥ @
# of Conditioning Columns
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Click the Color button L= on the Plots 2D palette. A Trellis
graph appears showing barley yield for each variety,
conditioned on the site. The yields for 1931 and 1932 appear

in different colors. The resulting graph is shown in Figure
3.41.
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Figure 3.41: Unformatted Trellis plot of barley yields for 1931 and 1932.

6. Turn conditioning mode off (click the Set Conditioning

Mode button B8 again), maximize the new Graph Sheet,
and close the Plots 2D palette.

Formatting the panels

To make it easier to compare yields across sites, we will make three
changes to the layout of the panels: Stack them in one column,
reorder them according to the median of the yield data shown in each
panel, and set the aspect ratio of each panel to 0.5.

1.

Right-click an empty space within the graph to display the
shortcut menu for the graph and select Multipanel.

In the Conditioning Columns group, set Order Type to
Median of X.

In the Layout group, type 1 for # of Columns.
Click the Position/Size tab of the dialog. Type 0.5 for Aspect
Ratio and then click OK.
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Adding a legend

Now add some final touches to your plot: Add a legend and vary the
symbol styles, as well as the symbol colors, for the two years.

*  Click the Auto Legend button =l on the Graph toolbar. A
legend is automatically created and placed on your graph.
You can position the legend by selecting it (click just inside
the border of the legend) and dragging it to the desired

location.

Varying the symbols

1. Right-click any symbol on the plot to display its shortcut
menu and select Vary Symbols.

2. On the Vary Symbols page, set Vary Style By to z Column
so that both the color and symbol styles vary by year. (You
can change the defaults for symbol styles and colors; see
Chapter 11, Customizing Your Spotfire S+ Session, for more
information.)

3. Click OK. Notice that the legend has been updated to reflect
the new symbol styles. Your final Trellis plot should look
similar to the one shown in Figure 3.42.
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Figure 3.42: Formatted Trellis plot of barley yields for 1931 and 71932.
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Now examine your graph to find the long-undetected discrepancy. It
appears in the Morris panel. For all other sites, 1931 produced a
significantly higher overall yield than 1932. The reverse is true at
Morris. But most importantly, the amount by which 1932 exceeds
1931 at Morris is similar to the amounts by which 1931 exceeds 1932
at the other sites. Either an extraordinary natural event, such as
disease or a local weather anomaly, produced a strange coincidence,
or the years for Morris were inadvertently reversed. More Trellis
graphics, a statistical modeling of the data, and some background
checks on the experiment led to the conclusion that the data are in
error. But it was a Trellis graphic, such as that created in Figure 3.42,
that provided the “Aha!” that led to the conclusion.

The scatter plots, scatterplot matrices, and Trellis plots discussed in
the preceding sections may all be used to display three-dimensional
data. In addition, 3D scatter plots, surface plots, and contour plots are
available. These plots are particularly suited for plotting points in
three-dimensional space, including plotting one variable as a function
of the other two variables.

In Spotfire S+ we consider some plots to be 2D plots and others to be
3D plots. This distinction is based upon the type of axes used. This
section discusses:

* 3D scatter plots
*  Surface plots
*  Contour plots

The first two plots are considered to be 3D plots because they use 3D
axes to represent their points in three-dimensional space. The contour
plot is a 2D plot in which the third variable is represented by contour
lines or fill colors.

A 3D scatter plot displays the variable values as locations in three-
dimensional space.

Sliced ball data

We begin by examining a set of simulated data contained in the
sliced.ball sample data set. The points are uniformly distributed
within a sphere, with the exception of a structural feature that we will
attempt to discover.
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First we create a scatterplot matrix and a Trellis plot with these data
and then create 3D scatter plots.

Scatterplot matrix

1. Use the Select Data dialog to display the s1iced.bal1 data in
a Data window.

2. Select all three columns.

3. Click the Scatter Matrix button on the Plots 2D palette.
Each panel displays an apparently random ball of data, as

shown in Figure 3.43.
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Figure 3.43: Scatterplot matrix of the sliced ball data.

There are no obvious relationships between any two columns of data,
so the bivariate plots suggest that the data are randomly distributed
within the sphere. No other relationships are apparent.
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Trellis plot

The limitation of bivariate plots is that they do not allow us to look at
interactions between variables. For example, how does the
relationship between V1 and V2 depend on V3? We can use Trellis
plots to look for such interactions.

1. Turn on conditioning mode by clicking the Set

Conditioning Mode button E& on the Standard toolbar.
(The small yellow bars at the top of each of the icons on the
Plots 2D palette indicate that conditioning mode is on.)

2. Ensure that # of Conditioning Columns is set to 1. With
these settings, multiple panels will be created with the data
grouped based on the values of the last selected column.

3. Select V1 and then CTRL-click to select columns V2 and V3.

4. Click the Scatter button k= on the Plots 2D palette. The
resulting graph is shown in Figure 3.44.
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Figure 3.44: Trellis plot of the sliced ball data.

5. Turn conditioning mode off by again clicking the Set

Conditioning Mode button EE on the Standard toolbar. (If
you skip this step, you may inadvertently have conditioning
mode on in the subsequent plot.)
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The data points are divided into four groups. Data points with values
of V3 between -0.9 and -0.4 are shown in the lower left panel. Data
points with the next highest values of V3 are shown in the panel to the
right. Notice that there is a diagonal gap running through the data.
This is also evident in the upper left panel. This suggests that the data
are not, in fact, random throughout the sphere.

3D scatter plots

To explore further, we can create a 3D scatter plot. This is perhaps
the most natural plot to use for these data, since the data represent
points in three-dimensional space.

1. Select all three columns in the Data window.

2. Click the 3D Scatter button & on the Plots 3D palette. The
resulting graph is displayed in Figure 3.45.

N3
-0.500 0.000 0.500

Figure 3.45: Three-dimensional scatter plot of the sliced ball data.

Note that, unlike the previous plot, this plot uses 3D axes
reflecting the location of points in three-dimensional space.

Rotating 3D plots

A single 3D scatter plot gives one view on the point cloud. To gain an
understanding of the overall structure, it’s useful to look at the point
cloud from multiple viewing angles. We can rotate the axes to view
the points from a different angle.

1. Click an empty space within the graph region to select the 3D
workbox. Four green circles and a green triangle appear. (If

only a solitary green knob appears, you have clicked on the
plot rather than the workbox—try again.)



Visualizing Multidimensional Data

2. Drag horizontally on one of the green circles. A bounding
box will appear and rotate in the direction you drag the
mouse. When you release the mouse, the graph is redrawn at
the new perspective. The green triangle can be dragged up
and down to rotate the graph vertically. Experiment with
rotating the graph.

Multiple panels

It’s often useful to look at the point cloud from different angles
simultaneously. We can do this by using a multipanel plot with
different rotations of the data in each panel.

1. Click within the graph to select the graph region. Eight green
boxes appear along the border of the graph to indicate that
the graph is selected.

2. Click the 6 Panel Rotation button on the Plots 3D
palette. The resulting graph is displayed in Figure 3.46.

X Angle = 124 X Angle = 184

X Angle = 64

Figure 3.46: Multiple panel 3D scatter plot of the sliced ball data.

The multiple panel 3D scatter plot is particularly clear in uncovering
the slice in the sliced ball data. Viewing the data in 3D allows us to
look at angles other than those displayed in the bivariate plots. This
helps us to discover higher-dimensional structure.
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Another way to examine these data is using brush and spin. This is

discussed in Dynamic Graphics on page 113.

Surface Plots

Surface plots are three-dimensional surfaces reflecting the value of a
variable over different values of two other variables. Data used in a
surface plot are often over a grid of values. If the data available are
not on a grid, interpolation is used to fit a surface over a grid, which is

then plotted.

Example surface data

The sample data set exsurf contains two columns representing a grid
of values and a third column that is the value of a function over the
grid. The help file for exsurf describes the equation used.

Creating surface plots

First we will create a surface plot of these data.

L.

Use the Select Data dialog to display the exsurf data in a

Data window.

Select all three columns in the Data window.

Click the Data Grid Surface button # on the Plots 3D
palette. The resulting graph is displayed in Figure 3.47.
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Figure 3.47: Surface plot of the exsurf data.

4.
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Using the same procedure as for 3D scatter plots, rotate the

plot to examine it from multiple angles.
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Contour Plots

Visualizing Multidimensional Data

Creating a filled surface
Next we will create a filled surface.
1. Click a line in the 3D mesh to select the plot.

9. Click the 16 Color Surface button ® on the Plots 3D

palette to convert the surface to a filled surface plot with color
varying by z value.

3. Click the Color Scale Legend button B on the Graph

toolbar to add a legend. The resulting graph is shown in
Figure 3.48.

N3
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Figure 3.48: Filled surface plot of the exsurf data.

Contour plots are flat, two-dimensional representations of three-
dimensional data. They are often used for data collected on a grid. If
the data available are not on a grid, interpolation is used to fit
contours over a grid, which are then plotted.

Creating a contour plot

1. Select all three columns in the exsurf Data window.
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2. Click the Contour button EZ on the Plots 2D palette. The
resulting graph is shown in Figure 3.49.

Figure 3.49: Contour plot of the exsurf data.

The lines on a contour plot indicate locations of equal magnitude.
Contour plots are read in the same manner as contour maps. They
point out minima and maxima, as well as the slope of the surface in
various regions.

Filled contour plots

A useful enhancement to a contour plot is to add color indicating the
magnitude of the z variable at each location.

1. Click any contour in the plot to select the plot.

2. Click the Filled Contour button 2 on the Plots 2D palette.
The plot is changed to a filled contour plot.



Dynamic
Graphics

The Sliced Ball
Data

Visualizing Multidimensional Data

3. Right-click the plot to display the shortcut menu and select
Contour/Fills to open the Contour Plot dialog. Change the
Fill Type to 2 Color Range. Click OK. The resulting
contour plot has colors between Blue and Lt Cyan, as shown
in Figure 3.50.

-1 0 1
Vi

Figure 3.50: Filled contour plot of the exsurf data.

4. Click the Color Scale Legend button B on the Graph
toolbar to add a legend.

With a scatterplot matrix and a 3D scatter plot, you can generate
interactive dynamic graphics. With them, you can view a matrix plot
of the data, select and label groups of points, and rotate the data
interactively, to obtain dynamic views of your multidimensional data
set.

We will demonstrate how to use Spotfire S+’s dynamic graphics using
the sample data set sliced.ball, a three-dimensional data set
representing points within a sphere. It contains structure that is not
apparent in a scatterplot matrix.

1. Use the Select Data dialog to display the s1iced.bal1 data in
a Data window.

2. Examine the data. Do you see anything unusual?
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Selecting Data
Points

Spinning Data

114

3.

Create a scatterplot matrix of the data. Again, do you see
anything unusual, any clear patterns or other distinguishing
features? Most people will see nothing unusual—the data seem
to be a cloud of random data points.

Now create a 3D scatter plot of the data.

Click the Select Data Points button &2 on the Graph Tools
palette.

Click and drag the pointer over some of the points in the 3D
scatter plot. A rectangular “lasso” appears as you drag. When
you release the mouse button, all the points inside the lasso

are highlighted.

Now click on the title bar of the scatterplot matrix Graph
Sheet to bring it into focus. Notice that the points you just
highlighted in the 3D scatter plot are also highlighted in each
of the matrix panels.

Click and drag the pointer to lasso an empty section in a
scatterplot matrix panel. The highlighting for the previously
selected points is turned off.

Experiment with the Select Data Points tool by selecting
and deselecting points.

It will be hard to find any kind of meaningful pattern in these data
using brushing. For some other data sets, brushing can be a very
useful exploratory data analysis tool.

Now let’s examine the 3D scatter plot. Here we can rotate the data
interactively. This allows us to view the data from a variety of angles
and thus may help us to understand the data better.

L.

Click an empty space within the graph region to select the 3D
workbox. Four green circles and a green triangle appear. (If
only a solitary green knob appears, you have clicked on the
plot rather than the workbox—try again.)

Now rotate the point cloud by dragging any of the circles (for
rotation about the vertical axis) or the triangle (for rotation
about the horizontal axis parallel to the screen). Examine the
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cloud as you rotate it. After a few rotations, you will start to
notice something. As shown in Figure 3.51, there is a slice of
data missing in this seemingly random point cloud!
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Figure 3.51: The sTiced.ball data set rotated to reveal missing points.

Viewing the points in three dimensions allows you to discover
structure not apparent in any of the two-variable plots.
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Introduction

INTRODUCTION

The Plot
Palettes

You probably need to create graphics for a variety of purposes—some
“quick-and-dirty” for your own use in visually exploring your data or
evaluating a model, some for sharing informally with colleagues, and
some highly refined for publication in journals or marketing
materials. Spotfire S+ offers a tremendous variety of plot types for all
these uses. In this chapter, we present a pictorial overview of all the
various plots you can create.

The Plots 2D, Plots 3D, and Extra Plots palettes contain buttons for
quickly creating plots. (See Figure 4.1 below.) To create a plot, simply
select your data columns, either through the Data window or the
Object Explorer, and then click a palette button.
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Figure 4.1: The Plots 2D, Plots 3D, and Extra Plots palettes.

The distinction between the 2D and 3D palettes is whether plots are
created with two axes or three. Many 2D plots, such as scatterplot
matrices, bubble color plots, and contour plots, can show data
representing more than two dimensions. In this chapter, we organize
the plots primarily by the dimensionality of the data.
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The Insert
Graph Dialog

Plot Properties
Dialogs

Structuring
Your Data to
Plot

120

You can also create any plot type by selecting it in the Insert Graph
dialog, as shown in Figure 4.2.

Ingert Graph x|
Azes Type: Flat Type:
Line with |zolated Paints [x, 11, w2, ...] ;I

Multiple Line with Scatter (4, 1, v2, ..

Multiple 5 Line with Text as Symbols [« v, text] 12 . |
Panel Pareto Plat [, v]

Wary 'y Panel Pareta Plat, Horiz. [%, ¥ b

Wary % Panel Prabability Plot [x, v) Yoz .

Wary 2 Panel FP Mormal with Line [x]

Lag* Quantile-Ouantile Plot (=, v] 159 -

Log i Q0 Mormal with Line [x) I

LogLag Fobust Least Trimmed 5q. (=, w1, v2, ..]

Ln' Fobust M [x oyl v2, L L
Lines Scatter Plat (¢, v1. 2, .. i
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Graph Sheet:

G51 =l

Cancel |

Help |

Figure 4.2: The Insert Graph dialog.

To open the Insert Graph dialog, do one of the following:

* From the main menu, choose Graph and select a graph type—
2D Plot, 3D Plot, or Multipanel Graph.

*  With a Data window open, choose Insert » Graph from the
main menu.

Double-clicking an existing plot, or creating a plot through the Insert
Graph dialog without first selecting your data, opens a plot properties
dialog specific to a particular group of plots. You can use these
dialogs to create or modify your plots. For a complete discussion of
the plot properties dialogs, see the online help.

Because some plot types require data to be structured in a particular
way, in the sections that follow, a sample data set is shown for each of
the various plot types. For many plots, however, the data can be
formatted in a number of different ways.

For example, data for creating grouped box plots may be structured
in one of two ways: as long form stacked data or as multiple y form
data. Whichever form your data are in, the same grouped box plot is
produced.
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In long form stacked data (see Figure 4.3), the x column is a column
of integers that assigns each y value to a group and determines the
placement of the boxes along the x-axis. When your data are
structured in this way, you simply select the x and y columns to create
the grouped box plot.

& gouped boxlong _ PIIsIEH|
1 2 B 1=
X
1 1.0 1091
2 1.00/ 16.45]
3 1.00/ 17,18
4 1.00/ 12.20|
3 1.00/ 9.22|
[} 2.00] 10.37|
7 2.00] 16.20|
a8 2.00] 14.00|
=] 2.00] 9.00|
10 2.00] 12,51
11 3.00] 13.00]
12 3.00] 10.28|
12 3.00] 871
14 3.00] 12.09|
13 3.00] 7.70| =
Ll | Mo

Figure 4.3: Long form stacked data for creating a grouped box plot.

In multiple y form data (see Figure 4.4), the x column determines the
grouping levels of the data in two or more y columns. When your data
are structured in this way, you select the x, y1, y2, y3, y4, and y5
columns to create the grouped box plot.

1 2 2 4 S [:] 7 =
X vl va ¥3 v Y3
1 1.0 10,91 16,45 17.18 12,20 9.22
2 2,00 10.37| 16.20] 14.00] 9.00| 12,51
3 3.00] 13.00] 10.26( 8.71| 12.09 7.70| =
Ll | s

Figure 4.4: Multiple y form data for creating a grouped box plot.

For insight into the data structure appropriate for any given plot type,
open the Insert Graph dialog (refer to Figure 4.2). Following each
plot type is a parenthetical listing of the various ways in which your
data may be structured to produce that particular plot.
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PLOTTING ONE-DIMENSIONAL DATA

Box Plots

A box plot displays the locations of the basic features of the
distribution of one-dimensional data—the median, the upper and
lower quartiles, outer fences that indicate the extent of your data
beyond the quartiles, and outliers, if any.

A box plot allows you to quickly grasp the location, scale (width), and
rough shape of the distribution of your data. For example, if the
upper and lower quartiles of the box plot are about the same distance
from the median, then the distribution of your data is approximately
symmetric in the middle. The median is represented by a horizontal
line segment within the rectangle, and the top and bottom areas of the
rectangle portray the upper and lower quartiles.

There are two types of box plots: single and grouped. (Grouped box
plots are discussed later in this chapter.) A single box plot consists of a
box plot describing one column of data.

To create a vertical box plot
for a single set of data: 1 2 3 3 5

1. Select the y column.

2. Click the ) button on L i
the Plots 2D palette.

To create a horizontal box plot, click the [= button instead.

Vertical box plot |£ Horizontal box plot ad

26

217

16

111

—_—

RENEE
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QQ Plots

Plotting One-Dimensional Data

A quantile-quantile plot, or QQ plot for short, is useful for comparing
your data with another set of data or with the quantiles of a
distribution function that you conjecture is a good model for your
data. In the latter case, the plot shows the ordered data values along
the vertical axis versus the corresponding quantiles of the distribution
function you specify along the horizontal axis. You interpret the plot
in a very simple way:

+ If the points fall close to a straight line, your conjectured
distribution is a reasonably good model for your data.

« If the points do not fall close to a straight line, your
conjectured distribution is not a good model, and you need to
look for an alternative distribution that is a better model.

The QQ normal with line plot is intended for comparing a single set
of data with the quantiles of a distribution function (by default, the
normal distribution). The QQ plot is intended for comparing two sets
of data and does not automatically display a distribution line.

To create a QQ normal with pm—— B

line plot for a single set of data: [~ « | = | = 4 | ¢ =
Y

2560.01
2345.00
1845.00

1. Select the y column.

EMNH
N

2. Click the Fa button on
the Plots 2D palette.
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To create the same plot without the distribution line, click the ]
button on the Extra Plots palette.

00 normal with line plot Fa

4000 7

3500 7

3000

2500

2000

Normal Distribution

To create a QQ plot

T =1

comparing two sets of data: [ : [ = [ s [ s [ s [
vl va
1. Select the yl and y2 L 08 059
2 0.73 0.40
columns to plot y2 |3 TR -
against y1. Ll 1Y
2. Click the ] button on
the Extra Plots palette.
Q0 plot &
1.0 1
(4
0.8 ‘.
N 0.6 7 KA
0.4 s
J‘",
0.2 ”»
e
0.0 T T T T T
0.0 0.2 0.4 0.6 0.8 1.0
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Probability A probability plot is similar to a QQ) plot except that it compares your

Plots data with the quantiles of a cumulative probability distribution
function. Probability plots can be created with or without a
distribution line.

To create a probability plot _
. o . ifi probability M=k
with a distribution line for a 3 z 3 3 = C

single set of data:

0.6
0.47
0.35

L« 1

W m e

1. Select the y column.

2. Click the e button on
the Plots 2D palette.

To create the same plot without the distribution line, click the e
button on the Extra Plots palette.

Probability normal with line plot e Probability plot e
R4
0.8 1 ®
,.
0.6 7
- P
0.4 ’.
”
0.2 7 /
0_‘55 0_‘60 0_;;5 0_‘70 0 ‘75 0 ‘50 0.‘55 0 250 0.255 0.‘70 O.‘75 O.‘SO
Normal Probabilities Normal Probabilities
Histogram/ A histogram displays a set of rectangular bars. The width of each bar

Density Plots represents a range of values, and the height of the bar represents the
counts of observations that fall within a given range. A nonparametric
density estimate is an estimate of the probability density function (or
density, for short) of your data that does not assume any parametric
form for the density, such as a normal density with mean parameter

and variance parameter 02 .
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You can think of a nonparametric density estimate as a smooth
alternative to a histogram, with the shape of the density estimate
being similar to that of the histogram. Histogram/density plots are
powerful visualization tools without the considerable data reduction
produced by a box plot.

To create any of the , ,
. . il histogram_density _ (O] %]
histogram/density plots for a [~ : = s | 4« | s =

single set of data, select the x t—
column. Then:

w e

0.70
0.59

« To create a histogram, Lol Iy

click the Y button on
the Plots 2D palette.

+ To create a density plot, click the LA button on the Plots 2D
palette.

+ To create a histogram/density plot, click the & button on the
Plots 2D palette.

Histogram o Density plot L

407 34

30

20
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! T T T T T
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Histogram/density plot e
1
.

: N

T T
0.1 0.3 0.5 0.7 0.9 1.1

Pie Charts A pie chart shows the share of individual values in a column relative
to the column sum.

To create a pie chart:

1. Select the x column.

1 1.0
2 2.00

2. Click the ® button on | o
the Plots 2D palette. ENIS] P

Pie chart ®

Dot Plots A dot plot plots independent data against categorical dependent data
using gridlines to mark the dependent levels.
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To create a dot plot:

Bar Plots

L.

Either select a single x
column to plot its
values along the
horizontal axis against
an integer sequence

7.18|

4,74

7 64|

along the vertical, or select both x, the categorical data, and y

to plot y against x.

Click the = button on the Plots 2D palette.

Dot plot =

CORRPNNWWAUIUIO O~ ~ 0o © ©
MNNwowohonomik NN 0w

A bar plot displays a bar of a height (or width, for a horizontal bar

plot) determined by its corresponding data value. A bar plot with

error displays an error bar on top (or at the end) of each bar.

To create a vertical bar (with
base at Y min) plot:

128

L.

Either select a single
column to create a bar
plot of its values using
an integer sequence to

1

2

El

4

]

il bar =3

X

¥

0.46

.63

0.74

R

H

label the bars, or select both x and y to create a bar plot of y

using the x data to label the bars.

Click the 8 button on the Plots 2D palette. (If any of the

= A
values in the column is negative, click the & button instead.)



Plotting One-Dimensional Data

To create a horizontal bar plot, select the columns in reverse order

and click the &= button.

Vertical bar with base at Y min plot [l Horizontal bar plot &=
R o /] L,
0.7 K
N
_ B g ‘
H |
-0t S —
<]
] |
=
€] |
MHHH ACEi ks N

T T T T T
X 0.40 0.45 0.50 0.55 0.60 0.65 0.70 0.75
y

Bar with base at zero plot [~

107

SR
™

If your data set contains a z column of error values, you can create a
bar plot of y using the z data for the error bars.

To create a bar with error plot:

1. Select the x, y, and z - : : : SIE
columns. : T

2. Click the lai button on Ll —— i
the Extra Plots
palette.
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For data arranged in multiple y columns, Spotfire S+ automatically
calculates and displays error bars. See the online help for details.

Bar with error plot |l
10 l
8 T
A T 11 L

Z |

Pareto Plots A Pareto plot is a bar plot sorted on the dependent variable combined
with a line plot displaying cumulative percentages of the categories
(bars). A histogram of descending percentages of each category is
plotted with a line plot displaying cumulative percentages. A Pareto
plot essentially combines the properties of a bar plot and a line plot.

To create a vertical Pareto

il pareto M=
plOt: 1 2 3 4 5 -
¥
1. Select an x column of ! ool xenon
mal N
categorical dataanday | Small 155,00
column of values. L | e o

2. Click the e button on
the Plots 2D palette.

To create a horizontal Pareto plot, select the columns in reverse order

and click the 1] button on the Extra Plots palette.
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j i ) &
Vertical Pareto plot i Horizontal Pareto plot
100 7
Large
80
van -
60 7 Sporty 7
Small~
40
Medium -
20 7
’—‘ Compact
0 T T T T T T i T T T T T
Compact Medium  Small  Sporty ~ Van Large 0 20 40 60 80 100
X y
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PLOTTING TWO-DIMENSIONAL DATA

Scatter and
Line Plots

>

132

0.48 7

0.46 7

0.44 1

0.42 7

0.40 7

0.38

Scatter and line plots are the most basic kinds of plots for displaying
data. You can use them to plot a single column of data or to plot one

data column against another.

To create any of the scatter/
line plots:

1. Select either the x or y
column to plot its
values  along  the
vertical axis against an

0.49

0.48

0.46

integer sequence along the horizontal, or select both x and y

to plot y against x.

2. Click the Plots 2D palette button corresponding to the
desired plot. (To create the high density line-Y zero plot,

click the I button on the Extra Plots palette.)

Scatter plot L

Line plot s

0.48 7

0.46 7

>0.44

0.42 7

0.40 7

0.38

T T T
20 30 40

T
20

T
30

T
40



0.48

0.46

>0.44

0.42

0.40

0.38

0.48

0.46

>0.44 |

0.42

0.40

0.38

0.48

0.46

>0.44

0.42

0.40

0.38

Line with scatter plot L

15 26 36 45
Vertical step plot L
15 25 35 45

Vertical high density line plot Lil

Plotting Two-Dimensional Data

Line with isolated points plot H

AN

0.48 1 '\\\

0.46 7 ° he

\'\_/

0.42 7 °

>0.44

\./.\07. - .
NN\
0.40 | L

0.38 T T T T
10 20 30 40

Horizontal step plot =

0.48

0.46

>0.44 7

0.42

0.40

0.38

Horizontal high density line plot E

048 77—

0.46 7

>0.44 7

0.42

0.40

0.38 T T T T
10 20 30 40
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High density line-Y zero plot ot

0.4

0.2

0.0 7

-0.2 1

-0.4 1

T
10 20 30 40

Curve-Fitting A curve-fitting plot displays a regression line with a scatter plot of the

Plots associated data points. Regression lines are generated using an
ordinary least-squares analysis to calculate y values for given values of
%, using a transformed model where appropriate.

To create any of the curve-

o
fitting plots: : 2 5 r 5 =
1. Select the x and vy : I B
Columns. 3 12:EIEI D:4ﬁ _
9. Click the Plots 2D -
palette button

corresponding to the desired plot.

Linear least squares curve-fitting plot Vs Polynomial curve-fitting plot le=?

0.48 * 0.48 7

0.46 0.46

0.44 ~0.44

0.42
0.427

0.40 7

0.38 7

0.38
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Exponential curve-fitting plot 2 Power curve-fitting plot £

0.48

0.46

0.44

0.42

0.40

0.38

T
10

T T T
20 30 40

0.48 1

0.46

0.44

0.42 1

0.40

0.38

Log base 10 curve-fitting plot it Log base e curve-fitting plot &

0.48 7

0.46 7

0.44 7

0.42

0.40

T
10

Nonlinear
Curve-Fitting
Plots

T T T
20 30 40

0.38

Nonlinear curve fitting fits a user-defined model to a set of data
points. Because you must specify a model and initial values for every
parameter in the model, simply selecting your data and clicking the
plot button does not automatically generate the plot. Instead, a new
Graph Sheet is opened with a plot icon in the upper left-hand
corner. To generate the plot, double-click the plot icon to open the
Nonlinear Curve Fitting dialog and specify the required
information in the appropriate fields. For detailed information on
producing this type of plot, see the online help.
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Smoothing
Plots

136

L.

To create an NLS plot:

Select the x column as

the independent
variable and the vy
column as the

dependent variable.

i nonlinear [0 x]
1 2 g 4 5 -
wMonlin yionlin
1 8.0 0.49 8.00 0.49
2 10.00 0.48 8.34 0.49
3 12.00 0.46 8.69 0.48
‘] 1aon e el ) ol

Click the s button on the Plots 2D palette. See the online

help.
Nonlinear least squares curve-fitting plot s

06 |
06 |

o ]
0z |
00 |
0.38 . 1‘0 2‘0 3‘0 4‘0

Scatterplot smoothers are useful for fitting arbitrary smooth functions
to a scatter plot of data points.

To create any of the smoothing

plots:

L.

Select the x and y
columns.

Click the Plots 2D
palette button

ismnﬂlh _ (O] %]
1 2 3 4 5 »
1 .00 0.49
2 10.00 0.48
3 12.00) 0.46
[« 1 P

corresponding to the desired plot.



Loess smoothing plot =

0.48

0.46 |

>0.44

0.42

0.40

0.38

0.48

0.46

0.44

0.42

0.40

0.38

T . .
10 20 30 40

Robust LTS smoothing plot B4

T . . :
10 20 30 40

Kernel smoothing plot |

0.48

0.46

>0.44 7

0.42

0.40

0.38

T . . :
10 20 30 40

Plotting Two-Dimensional Data

Spline smoothing plot lee?

Robust MM smoothing plot 2

0.48
0.46
>\0.44 7
0.42

0.40

0.38

T . . ‘
10 20 30 40

Friedman super smoothing plot |&

0.48 1

0.46

>0.44 7

0.42

0.40 1

0.38 : : ‘ ‘
10 20 30 40
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Text as A text as symbols plot is just a special kind of line/scatter plot, with
Symbols Plots text strings used as plotting symbols.

To create the text as symbols

plOt: ﬁ

H

2.0 0.49
10.00 0.48
12.00 0.46

1. Select the x, y, and z :
columns, with the z [=
column text used as the Ll 17
plotting symbols.

Ho|le| e

2. Click the [=2 button on the Plots 2D palette.

B
Text as symbols plot [+
A
0.48 7 B
0.46 7 C F
D
>0.44 1 E
0.42 G |
H J K M 0
0.40 1 L N P
QR

0.38 T T T T

10 20 30 40

Y Series Plots A Y series plot is just a special kind of line plot that plots multiple
series on the same graph. The data are plotted along the vertical axis
against a common, automatically-generated integer sequence along
the horizontal. You can replace the integer sequence with more
appropriate labels, such as times or dates, by using the X Axis
Labels dialog. For details, see the online help.

To create a Y series plot:

i . series =
1. Select the y1 and y2 e - - =
columns. L 0o L4
2 0.13 1.08
3 0.14 1.50 -
2. Click the e button on Ll ip

the Plots 2D palette.
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XY Pairs Line
Plots

Plotting Two-Dimensional Data

Y series plot [

-1 T T T T T T T T
1993 1994 1995 1996 1997 1998 1999 2000

An XY pairs line plot lets you plot multiple sets of x and y pairs on a
common set of axes.

To create an XY pairs line

plOtI 1 2 3 4 5 -
x1 y1 %2 y2
1. Select the xI, y1, x2, |* [ os o oo
2 10.00 .48 10.00 .45
and y2 columns. 3 12.00 0.46 12,00 0.4 .
B . e . . » |
9. Click the ¥ button on
the Plots 2D palette.
XY pairs line plot =4
0.47 7
0.43 7
0.39 7
0.35 T T T T T T
5 10 15 20 25 30 35

139



Chapter 4 Creating Plots

Grouped Box A grouped box plot consists of side-by-side box plots describing

Plots multiple columns of data. The number of rows in the x column
determines the number of boxes, and the number of rows in the y
column must be evenly divisible by the number of rows in x.

To create a vertical grouped

box plOt: 1 2 a 4 5 =
B ¥
1.0 10,91
2,00 10.37|
3.00] 13.00]

1. Select the x and vy
columns.

win e

2. Click the e button on
the Extra Plots palette.

To create a horizontal grouped box plot, click the & button instead.

Vertical grouped box plot L] Horizontal grouped box plot |

16 7
|

141

1 L T E I H

Grouped Bar A grouped bar plot displays data as clusters of bars. The x values are

Plots the labels. Multiple y columns determine the bar heights; that is, the
height of the first bar in each group is determined by the values in the
first y column, the height of the second bar in each group by the
values in the second y column, etc.

To create a vertical grouped
bar plOt: ﬁ

¥l y2 w3
1. Select the x and 109 68y 6w 1&
multiple y columns.

1993 1.19 4.13 7.79
1999 6.14 3.74 4.42

w e

2. Click the W button on
the Plots 2D palette.
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Plotting Two-Dimensional Data

To create a horizontal grouped bar plot:

1. Select the multiple y columns first, then CTRL-click to select

the x column last.

2. Click the = button on the Plots 2D palette.

Vertical grouped bar plot il

Horizontal grouped bar plot =

To produce a grouped bar with error plot using a palette button, you
must first stack all of your y data into a single column. Then create a z
column of the same length containing the values to use for the error
bars. Note that error bars cannot be automatically calculated for

grouped bar plots.
To create a grouped bar with
error plot: 1 2 2 7 s =
1. Select the x, y, and z |* 5] eed  na
2 1998 1.19) 0,30
columns. E 1999 6,14 030
KIS = i o AW
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Chapter 4 Creating Plots

2. Click the i button on the Extra Plots palette.

Grouped bar with error plot

Stacked Bar

A stacked bar plot displays data in stacks of bars. The x values are the

Plots labels. Multiple y columns determine the bar segment heights; that is,
the height of the bottom segment in each stack is determined by the
values in the first y column, the height of the middle segment in each
stack by the values in the second y column, etc. Note that error bars
cannot be displayed in stacked bar plots.

To create a vertical stacked bar

plOtZ 1 E E 4 5 B
x i ¥2 ¥3
1. Select the x and [! e L I T
i 2 1098 119 4.13 7.79)
multlple Yy Columns. a 1999 6.14 374 4.42)

2. Click the [l button on
the Plots 2D palette.

To create a horizontal stacked bar plot:

1. Select the multiple y columns first, then CTRL-click to select

the x column last.
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9. Click the B button on the Plots 2D palette.

Vertical stacked bar plot [ Horizontal stacked bar plot =

15
2000

1999

1998

1997

I T T T T T T T T
1997 1998 1999 2000 0 2 4 6 8 10 12 14 16

X y
Polar Plots A polar plot displays data in polar coordinates.
To create a polar scatter plot:
3l polar M
1. Select the x (radius : : : : =7
values) and y (angle |2 o o
Values) columns. E EI:E‘EI 1:26

9. Click the * button on
the Extra Plots palette.

To create a polar line plot, click the “® button instead.

Polar scatter plot E Polar line plot e

/ —
- ~ \
\
/ S \
} \\ \‘
| \ \ \
l

o | | | [ | | |
038 075 113 038 075 1.13
N A / / \ A / /
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PLOTTING MULTIDIMENSIONAL DATA

3D Scatter and 3D scatter and line plots display multidimensional data in three-

Line Plots dimensional space. 3D regression plots, which are just special kinds of
3D scatter and line plots, draw a regression plane through the data
points.

To create any of the 3D
scatter/line plots:

1 49 3
2 3 49
3

1. Select the x, y, and z

columns. 10 48 10 _
9. Click the Plots 3D -
palette button

corresponding to the desired plot.

3D scatter plot 3D line plot =

12

3D line with scatter plot &
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Plotting Multidimensional Data

3D regression plot & 3D regression with scatter plot Cd

Bubble and Bubble and color plots are scatter plots that let you represent an
Color Plots additional dimension by varying the size or color of the plotting
symbol.

To create a scatter plot of y
against x with the z data
represented as bubbles of

1 8.0 0.49 8.00

varying size (bubble plot) or |2 EW os e
bubbles of varying color (color j_l e — ] w
plot): '

1. Select the x, y, and z columns.

2. TFor a bubble plot, click the L= button on the Plots 2D palette.
For a color plot, click the L* button.

Bubble plot L= Color plot L

0.47 7
0.42 7

°
oo o0 0.37
0.37 7 L]

0.32 T T T T
0.32 T T T T 10 20 30 40
10 20 30 40 X
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Bubble Color
Plots

A bubble color plot is just a combination of a bubble plot and a color
plot.

To produce a scatter plot of y

! .
against x with the z data [T« | 2 | s | & | s |=
% ¥ z
represented as bubbles of |, .
varying size and the w data |2 E ICEE BCE: BT
2 10,00/ 0.4g 10,00/ 10,00/
represented as bubbles of | o o o tE
4

varying color:

1. Select the x, y, z, and w columns.

2. Click the H button on the Plots 2D palette.

Bubble color plot -
0.47 .
[ ]
[ ] [ ]
[ ]
e o 0 [ ]
0.42 7 L °
> [ ] [ N )
o e 0 [ ]
[ N )
0.37 [ ]
[ J
0.32 T T T T
10 20 30 40

High-Low Plots A high-low plot typically displays the daily, monthly, or yearly high

146

and low values of a series, together with average or closing values,
and perhaps opening values. Meaningful high-low plots can thus
include from three to five columns of data. The first column selected,
containing the x data, is used to label the x-axis. The final two
columns represent the high and low data values. Average data, or
open and close data, should be selected as the y or y and z columns,
respectively.

To create a high-low-close or

.
high-low-average plot: Tt | 2 | 3 | % | 5 [=
X close high I
1. Select the X, close or 1 ol 261937 263064 258401
2 1/2/00  2547.75 261050 253423
average, hi g h, and Tow 3 1/3/00) 261577 2628.83  2546.17
columns. Ll | iy




Candlestick
Plots

Plotting Multidimensional Data

2. Click the [# button on the Plots 2D palette.
High-low plot ]

2620

2580

2540 1

2500 T T T T T T T
1/1/00  1/2/00 1/3/00 1/4/00 1/5/00 1/6/00 1/7/00

To create a high-low-open-

close plot: : 2 5 : 5 | =
X open close high (=
1. Select the X, open, 1 1o 2seeB1  2619.37  2639.64)  2584.01
2 1/2/00 259139 254775 2619.50  2534.23
clos e, hi g h, and Tow a 1/3/00 259681 261577 2628083  2546.17
data (in that order). Lol | 7

2. Click the [H button on
the Plots 2D palette.

High-low-open-close plot 4]

2620

2580

2540

2500 T T T T T T T
1/1/00 1/2/00 1/3/00 1/4/00 1/5/00 1/6/00 1/7/00

A candlestick plot, a variation on the high-low-open-close plot,
displays the difference between the open value and the close value as
a filled rectangle. The color of the rectangle shows whether the
difference is positive or negative.
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To create a candlestick plot:

L.

Select the x, open,
close, high, and low
data (in that order).

Click the all button on
the Plots 2D palette.

Candlestick plot [t

1 2 3 4 5l o
H open close high low
1 1/, 2588.81) 2619.37 2639.64 2584.01]
2 1/2/00 2591.39 2547.75 2619.59 2534.23
3 1/3/00 2596.81] 2615.77 2628.83 2546.17
B PPV e ) B ——— m_’l_j!

2620 ﬁ
2580
2540

2500 T

T T T T
1/1/00 1/2/00 1/3/00 1/4/00 1/5/00 1/6/00 1/7/00

Error Bar Plots An error bar plot displays a range of error around plotted data points.
The x values determine the positions of the bars along the x-axis. If
your data set contains an x column and multiple y columns, Spotfire

S+ automatically calculates and displays error bars. See the online
help for details.

To create a vertical error bar

plot:

L.

2.

Select the x, y, and z
columns to create an
error bar plot of y
using the z data to
display error bars.

il error_bar _ (O] %]
1 2 2 4 S -
% ¥ z
1 4.6 4473 -8.00
2 9.61] 57.65| 16,96
2 14,04 -30.66) -25.28
‘] e i e S

Click the il button on the Plots 2D palette.

To create a horizontal error bar plot, select the x and y columns in

reverse order and click the & button.
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. g . )
Vertical error bar plot [ Horizontal error bar plot =
150 ey
[ 40
1007
e
o 1 I I 20
- 3 < e
0 i
L 20 [l
-50 1 { e
‘{ 10 7 F——
-100 7
[
-150 T T T T 0 .
0 10 20 30 40 150 -100 50 0 50 100 150

To create a plot with both

vertical and horizontal error ﬁ,
barS: 1 - 4.6 y44‘73 2-3‘00 W-Q‘UD

1. Select the x, y, z, and w - e '

columns to create an Julo T oo mm I

error bar plot using the
z data to display horizontal error bars and the w data to
display vertical error bars.

2. Click the e button on the Plots 2D palette.
Error bar—both plot e

150

100

A I

-150

Vector Plots A vector plot displays the direction and velocity of flow at positions in
the x-y plane. You can also use vector plots to draw any group of
arrows using the data in a data set.
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To create a vector plot:

L.

Area Charts

& vector

0.21f

0.22|

0.22|

Select the x, y, z (angle - : :
values), and w3 o
(magnitude Values) 3 D:El D:lEI 72153
columns. [« ]
Click the |24 button on
the Plots 2D palette.
Vector plot EX
1.9 7
N A \ i v
Ll OO ﬁ

e e U

-0.17

'
b
b1

T
0.0 0.5

affects the whole over time.

To create an area chart:

L.

Select the x column
and a single y column
to draw an x,) curve
and fill the area
beneath the curve.

T
2.0

An area chart is useful for showing how each series in a set of data

¥1

119.37|

34.01)

10264

47,79

34.23

82,59

115.77|

46,17

91.83

Select x and multiple y columns to draw a curve for each set
of values and fill the area beneath each curve.

9. Click the M button on the Plots 2D palette.
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Scatterplot
Matrices

Plotting Multidimensional Data

Area chart L]

0
1994

1995 1996

1997

X

1

998

1999

2000

A scatterplot matrix is an array of pairwise scatter plots showing the
relationship between any pair of variables in a multivariate data set.

To create a scatterplot matrix:

1. Select the x, y, and z - - - - =z
columns 1 0.7 0.87] 0.84
: 2 0.41 0.73 0.70

) & o T T e B

2. Click the E& button on < P

the Plots 2D palette.

Scatterplot matrix

02 04 06 08 10 ‘
] R o 12
4 . - L
.ot s oo [
4 . . |-
: LN ] * : L] . ° 08
| . . D Fos
e .
- .... L] .... L] 0.4
] oS s tad L
w337 PO 02
| Fo.0
1.07 oo o e |
o 0 ~
0s] HED ’ i
o oo -
0.6 [ Dl y * r
o Kanl
g » ’
0.2
| eee o ° |
A - 0.9
o oo -
i e e » Fo7
R » 2
i 3;\. ~ Fo5
L . '
'- ’
i & ”~ 0.3
o : : : : :
00 02 04 06 08 1.0 12 03 0.5 0.7 0.9
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Contour/Levels 2D contour/levels plots are representations of three-dimensional data

Plots

152

in a two-dimensional plane. Each contour line represents a level or
height from the corresponding three-dimensional surface. Filled
contour plots use color between contour lines to differentiate between
the levels. 3D contour plots are identical to 2D contour plots except
that the contour lines are drawn in three-dimensional space.

You can create 2D and 3D contour plots from either gridded or
irregular data. For more information, see the online help.

To create any of the contour/
levels plots:

1 -2.0 -2.00| 128
2 -1.87| -2.00| 163
El -1.74| -2.00| 1.94

1. Select the x, y, and z
columns.

2. Click the Plots 2D or
Plots 3D  palette
button corresponding to the desired plot.

Contour plot EZ Filled contour plot =

: \j (¢

-




Plotting Multidimensional Data

Levels plot =

> 0

L 3

Surface/3D Bar A surface plot draws a mesh or grid of your data in three-dimensional
space, and a spline plot is a smoothed surface of gridded data. A 3D
bar plot is a gridded surface drawn with bars; for two variables, a 3D
bar plot produces a binomial histogram showing the joint distribution
of the data. A color surface plot lets you specify color fills for the
bands or grids on a surface plot.

Plots

You can create surface and 3D bar plots from either gridded or
irregular data. For more information, see the online help.

To create any of the 3D
surface/bar plots:

1. Select the x, y, and z

1 -2.0 -2.00] 1.24|
2 -1.87| -2.00| 163
El -1.74| -2.00| 1.94

columns.
2. Click the Plots 3D
palette button

corresponding to the desired plot.

3D coarse surface plot &
% ‘\ AN

/G

A o

e

°
-
~

N

3D filled coarse surface plot &

W
T , TR

GO
(=2

NG
TGN

"“\\‘9;///’

N
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3D data grid surface plot &

Iy
7
A

3D filled data grid surface plot &

i
i

W
M. i
70
(A
7 75 o
s « i i
e - e 0%
- Al s 5
s - s
1919 990 <
s - e,
AN/ - W <
) I'ﬂ“ ° W
I% ,';';,4 . - W /4 +
> 9% P 9
Y 3 .
¥ o
3D 16 color surface plot -
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3D 32 color surface plot &

Comment A comment plot plots character data on a graph and can be used with

Plots all axes types. For a 2D comment plot, the x and y values specify the
x,y position of each comment, and the z values are the comment text.
If no z values are specified, the x,y coordinates are displayed on the
plot.

You can use comment plots to plot any character, or combination of
characters, as a symbol, to produce labeled scatter plots, to
automatically plot character data, and to create tables.

To create a comment plot:

1. Select the X, Y, and z 1 2 3 3 = =
columns 1 50 =
) 2 10.00 0.48 FEB|
3 12.00 0.46 MAR
: ] — <
2. Click the button on Ll 5
the Extra Plots
palette.
]
Comment plot
JAN
0.48 FEB
0.46 JUN
-
0.447 NOV
0.42 JuL
0.40 DEC
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Smith Plots
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Smith plots, which are drawn in polar coordinates, are often used in
microwave engineering to show impedance characteristics. There are
three types of Smith plots: reflection, impedance, and circle. Only
reflection plots can be produced automatically by clicking a palette

button.

In the Smith—reflection plot, the x values are magnitudes, which must
range between 0 and 1. The y values are angles, measured clockwise

from the horizontal.

To create a Smith—reflection
plot:

1. Select the x and vy

columns.

9. Click the ® button on
the Extra Plots palette.

il smith _ (O] %]
1 2 3 4 3 il
X
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In the Smith—impedance plot, the x values are resistance data and the

y values are reactance data.

To create a Smith—impedance
plot:

1. Select the x and vy
columns.

1 0.1 0.63]
2 0.20] 1.26|
3 0.30] 1.88




Plotting Multidimensional Data

9. Click the ® button on the Extra Plots palette.

3. Right-click a plot element and select Options from the
shortcut menu.

4. In the Data Options group, select Impedance in the Data
Type field.

5. Click OK.
Smith—impedance plot
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In the Smith—circle plot, the x values, which must be positive, specify
the distance from the center of the Smith plot to the center of the
circle you want to draw. The y values are angles, measured clockwise
from the horizontal. The z values are radii and must also be positive.

To create a Smith—circle plot:

1. Select the x, y, and z - . = : SR
columns. 1 0.1 063 010
2 0.20| 1.26| 0.20|
3 0,30 1.58| 0,30 -
9. Click the & button on s P
the Extra Plots
palette.

3. Right-click a plot element and select Options from the
shortcut menu.

4. In the Data Options group, select Circle in the Data Type
field.

5. Click OK.
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Chapter 4 Creating Plots

Projection plots are useful for combining multiple 2D plots in 3D

space and then rotating the results.
You can use either menus or drag-and-drop to create projection plots.

Most of the 2D plot types can be projected onto a 3D plane.
For details on creating projection plots, see the online help.

Projection
Plots
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Trellis Graphs

Trellis graphs let you view relationships between different variables in
a data set through conditioning. A series of panels is displayed, with
each panel containing a subset of the data divided into intervals of a
conditioning variable.

To create a scatter plot of y
against x conditioned on z

L.

Open the Plots 2D

1.0

5.11f 0.00]

740,80/

6,39 0.00]

palette and then click

the Set Conditioning

1407 47|

7.39 0.00]

Mode button on the

Standard toolbar. A yellow bar appears at the top of each

plot button in the palette.

2. Select the x, y, and z columns.

3. Click the E button on the Plots 2D palette.
Trellis graph

10 7

z:37.81098.9

| |
2:98.91099.9

T T
1000 3000 5000 7000

v

For more examples of Trellis graphs, see Trellis Graphs on page 96.
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INTRODUCTION

162

One easy method of getting data into Spotfire S+ for plotting and
analysis is to import the data from another source.

Spotfire S+ can read and write a wide variety of data formats, making
importing and exporting data easy. Spotfire S+ also supports the
Open DataBase Connectivity (ODBC) standard, allowing you to
import and export between Spotfire S+ and any ODBC-compliant
database.

You can also import data from the leading financial databases—
Bloomberg, FAME, and MIM—for statistical and graphical analysis.
To do this, you must load the financedb library from the main menu
by navigating to File » Load Library or from the Commands
window:

> Tibrary(financedb)

This library contains all the relevant functions for importing and
exporting data, including customizing the dialogs. Help is available
for all the financial-related functions from the Commands window,

and you can also access help from the main menu by navigating to
Help » Available Help » financedb.

In this chapter, we discuss each of these import/export options in
turn.
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SUPPORTED FILE TYPES FOR IMPORTING AND
EXPORTING

Table 5.1 lists all the supported file formats for importing and
exporting data. Note that Spotfire S+ both imports from and exports
to all the listed types with two exceptions: SigmaPlot (.jnb) files are
import only and HTML (htm*) tables are export only.

Note

As of Spotfire S+ version 8.2, native database drivers are deprecated. In lieu of these drivers, you
should use JDBC/ODBC drivers for all supported database vendors.

Table 5.1: Supported file types for importing and exporting data.

Default Exten-
Format Type sion Notes

ASCII File "ASCIT" .CSV Comma delimited.

.asc, .csv, .txt, | Delimited.

prat Whitespace ~ delimited;  space

.asc, .dat, .txt, | delimited; tab delimited; user-

.prn defined delimiter.
dBASE File "DBASE" .dbf I1, I1+, IT1, IV files.
DIRECT-DB2 "DIRECT-DB2" DB2 database connection. No file

argument should be specified.

DIRECT-ORACLE "DIRECT-ORA- | .ora Oracle database connection. No
CLE file argument should be specified.

DIRECT-SQL "DIRECT-SQL" Microsoft SQL Server database
connection. No file argument
should be specified. This option
is available only in Spotfire S+
for Windows.
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Table 5.1: Supported file types for importing and exporting data. (Continued)

Default Exten-

Format Type sion Notes
DIRECT-SYBASE "DIRECT- Sybase database connection. No
SYBASE™ file argument should be specified.

Epi Info File "EPT™ .rec

Fixed Format ASCII "FASCII" fix, fsc

File

FoxPro File "FOXPRO" .dbf

Gauss Data File "GAUSS™, .dat Automatically reads the related

"GAUSS96™ DHT file, if any, as GAUSS 89. If

no DHT file is found, reads the
DAT file as GAUSS96. GAUSS96 is
available in Unix only.

HTML Table "HTML" htm* Export only.

Lotus 1-2-3 Work- "LOTUS™ wk*, wr*

sheet

Matlab Matrix "MATLAB" .mat File must contain a single matrix.
Spotfire S+ recognizes the file's
platform of origin on import. On
export, specify type="MATLAB" to
create a pre-MATLAB 7 version
file; otherwise, specify
type="MATLAB7" to export the
MATLAB 7 file format.

Minitab Workbook “MINITAB” mtw Versions 8 through 12.

Microsoft Access File | "ACCESS” .mdb Microsoft Access file. This file

type is available only in Spotfire
S+ for Windows.
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Table 5.1: Supported file types for importing and exporting data. (Continued)

Default Exten-

Format Type sion Notes

Microsoft Excel "EXCEL™ x1? Versions 2.1 through 2010. Note

Worksheet "EXCELX" Xxlsx that "EXCELX" and the new file
extension, ".x1sx" are for files
imported from or exported to
Excel 2007 or 2010.

ODBC "0DBC" Not applicable For Informix (.ifx), Oracle (.ora),
and Sybase (.syb) databases. This
file type is available only in Spot-
fire S+ for Windows.

Oracle "Oracle” .ora Same as "DIRECT-ORACLE". Oracle
database connection. No file
argument should be specified.

Paradox Data File "PARADOX" .db

QuattroPro Work- "QUATTRO" wq?, .wh?

sheet

S-PLUS File "SPLUS" .sdd Windows, DEC UNIX. Uses
data.restore() to import file.

STATA “STATA” dta Portable across platforms
(UNIX, Windows, and Mac).

“STATASE” Can import STATA files and
éﬁ?P()’rt export STATA or STATASE.
Y
When exporting a STATA

dataset, you are limited to 2,047
characters. For larger STATA
datasets (up to 32,767 variables),
specify type="STATASE" .
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Table 5.1: Supported file types for importing and exporting data. (Continued)

Default Exten-

Format Type sion Notes
SAS File "SAS", sd2 SAS version 6 files, Windows.
"SASV6"
"SAS1", .ssd01 SAS version 6 files, HP, IBM,
"SAS6UX32" Sun UNIX.
"SAS4™, .ssd04 SAS version 6 files, Digital
"SAS6UX64" UNIX.
"SAST" .sas7bdat, .sd7 SAS version 7 or 8 files, current
platform.
"SASTWIN" .sas7bdat, .sd7 SAS version 7 or later data files,
Windows.
"SAS7UX32" .sas7bdat, .sd7 SAS version 7 or later data files,
Solaris (SPARC), HP-UX, IBM
AIX.
"SAS7UX64" .sas7bdat, .sd7 SAS version 7 or later data files,
Digital/Compaq UNIX.

SAS Transport File "SAS_TPT™ Xpt, .tpt Version 6.x. Some special export
options may need to be specified
in your SAS program. We suggest
using the SAS Xport engine (not
PROC CPORT) to read and
write these files.

“SAS_CPORT” stc, .cpt CPORT files created by SAS ver-
sions 7.01-9.01 can be imported.

SigmaPlot File "SIGMAPLOT" jnb Import only.

SPSS Data File "SPSS™ sav 0S/2; Windows; HP, IBM, Sun,

DEC UNIX.
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Table 5.1: Supported file types for importing and exporting data. (Continued)

Default Exten-

Format Type sion Notes

SPSS Portable File "SPSSP" .por

Stata Data File "STATA" .dta Versions 2.0 and higher.

Sybase "SYBASE" Same as "DIRECT-SYBASE". Sybase

database connection. No file
argument should be specified.

SYSTAT File "SYSTAT" syd, .sys Double- or single-precision .sys
files.

Note

All imports from and exports to Informix, Oracle, and SYBASE databases are done using
ODBC so the various ODBC components must be properly installed. See Importing From and
Exporting to ODBC Tables on page 179.
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IMPORTING FROM AND EXPORTING TO DATA FILES

Spotfire S+ provides convenient dialogs for importing and exporting
data. When importing most types of files, typically you only need to
specify the file’s name and type. By default, Spotfire S+ imports the
data into a new data set and displays it in a Data window.

Note

If you prefer not to have your imported data automatically displayed in a Data window, choose
Options » General Settings from the main menu, click the Data tab, and clear the Show
Imported Data in View check box.

When exporting to most types of files, usually all you need to do is
specify the data set you want to export and the new file’s name and
type. By default, Spotfire S+ exports the data into a new data file
using default settings.

Importing The Import From File dialog, shown in Figure 5.1 below, consists of
From a Data three tabbed pages labeled Data Specs, Options, and Filter. To
File open the dialog, do one of the following:

* From the main menu, choose File » Import Data » From
File.

* From the main menu, choose Data » Select Data. In the
Source group of the Select Data dialog, click the Import
File radio button and then click OK.
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Import From File = ]
[rata Specs | Options | Filker |
— From
File M ame: I
Browse |
File Eormat: I Unspecified file format j
~To
Diata set J5DF1 =l
& Create new data set
~ Add to existing data set
Start cal <END> =l
ak. I Cancel | Apply | I<| >| cLment Help |

Figure 5.1: The Data Specs page of the Import From File dialog.

Data Specs page, From group

File Name Specify the file you want to import by doing one of the

following:

*  Click Browse and navigate to the file.

If the file is in your current project folder, simply type the file

name, including its extension.

+ If the file is not in your current project folder, type the full

pathname of the file.

File Format Select the format of the file from the dropdown list in

this field.

Hint

In most cases, if you use Browse to specify the file to import, Spotfire S+ automatically selects

the correct format type.

169



Chapter 5 Importing and Exporting Data

Data Specs page, To group

Data set By default, Spotfire S+ creates a new data set with the same
name as the file being imported. To override the default name, type a
different name in this field. To import the data into an existing data
set, type or select its name.

Note

If the name you specify in the Data set field is the name of an existing object, by default Spotfire
S+ prompts you for an overwrite confirmation. To turn off this feature, choose Options »
General Settings from the main menu, click the Data tab, and clear the Prompt on import
overwrite check box.

Create new data set When selected, Spotfire S+ creates a new data
set with the name specified in the Data set field.

Add to existing data set When selected, Spotfire S+ imports the
data into the existing data set specified in the Data set field.

Start col By default, when you select Add to existing data set,
Spotfire S+ appends the imported data to the end of the data set. To
specify a different starting column, type or select its name in this field.

Note

After you make your selections on the Data Specs page of the Import From File dialog,
Spotfire S+ has the basic information necessary to import a data file. For greater control over
your importing parameters, use the Options and Filter pages, discussed below.
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The Options page of the Import From File dialog is shown in
Figure 5.2.
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Import From File = ]
[rata Specs | Options | Filker |

— General — &dditional
Lol names row IAuto 'l work sheet number
Bow name col IAuto VI IAuto jv

Start col I-I— V' Shings as factors
End col lm ¥ Sort factor levels

Start row |1 ™ Labels as rumbers
End row |<END> vl Century cutoff |1 930

—ASCH

Farmat string: I

Drelimiter I j

™ Separate Delimiters

Doate format: IM.-"d.-"yyyy - l
Time format: Ih:mm:ss It VI

Cancel | Apply | I<| >| current Help |
Figure 5.2: The Options page of the Import From File dialog.

Options page, General group

Col names row If the file you are importing contains column
names, type the number corresponding to the row in the file that
contains the column names. By default, Spotfire S+ attempts to
formulate sensible column names from the first imported row.

Row name col If the file you are importing contains row names,
type the number corresponding to the column in the file that contains
the row names.

Note

Because the underscore character is a reserved character in S-PLUS, Spotfire S+ replaces the
underscore (“_”) with a period (“.”) when importing column or row names.

“

Start col Type the number corresponding to the first data column to
be imported from the file. By default, Spotfire S+ begins reading from
the first column in the file.

End col Type the number corresponding to the last data column to
be imported from the file. The default is the last column in the file.
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Start row Type the number corresponding to the first data row to be
imported from the file. By default, Spotfire S+ begins reading from
the first row in the file.

End row Type the number corresponding to the last data row to be
imported from the file. The default is the last row in the file.

Options page, Additional group

Worksheet number When importing data from a spreadsheet such
as Excel or Lotus, specify the number of the worksheet you want to
import.

Strings as factors When selected, Spotfire S+ converts all character
strings to factor variables when the data file is imported. Otherwise,
character strings are imported with class character.

Sort factor levels When selected, Spotfire S+ (alphabetically) sorts
the levels for all the factor variables created from character strings.
Otherwise, the levels are defined in the order in which they are read
from the data file.

Labels as numbers When selected, SAS and SPSS variables that
have labels are imported as numbers. Otherwise, the value labels are
imported.

Century cutoff When importing an ASCII text file, this field
specifies the origin for two-digit dates. Dates with two-digit years are
assigned to the 100-year span that starts with this numeric value. The
default value of 1930 thus reads the date 6/15/30 as June 15, 1930,
while the date 12/29/29 is interpreted as December 29, 2029.

Options page, ASCII group

Format string This field is required when importing a formatted
ASCII (FASCII) text file. A format string specifies the data types and
formats of the imported columns. For more information on the syntax
accepted by this field, see Format Strings on page 191.

Delimiter Specify all characters used to separate elements in an
ASCII file. By default, Spotfire S+ uses the comma (,”).

Separate Delimiters When selected, the separator is strictly a single
character; otherwise, repeated consecutive separator characters are
treated as one separator.
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Date format Select the format you prefer to use when importing
date data. The available choices mirror those in your Windows
Regional Options; the default value for this field is the current
Windows default.

Time format Select the format you prefer to use when importing
time data. The available choices mirror those in your Windows
Regional Options; the default value for this field is the current
Windows default.

Note

To change the default delimiter for importing ASCII files, choose Options » General Settings
from the main menu and then click the Data tab. In the ASCII Import/Export Options group,
type your preferred default in the Import Delimiter field.

The Filter page of the Import From File dialog is shown in Figure
5.3.

Import From File M= EI

[rata Specs | Options | Filker |

— Columns ta impart

Show names

Select columns -
v

— Filter colurnn:

Filter expression: I

Al col names: I

Eancell Apply | I<| >| current Help |

Figure 5.3: The Filter page of the Import From File dialog.

Filter page, Columns to import group

Select Columns Specify the columns you want to import by clicking
the Show Names button and selecting the columns from the list in
this field.
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Filter page, Filter colum

Filter expression By

ns group

specifying a query, or filter expression, you

can subset the data you import. By default, this field is blank, resulting
in all the data being imported. For more information on the syntax
accepted by this field, see Filter Expressions on page 187.

Alt col names If the
contain column names

data file you are importing either does not
or contains names that you want to replace,

type a comma-delimited list of names that you want to use in this

field.

Exporting to a
Data File

The Export To File dialog, shown in Figure 5.4 below, consists of
three tabbed pages labeled Data Specs, Options, and Filter. To

open the dialog, do the following:

* From the main menu, choose File » Export Data » To File.
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Export To File M= EI
[rata Specs | Options | Filker |
From
lrgata frame I j
To
File M ame: I
Browse |
Filez of Type: IASEII file - whitezpace delimited [azcdat:tst:pm] j
ak. I Cancel | Apply | I<| >| cLment Help |

Figure 5.4: The Data Specs page of the Export To File dialog.

Data Specs page, From group

Data frame Type or select the name of the data set you want to

export.
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Data Specs page, To group

File Name By default, Spotfire S+ creates a new data file with the
same name as the data set being exported and saves it in your current
project folder. To save the file in a different location, click Browse
and navigate to the desired folder. You can also replace the default
file name with a different name.

Note

If the name you specify in the File Name field is the name of an existing file, Spotfire S+
prompts you for an overwrite confirmation.

Files of Type Select the desired format for the exported file from
the dropdown list in this field. The file extension is automatically
reflected in the File Name field.

Note

After you make your selections on the Data Specs page of the Export To File dialog, Spotfire
S+ has the basic information necessary to export a data set. For greater control over your
exporting parameters, use the Options and Filter pages, discussed below.

The Options page of the Export To File dialog is shown in Figure
5.5.

Export To File M= EI

[rata Specs | Options | Filker |

—E |
General

V' Column names

™ Bow MNames

V' Quates

— Formatting

Earmat string: I

Drelimiter l—
Doate format: m
Time format: lm

Eancell Apply | I<| >| current Help |

Figure 5.5: The Options page of the Export To File dialog.
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Options page, General group

Column names When selected, Spotfire S+ includes the column
names of the data set as the first row in the file.

Row Names When selected, Spotfire S+ includes the row names of
the data set as the first column in the file.

Quotes When selected, Spotfire S+ exports factor and character
variables as character strings enclosed with quotation marks.

Options page, Formatting group

Format string When exporting to an ASCII text file, specify the
data types and formats for the exported columns. For more
information on the syntax accepted by this field, see Notes on
Importing and Exporting Files of Certain Types on page 190.

Delimiter When exporting to an ASCII text file, specify the
delimiter to use to separate the elements in the file. By default,
Spotfire S+ uses the comma (,”).

Date format Select the format you prefer to use when exporting
date data. The available choices mirror those in your Windows
Regional Options; the default value for this field is the current
Windows default.

Time format Select the format you prefer to use when exporting
time data. The available choices mirror those in your Windows
Regional Options; the default value for this field is the current
Windows default.
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The Filter page of the Export To File dialog is shown in Figure 5.6.

Export To File M= EI

[rata Specs | Options | Filker |

— K.eep or drop column:
[~ Preview column names

Select columnz |<ALL> j

* Keep selected
" Drop selected

— Filter ro

™ Preview row names

Select Bows |<ALL> j

Filter expression: I

Eancell Apply | I<| >| current Help |

Figure 5.6: The Filter page of the Export To File dialog.

Filter page, Keep or drop columns group

Preview column names When selected, Spotfire S+ populates the
Select columns dropdown list with the column names of the data set
you are exporting.

Select columns Depending upon your choice of Keep selected or
Drop selected, specify either the columns you want to export or the
columns you do not want to export, respectively. When Preview
column names is selected, this field becomes a dropdown list from
which you can make your selections. When Preview column names
is not selected, you must type a column list of names (see Creating a
Column List on page 32) in this field.

Keep selected When selected, Spotfire S+ exports only the columns
you specify in the Select columns dropdown list.

Drop selected When selected, Spotfire S+ exports all columns
except those you specify in the Select columns dropdown list.

Filter page, Filter rows group

Preview row names When selected, Spotfire S+ populates the
Select Rows dropdown list with the row names of the data set you
are exporting.
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Select Rows Specify the rows you want to export in this field. When
Preview row names is selected, this field becomes a dropdown list
from which you can make your selections. When Preview row
names is not selected, you must type a row list of numbers (see
Creating a Row List on page 36) in this field.

Filter expression By specifying a query, or filter expression, you
can subset the data you export. By default, this field is blank, resulting
in all the data being exported. For more information on the syntax
accepted by this field, see Filter Expressions on page 187.
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IMPORTING FROM AND EXPORTING TO ODBC TABLES

Applications such as Microsoft Access and Excel, as well as most
commercial databases (generically known as data sources), support
the Open DataBase Connectivity (ODBC) standard.

Designed to provide a unified, standard way to exchange data

Note

As of Spotfire S+ version 8.2, native database drivers are deprecated. In lieu of these drivers, you
should use JDBC/ODBC drivers for all supported database vendors.

between databases, ODBC has become widely supported. Each
application typically has an ODBC driver that allows the application
to accept or distribute data via the ODBC interface. Spotfire S+
supports ODBC versions 2.0 and 3.0.

Spotfire S+ provides convenient dialogs for importing data from and
exporting data to ODBC databases and applications that support the
ODBC specification. By default, Spotfire S+ imports an entire table
into an S-PLUS data frame and displays it in a Data window.
Similarly, Spotfire S+ exports an entire data set into an ODBC table
unless you specify otherwise.

Note

If you prefer not to have your imported data automatically displayed in a Data window, choose
Options » General Settings from the main menu, click the Data tab, and clear the Show
Imported Data in View check box.

The ODBC Data The ODBC Data Source Administrator manages database drivers

Source
Administrator

and data sources. You can find the ODBC Data Source Administrator
from the Windows Start menu. Click Control Panel »
Administrative Tools and look for the Administrator icon Data
Sources (ODBC).
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ODBC Drivers

Defining a
Data Source
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An ODBC driver is a dynamically linked library (DLL) that connects
an application or database to the ODBC interface. Applications call
functions in the ODBC interface, which are implemented in the
database-specific drivers. The use of drivers isolates applications from
database-specific calls in the same way that printer drivers isolate
word processing programs from printer-specific commands.

Spotfire S+ is automatically installed with an ODBC driver that
connects to Spotfire S+, but you must provide an appropriate ODBC
driver for your database. Contact your database vendor or a third-
party ODBC driver vendor for assistance.

To determine which drivers are already installed on your computer,
start the Administrator and click the Drivers tab. The name, version,
company, file name, and file creation date of each ODBC driver
installed on the computer are displayed. To add a new driver or to
delete an installed driver, use the driver’s setup program.

A data source is a logical name for a data repository or database. It
points to the data you wish to access, the application that has the data,
and the computer and network connections necessary to reach the
data. Adding or configuring a data source can be done using the
Administrator or from within Spotfire S+ (see the online help).

To add a data source, open the Administrator by double-clicking the
Administrator icon in the Control Panel. If you are running
Administrator 3.0, you can then click the tab that corresponds to the
type of DSN (Data Source Name) you wish to create. The type of
DSN controls access to the data source you are creating, as follows:

+ User DSNs are specific to the login account that is in effect
when they are created. They are local to a computer and
dedicated to the current user.

* System DSNs are local to a computer but not dedicated to a
particular user. Any user having login privileges can use a
data source set up with a System DSN.

» File DSNs are file-based data sources that may be shared
among all users that have the same drivers installed. These
data sources are neither dedicated to a user nor local to a
computer.
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Click the appropriate tab and then click the Add button. (If you are
running Administrator 2.0, you can create a User DSN by clicking the
Add button from the initial dialog. Or, to create a System DSN, click
that button and then the Add button in the subsequent dialog. File
DSNs are only available with Administrator 3.0.) The Create New
Data Source dialog appears.

Select the ODBC driver for the database you want to connect to and
click Finish. If the list of drivers in the Create New Data Source
dialog is empty or does not contain a driver for your database or
application, you need to install the database or its ODBC driver.

At this point, a driver-specific dialog should appear asking database-
and driver-specific information required to connect to the database.
Fill in the required fields and click OK. The new data source should
be visible the next time the Import From ODBC or Export to
ODBC dialogs are launched from Spotfire S+.

The Import From ODBC dialog, shown in Figure 5.7 below,
consists of two tabbed pages labeled ODBC and Filter. To open the
dialog, do the following:

* From the main menu, choose File » Import Data » From
ODBC Connection.

Import From ODBC M= EI
0DBC | Fiter |
— From
DataSowee  |<SELECT SOURCE> |
Add Sources... | Modify Source... |
Table Mame I j
SOL Query ;I
H
~To
Data frame ISDF‘I j
Start cal |<END> =l

& Inzert at start col

" Owvenarite target

QK I Eancell Applyl I<| >| current Help |

Figure 5.7: The ODBC page of the Import From ODBC dialog.
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ODBC page, From group

Data Source Select the desired data source from the dropdown list
in this field.

Note

A data source consists of the data you want to access, the application that has the data, and the
computer and network connections necessary to reach the data. If the desired data source does
not appear in the Data Source dropdown list, or if the list is blank, you may need to configure
one or more data sources. To do so, either use the ODBC applet available in the Control Panel
or click the Add Sources (or Modify Source) button in the Import From ODBC dialog. For
more information on adding or modifying data sources, see the online help.

Table Name Once you select a data source, the dropdown list in
this field is populated with table names. Select the table you want to
import. By default, the first table in the data source is selected.

SQL Query Specify any legal Structured Query Language (SQL)
statement in this field. When you select a table to import, a default
SQL query is generated for importing all the data in the table.

ODBC page, To group

Data frame By default, Spotfire S+ creates a new data set with the
same name as the table being imported. To override the default name,
type a different name in this field. To import the data into an existing
data set, type or select its name.

Start col By default, Spotfire S+ appends the imported data to the
end of the data set specified in the Data frame field. To specify a
different starting column, type or select its name in this field.

Insert at start col When selected, Spotfire S+ inserts the imported
data starting at the column specified in the Start col field.

Overwrite target When selected, Spotfire S+ overwrites any
existing data when importing.

Note

After you make your selections on the ODBC page of the Import From ODBC dialog, Spotfire
S+ has the basic information necessary to import an ODBC table. For greater control over your
importing parameters, use the Filter page, discussed below.
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The Filter page of the Import From ODBC dialog is shown in

Figure 5.8.
Import From ODBC M= E
ODBC | Fiter |
Filter expression: ;I
H

Eancell Apply | I<| >| cument Help |

Figure 5.8: The Filter page of the Import From ODBC dialog.

Filter expression By specifying a query, or filter expression, you
can subset the data you import. By default, this field is blank, resulting
in all the data being imported. For more information on the syntax

accepted by this field, see Filter Expressions on page 187.

Exporting to The Export to ODBC dialog, shown in Figure 5.9 below, consists of

P 8 P g gu

an ODBC Table two tabbed pages labeled ODBC and Filter. To open the dialog, do
the following:
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*  From the main menu, choose File » Export Data » To
ODBC Connection.

Export to ODBC M= E
ODBC | Fiter |
Fraom
’7Data frame I j
To
Diata Target [<SELECT TARGET> =l

Add Targets... | Modify Target...

Table Mame I

QK I Eancell Applyl I<| >| current Help |

Figure 5.9: The ODBC page of the Export to ODBC dialog.

ODBC page, From group

Data frame Type or select the name of the data set you want to
export.

ODBC page, To group

Data Target Select the desired data target from the dropdown list in
this field.

Note

A data target is the counterpart when exporting to a data source when importing. If the desired
data target does not appear in the Data Target dropdown list, or if the list is blank, you may
need to configure one or more data targets. To do so, either use the ODBC applet available in
the Control Panel or click the Add Targets (or Modify Target) button in the Export To ODBC
dialog. For more information on adding or modifying data targets, see the online help.
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Table Name By default, Spotfire S+ creates a new ODBC table with
the same name as the data set being exported. If you prefer, you can
replace the default table name with a different name.

Note

After you make your selections on the ODBC page of the Export To ODBC dialog, Spotfire S+
has the basic information necessary to export an ODBC table. For greater control over your
exporting parameters, use the Filter page, discussed below.

The Filter page of the Export to ODBC dialog is shown in Figure
5.10.

Export to ODBC M= EI
ODBC | Fier |

— K.eep or drop column:

¥ Preview column names

Select columnz |<ALL> j

* Keep selected
" Drop selected

— Filter ro

V' Preview row names

Select Bows |<ALL> j

V' Export Rownames

Eancell Apply | I<| >| current Help |

Figure 5.10: The Filter page of the Export to ODBC dialog.

Filter page, Keep or drop columns group

Preview column names When selected, Spotfire S+ populates the
Select columns dropdown list with the column names of the data set
you are exporting.

Select columns Depending upon your choice of Keep selected or
Drop selected, specify either the columns you want to export or the
columns you do not want to export, respectively. When Preview
column names is selected, this field becomes a dropdown list from
which you can make your selections. When Preview column names
is not selected, you must type a column list of names (see Creating a
Column List on page 32) in this field.
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Keep selected When selected, Spotfire S+ exports only the columns
you specify in the Select columns dropdown list.

Drop selected When selected, Spotfire S+ exports all columns
except those you specify in the Select columns dropdown list.

Filter page, Filter rows group

Preview row names When selected, Spotfire S+ populates the
Select Rows dropdown list with the row names of the data set you
are exporting.

Select Rows Specify the rows you want to export in this field. When
Preview row names is selected, this field becomes a dropdown list
from which you can make your selections. When Preview row
names is not selected, you must type a row list of numbers (see
Creating a Row List on page 36) in this field.

Export Rownames When selected, Spotfire S+ includes the row
names of the data set as the first column in the ODBC table.



Filter Expressions

FILTER EXPRESSIONS

Variable
Expressions

By including a logical expression in the Filter expression field of the
import/export dialogs, you can subset the data you import or export.
The filter expression must be written in terms of the original column
names in the file and not in terms of the variable names specified by
the Col names row field.

Note also that the filter is not evaluated by Spotfire S+, meaning that
expressions containing built-in Spotfire S+ functions (such as mean)
are not allowed. One special exception to this rule deals with missing
values—while you can use NA to denote missing values in logical
expressions, you cannot use NA-specific functions such as is.na and
na.exclude.

To construct a variable expression, specify a single variable or an
expression involving several variables. In addition to the usual
arithmetic operators [+ - * / ()] that are available, Table 5.2 lists

the relational operators that are accepted by the Filter expression
field.

Table 5.2: Relational operators.

Operator Description

== Equal to

1= Not equal to

< Less than

> Greater than

<= Less than or equal to

>= Greater than or equal to
& And
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Table 5.2: Relational operators. (Continued)

Operator Description

| Or

! Not

For example, to select all rows that do not have missing values in the
id column, type

id I= NA

To import all rows corresponding to 10-year-old children who weigh
less than 150 pounds, type

Age == 10 & Weight < 150

Note

When constructing a filter expression, be sure to type the variable name on the left side of the
relational operator. For example, type Age > 12, rather than 12 < Age.
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You can also use the wildcard characters ? (for single characters) and
* (for strings of arbitrary length) to select subgroups of character
variables. For example, the expression

account == 27?722

selects all rows for which the account variable is six characters long
and ends in 22. The expression

id == 3%

selects all rows for which id starts with 3, regardless of the length of
the string.

To import specific row numbers, use the built-in variable @rownum.
For example, the expression

@rownum < 200

imports the first 199 rows of a data file.
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Sampling Three functions that permit the random sampling of data are
Functions available for use in filter expressions:

samp.rand allows for simple random sampling. This function
accepts the single numeric argument prop, where 0 < prop <
1. Rows are selected randomly with a probability equal to
prop.

samp.fixed selects a random sample of fixed size. This
function accepts two numeric arguments, sample.size and
total.observations. The first row is drawn with a
probability of sample.size/total.observations. The ith row
is drawn with a probability of (sample.size - i)/
(total.observations - i), where i=1, 2, ..., sample.size.

samp.syst performs a systematic sarnple of every nth case
after a random start. This function accepts the single numeric
argument n.

Because expressions are evaluated from left to right, you can sample a
subset of rows in a data file by first subsetting and then sampling. For
example, to import a random sample of half the rows corresponding
to high school graduates, use the expression

schooling >= 12 & samp.rand(0.5)

The sampling functions use the S-PLUS random number generator to
create random samples. Therefore, you can use the set.seed function
in the Commands window to produce the same data sample
repeatedly. For more details, see the help files for set.seed and
.Random.seed.
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NOTES ON IMPORTING AND EXPORTING FILES OF
CERTAIN TYPES

ASCll
(Delimited
ASCII) Files

dBASE Files

Files With
Multiple Tables
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In this section, we offer some additional comments to help you when
importing and exporting data in particular file formats.

You have the option of specifying column names when importing
columns from an ASCII file. To do so, type a list of names, separated
by any of the delimiters specified in the Delimiter field, in the Alt
col names field. For each imported column, specify one column
name (for example, Apples, Oranges, Pears). You can use an
asterisk (*) to denote a missing name (for example, Apples, *, Pears).

A row of data must always end with a new line. Multiple delimiter
characters are not grouped and treated the same as single delimiters.
For example, if the comma is a delimiter, two commas are interpreted
as a missing field.

cc)a)

Double quotes (“”) are treated specially. They are always treated as an
“enclosure” marker and must always come in pairs. Data contained
within double quotes are read as a single unit of character data. Thus,
spaces and commas can be used as delimiters, and spaces and
commas can still be used within a character field as long as that field
is enclosed by double quotes. Double quotes cannot be used as
standard delimiters.

Note that when importing from or exporting to ASCII, Spotfire S+
truncates column names to 256 characters.

When importing dBASE and dBASE-compatible files, the file name
and file type are often the only things you need to specify. (Column
names and data types are obtained from the dBASE file.) However,
you can select a rectangular subset of the data by specifying starting
and ending columns and rows.

An application that can support multiple tables or data sets (such as
Informix, Microsoft Access, Microsoft SQL Server, Oracle, SAS,
SigmaPlot, SYBASE) will support exporting multiple tables or data
sets to a file. Spotfire S+ currently only supports importing the first
table from the file unless the file type is ODBC.



Formatted
ASCII (FASCII)
Files

Format Strings
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You can use FASCII import to specify how each character in the
imported file should be treated. For example, you must use FASCII
for fixed-width columns not separated by delimiters if the rows in the
file are not separated by line feeds or if the file splits each row of data
into two or more lines.

Column names cannot be read from a FASCII data file. If you want
to name the columns, type a list of names, separated by any of the
delimiters specified in the Delimiter field, in the Alt col names field.
For each imported column, specify one column name (for example,
Apples, Oranges, Pears). You can use an asterisk (*) to denote a
missing name (for example, Apples, *, Pears).

If each row ends with a new line, Spotfire S+ treats it as a single,
character-wide variable that is to be skipped.

If you want to import only some of the rows, specify a starting and

ending row.

Format strings are used when importing data from, or exporting data
to, fixed-format ASCII (FASCII) text files. A format string specifies
how each character in the imported file should be treated. You must
use a format string, together with the FASCII file type, if the columns
in the data file are not separated by delimiters.

Format strings for importing data

When importing data from a FASCII file, a valid format string
consists of a percent (%) sign followed by the data type for each
column in the file. Available data types are:

* s, which denotes a character string,
» f, which denotes a numeric value, and
+ the asterisk (*), which denotes a skipped column.

One of the characters specified in the Delimiter field must separate
each specification in the string. For example, the format string

ks, %f, B*, %f

imports the first column of the data file as type character and the
second and fourth columns as type numeric and skips the third
column altogether.
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If you specify a variable to be type numeric and the value of any cell
cannot be interpreted as a number, that cell is filled with a missing
value. Incomplete rows are also filled with missing values.

Note

Some dates in text files may be imported automatically as numbers. After importing data that
contain dates, you should check the class of each column and, if necessary, change it to the
appropriate data type.
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Format strings and field width specifications are irrelevant for regular
ASCII files and are therefore ignored. For FASCII files, however, you
can specify an integer that defines the width of each field. For
example, the format string

%4f, %6s, %3*, %6f

imports the first four entries in each row as a numeric column. The
next six entries in each row are read as characters, the next three are
skipped, and then six more entries are imported as another numeric
column.

Format strings for exporting data

When exporting data to a FASCII file, the syntax accepted by the
Format string field is similar to that for importing data. However, in
addition to the data type, the precision of numeric values can also be
specified. For example, the format string

%3, %7.2, B4, %5.2

exports the first and third columns as whole numbers of three and
four digits, respectively. The second and fourth columns each have
two decimal digits of precision.

If a precision value is not specified, it is assumed to be zero; if you
supply a precision value for a character column, it is ignored. Note
that when exporting row names, the first entry in the format string is
reserved for the row names.

Specifying a format string can potentially speed up the export of data
sets that have many character columns. If you do not include a format
string, Spotfire S+ must check the width of every entry in a character
or factor column and determine a width large enough for all values in
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Lotus Files

Microsoft
Access Files

Microsoft Excel
Files

Oracle Files

Notes on Importing and Exporting Files of Certain Types

the column. Since many of the supported file types use fixed widths,
considerable space can be saved by specifying a narrow width for
character columns that have many short values and only a few long
values. With this approach, the few long values are truncated.

All imports from and exports to Informix files are done using ODBC
so the various ODBC components must be properly installed.

If your Lotus-type worksheet contains numeric data only in a
rectangular block, starting in the first row and column of the
worksheet, then all you need to specify is the file name and file type.
If a row contains column names, specify the number of that row in
the Col names row field (it does not have to be the first row). You
can select a rectangular subset of the worksheet by specifying starting
and ending columns and rows. Lotus-style column names (for
example, A, AB) can be used to specify the starting and ending
columns.

The row specified as the starting row is always read first to determine
the data types of the columns. Therefore, there cannot be any blank
cells in this row. In other rows, blank cells are filled with missing
values.

All imports from and exports to Access files are done using ODBC,
so the various ODBC components must be properly installed.

If your Excel worksheet contains numeric data only in a rectangular
block, starting in the first row and column of the worksheet, then all
you need to specify is the file name and file type. If a row contains
column names, specify the number of that row in the Col names
row field (it does not have to be the first row). You can select a
rectangular subset of the worksheet by specifying starting and ending
columns and rows. Excel-style column names (for example, A, AB)
can be used to specify the starting and ending columns.

Note that when importing from or exporting to Excel, Spotfire S+
truncates column names to 256 characters.

All imports from and exports to Oracle files are done using ODBC so
the various ODBC components must be properly installed.
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When exporting to Oracle, table names and column names must be

in UPPERCASE.

SYBASE Files All imports from and exports to SYBASE files are done using ODBC
so the various ODBC components must be properly installed.
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The power of Spotfire S+ comes from the integration of its graphics
capabilities with its statistical analysis routines. In other chapters
throughout this manual, we introduce Spotfire S+ graphics. In this
chapter, we show how statistical procedures are performed in Spotfire

S+.

It is not necessary to read this entire chapter before you perform a
statistical analysis. Once you’ve acquired a basic understanding of the
way statistics are performed, you can refer directly to a section of
interest.

We begin this chapter by presenting general information on using the
statistics dialogs, and devote the remaining sections to descriptions
and examples for each of these dialogs.

Figure 6.1 displays many elements of the Spotfire S+ interface.
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Figure 6.1: Statistics-related menus and windows.



Introduction

Statistics menu: The Statistics menu gives you access to
most of the statistical procedures available in Spotfire S+. The
procedures are logically grouped, with submenus that allow
you to precisely specify the procedure you want to use. For
example, in Figure 6.1 the menu tree for summary statistics is
shown. It is selected by choosing Statistics P Data
Summaries » Summary Statistics.

Statistics dialogs: The open dialog shown in Figure 6.1
entitted Summary Statistics, and is used to specify which
data summaries to calculate.

Data menu (not shown): The Data menu, located to the left
of the Statistics menu, is used to access functions that
generate and manipulate data.

Data Window: The open window on the left in Figure 6.1 is
a Data window, which you can use to create or edit a data set.
See Chapter 2, Working With Data, for a detailed
introduction to the Data window.

Report Window: The Report window displays the results of
a statistical analysis. In the example in Figure 6.1, a Report
window shows the results of the summary statistics.

Graph Sheet (not shown): A Graph Sheet displays the
graphics created from the statistics menus.

Message Window (not shown): A Message window appears
only if an error, warning, or informational message is
generated by a statistics procedure. If you close a Message
window, it reappears the next time an informational message
is generated. You should regularly examine the contents of
the Message window to ensure that nothing out of the
ordinary occurs during your statistical analysis.
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Basic The basic procedure for analyzing data is the same regardless of the
Procedure type of analysis.

1. Select the data you want to work with.

2. Choose the statistical procedure (summary statistics, linear
regression, ANOVA, etc.) you want to perform from the
Statistics menu. The dialog corresponding to that procedure
opens.

3. Select the data set, variables, and options for the procedure
you have chosen. (These are slightly different for each dialog.)
Click the OK or Apply button to conduct the analysis. If you
click OK, the dialog closes when the graph is generated; if
you click Apply, the dialog remains open.

4. Check for messages. If a message is generated, it appears in a
Message window. If no Message window opens, then no
message was generated.

5. Check the result. If everything went well, the results of your
analysis are displayed in a Report window. Some statistics
procedures also generate plots.

If you want, you can change the variables, parameters, or options in
the dialog and click Apply to generate new results. Spotfire S+ makes
it easy to experiment with options and to try variations on your
analysis.

Dialogs Most of the statistical functionality of Spotfire S+ can be accessed
through the Data and Statistics menus.

The Data menu includes dialogs for tabulating data, calculating
distribution functions, and generating random samples and random
numbers. The Data menu also includes dialogs for manipulating
data, including sorting, stacking, and transforming data sets. See
Chapter 2, Working With Data for detailed information.

The Statistics menu includes dialogs for creating data summaries and
fitting statistical models. Many of the dialogs consist of tabbed pages
that allow for a complete analysis, including model fitting, plotting,
and prediction. Each dialog has a corresponding function that is
executed using dialog inputs as values for function arguments.
Usually, it is only necessary to fill in a few fields on the first page of a
tabbed dialog to launch the function call.
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Introduction

Many dialogs include a Data Set field. This field is automatically
filled in with the name of the data set most recently opened with
either File » Open or the Select Data dialog. To specify another
data set, you can either type its name directly in the Data Set field, or
make a selection from the dropdown list. The data sets that appear in
the dropdown list are limited to those that have been filtered by an
Object Explorer.

Most dialogs that fit statistical models include a Subset Rows field
that you can use to specify only a portion of a data set. To use a subset
of your data in an analysis, enter an S-PLUS expression in the Subset
Rows field that identifies the rows to use. The expression can
evaluate to a vector of logical values: true values indicate which rows
to include in the analysis, and false values indicate which rows to
drop. Alternatively, the expression can specify a vector of row
indices. For example:

* The expression Species=="bear" includes only rows for
which the Species column contains bear.

* The expression Age>=13 & Age<20 includes only rows that
correspond to teenage values of the Age variable.

* The expression 1:20 includes the first 20 rows of the data.
To use all rows in a data set, leave the Subset Rows field blank.

Some dialogs have Variables fields. These fields are automatically
filled in with the column names in the data set you have selected.

Some dialogs require a Formula, which is automatically filled in if
you have selected columns of a data set. The first selected column is
the response, and the remaining columns are the predictors. If you do
not want the formula that automatically appears, you can type
another one directly in the Formula field, or click the Create
Formula button to bring up a dialog that builds a formula for you.
Some dialogs, such as the Generalized Additive Models dialog,
require special formulas; in these cases, the special terms available are
listed in the Formula Builder.

Most dialogs have a Save As field that corresponds to the name of
the object in which the results of the analysis are saved. This object
may be manipulated in the Object Explorer to obtain additional
summaries or plots after the model has been fit. Many of the
modeling dialogs also have one or more Save In fields. The Save In

201



Chapter 6 Statistics

Plotting From
the Statistics
Dialogs
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field corresponds to the name of a data set in which new columns are
saved. Examples of new columns include fitted values, residuals,
predictions, and standard errors.

Most of the statistics dialogs produce default plots that are
appropriate for the analysis. Many have several plot options, usually
on a separate Plot tab.

By default, plots produced from the statistics dialogs are not editable.
If you prefer, you can change the default behavior for statistics dialogs
from traditional to editable graphics:

1. From the main menu, choose Options » Graph Options.
The Graphs dialog opens, as shown in Figure 6.2.

2. Check the Create Editable Graphics option in the
Statistics Dialogs Graphics group.

3. Click OK.
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Figure 6.2: The Options page of the Graphs dialog.

Help |

For faster performance, we recommend creating complicated plots
such as multipanel Trellis displays with traditional graphics. To
convert a non-editable graph into an editable one, right-click the data
part of the graph and select Convert to Objects from the context
menu.
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A statistical model object may be created by specifying a name for the
object in the Save As field of a dialog. Once the execution of a dialog
function completes, the object shows up in the Object Explorer.
Double-clicking on the object either displays results in a Data
window or prints a summary for the object. For model objects such as
the results from a linear regression, right-click context menus are
available. To display the related menus, right-click the model object
in the Object Explorer. Most menu choices correspond to the
tabbed pages from the dialog. This allows you to do plotting and
prediction for a model without relaunching an entire dialog. An
example for a linear model object is shown in Figure 6.3.
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Figure 6.3: The right-click context menu shown for a linear model object.
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SUMMARY STATISTICS

Summary
Statistics

204

One of the first steps in analyzing data is to create summaries. This
can be done numerically through the Summary Statistics,
Crosstabulations, and Correlations and Covariances dialogs.

* Summary Statistics: calculates summary statistics, such as
the mean, median, variance, total sum, quartiles, etc.

* Crosstabulations: tabulates the number of cases for each
combination of factors between your variables, and generates
statistics for the table.

¢ Correlations: calculates correlations or covariances between
variables.

These three procedures can be found under the Statistics » Data
Summaries menu. In addition, the Data » Tabulate dialog provides
a tabular summary of data and also creates a data set convenient for
use in Trellis graphs.

The Summary Statistics dialog provides basic univariate summaries
for continuous variables, and it provides counts for categorical
variables. Summaries may be calculated within groups based on one
or more grouping variables.

Computing summary statistics

From the main menu, choose Statistics » Data Summaries »
Summary Statistics. The Summary Statistics dialog opens, as
shown in Figure 6.4.



Summary Statistics

Diata | Statistics |

—Data Result

Data Set: air - Save Az Isummary.air

Wariables: V' Summarize Categorical Variables
ozone
radiation V' Print Results
temperature
wind
5 ies by Group

Group Y ariables:

020nE
radiation

temperature
wind

I Ewimum U nigue Wumene alues:
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Idumber of Bite fon W umernc Yalues:
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QK I Eancell Applyl I<| >| current Help |

Figure 6.4: The Summary Statistics dialog.

Example

We use the data set air. This data set measures the ozone
concentration, wind speed, temperature, and radiation of 111
consecutive days in New York. In this example, we calculate
summary statistics for these data.

L.
2.
3.

Open the Summary Statistics dialog.
Type air in the Data Set field.

Select the variables you want summary statistics for in the
Variables field. For this example, we choose <ALL> (the
default).

We want to print the results in a Report window and store
the results in a model object. Enter summary.air in the Save
As field to create an object of this name in which to store the
results. Spotfire S+ overwrites any existing variable with this
name without warning. Make sure that the Print Results
check box is selected to ensure that the results are printed in a
Report window.
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5. Click on the Statistics tab to see the statistics available. For
this example, select the Variance and Total Sum check
boxes.

6. Click OK. A Report window is created with the following
output:

*** Summary Statistics for data in: air ***

ozone radiation temperature wind

Min: 1.00 7.00 57.00 2.30

1st Qu.: 2.62 113.50 71.00 7.40
Mean: 3.25 184.80 77.79 9.94
Median: 3.14  207.00 79.00 9.70
3rd Qu.: 3.96  255.50 84.50 11.50
Max: 5.52 334.00 97.00 20.70
Total N: 111.00 111.00 111.00 111.00
NA's 0.00 0.00 0.00 0.00
Variance: 0.79 8308.74 90.82 12.67
Std Dev.: 0.89 91.15 9.53 3.56
Sum: 360.50 20513.00 8635.00 1103.20

7. If the above output is not displayed in a Report window,
check the Message window for error messages and correct
any problems that are reported.

8. To access the model object containing the results, use the
Object Explorer. To open the Object Explorer, click the

Object Explorer button " on the Standard toolbar.

9. Highlight the Data folder. In the right pane, double-click the
new data matrix called summary.air (the name we specified in
Step 7 above). This loads the summary statistics into a Data
window.

We are done. As you can see, calculating summary statistics is
straightforward. Other statistical procedures use the same basic steps
that we did in this example.
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The Crosstabulations dialog produces a table of counts for all
combinations of specified categorical (factor) variables. In addition, it
calculates cell percentages and performs a chi-square test for
independence. The Crosstabulations dialog returns results in an
ASCII formatted table.

The chi-square test for independence is useful when the data consist
of the number of occurrences of an outcome for various combinations
of categorical covariates. It is used to determine whether the number
of occurrences is due to the marginal values of the covariates, or
whether it is influenced by an interaction between covariates.

To construct a table of counts for use in further analysis, use the
Tabulate dialog available from the Data menu.

Computing crosstabulations

From the main menu, choose Statistics » Data Summaries »
Crosstabulations. The Crosstabulations dialog opens, as shown in
Figure 6.5.

Crosstabulations M= EI
Model | Options |
—Data Result
Data Set: Iclaims 'l Save Az I
Wariables: <ALLy &l | Frint Fesuls
age
cost -
LCounts Y ariable: Inumber vl
Subset Bows with: I
Method to Handle Missing Y alues:
IFaiI 'l
ak. I Cancel | Apply | I<| >| cLment Help |

Figure 6.5: The Crosstabulations dialog.

Example

Consider the data set claims, which has the components age,
car.age, type, cost, and number. The original data were taken from
8,942 insurance claims. The 128 rows of the claims data set represent
all possible combinations of the three predictor variables (columns)
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age, car.age, and type. An additional variable, number, gives the
number of claims in each cell. The outcome variable, cost, is the
average cost of the claims.

We can use a contingency table to examine the distribution of the
number of claims by car age and type. The corresponding test for
independence tells us whether the effect of age upon the likelihood of
a claim occurring varies by car type, or whether the effects of car age
and type are independent.

To construct a contingency table for the c1aims data:

L.
2.
3.

5.

Open the Crosstabulations dialog.
Type claims in the Data Set field.

In the Variables field, click on car.age and then CTRL-click
type. This selects both variables for the analysis.

In the Counts Variable field, scroll through the list of
variables and select number.

Click OK.

The table below appears in the Report window.

Call:

crosstabs(formula = number ~ car.age + type, data
claims, na.action = na.fail, drop.unused.levels

*** Crosstabulations ***

T

8942 cases in table

R +

N |

[N/RowTotal |

[N/ColTotal]|

[N/Total |

R +

car.age|type
|A |B |C |D |RowTotT |

------- e R R

0-3 | 391 |1538  |1517 | 688  |4134 |
|0.0946 |0.3720 |0.3670 |0.1664 |0.462 |
[0.3081 |0.3956 |0.5598 |0.6400 | |
|0.0437 ]0.1720 [0.1696 |0.0769 | |

——————— e R e e e =

4-7 | 538  |1746 | 941 | 324  |3549 |



Correlations

Summary Statistics

|0.1516 |0.4920 |0.2651 |0.0913 |0.397 |
|0.4240 |0.4491 |0.3472 |0.3014 | |
|0.0602 [0.1953 |0.1052 |0.0362 | |

8-9 | 187 | 400 | 191 | 44 |822 |
|0.2275 |0.4866 |0.2324 |0.0535 [0.092 |
|0.1474 |0.1029 |0.0705 |0.0409 | |
|0.0209 |0.0447 |0.0214 |0.0049 | |

10+ | 153 | 204 | 61 | 19  |437 |
|0.3501 |0.4668 |0.1396 |0.0435 |0.049 |
|0.1206 |0.0525 |0.0225 |0.0177 | |
|0.0171 |0.0228 |0.0068 |0.0021 | |

ColTot1|1269  [3888  |2710  |1075  |8942 |
|0.14  ]0.43 ]0.30 [0.12 | |

Test for independence of all factors
Chinr2 = 588.2952 d.f.= 9 (p=0)
Yates' correction not used

Each cell in the table contains the number of claims for that car age
and type combination, along with the row percentage, column
percentage, and total percentage of observations falling in that cell.
The results of the test for independence indicate that the percentage
of observations in each cell is significantly different from the product
of the total row percentage and total column percentage. Thus, there
is an interaction between the car age and type, which influences the
number of claims. That is, the effect of car age on the number of
claims varies by car type.

The Crosstabulations dialog is most useful for examining row and
column percentages and performing a test for independence. To
create a simpler table of data, use the Tabulate dialog as discussed on
page 211.

The Correlations and Covariances dialog produces the basic
bivariate summaries of correlations and covariances.
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Computing correlations and covariances

From the main menu, choose Statistics » Data Summaries »
Correlations. The Correlations and Covariances dialog opens, as
shown in Figure 6.6.

| o] x|

Comrelations and Covariances
—Data

— Statistic

Data Set: air - Tupe: + Comrelations

" Caovariances

FEraction ta Trim: ID
— Result

Wariables:

Method to Handle Missing Y alues: Save Az

I Fail =z l

V' Print Results

ak. I Eancell Applyl I<| >| cLment

Figure 6.6: The Correlations and Covariances dialog.

Help |

Example

In Summary Statistics on page 204, we looked at univariate
summaries of the data set air. We now generate the correlations
between all four variables of the data set. Here are the basic steps:

1. Open the Correlations and Covariances dialog.
2. Type air in the Data Set field.

3. Choose <ALL> in the Variables field.

4. Click OK.

The Report window displays the correlations between the four
variables:

***  Correlations for data in: air **x*
ozone radiation temperature wind
ozone 1.0000000 0.4220130 0.7531038 -0.5989278
radiation 0.4220130 1.0000000 0.2940876 -0.1273656
temperature 0.7531038 0.2940876 1.0000000 -0.4971459
wind -0.5989278 -0.1273656 -0.4971459 1.0000000

Note the strong correlation of 0.75 between ozone and temperature:
as temperature increases, so do the ozone readings. The negative
correlation of -0.60 between ozone and wind indicates that ozone
readings decrease as the wind speed increases. Finally, the correlation
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of -0.50 between wind and temperature indicates that the temperature
decreases as the wind increases (or that the temperature increases as
the wind decreases).

The Tabulate dialog creates a tabular summary of data from a data
set.

Creating a table

From the main menu, choose Data » Tabulate. The Tabulate
dialog opens, as shown in Figure 6.7.

Tabulate =10 =]

[rata — Optio:

Data Set: Ibarley VI M aximum Unique Mumeric Y alues:

10

Wariables:
Mumber of Bing for Mumeric Y alues:

e

— Result
IV Biint Table

Save [n: I
QK I Eancell Applyl I<| >| current Help |

Figure 6.7: The Tabulate dialog.

Example

The barley data set contains observations from a 1930s agricultural
field trial that studied barley crops. At six sites in Minnesota, ten
varieties of barley were grown for each of two years, 1931 and 1932.
The data are the yields for all combinations of site, variety, and year,

so there are a total of 6 X 10 X2 = 120 observations. Chapter 3,

Exploring Data, examines these data in a Trellis plot. In this example,
we tabulate the data in a variety of ways.

To tabulate the barley data:
1. Open the Tabulate dialog.
2. Type barley in the Data Set field.

3. Click the variable yield and then CTRL-click to select year
(the order of selection is important).

4. Click OK.
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The table below appears in a Report window.

*** Table of yield,year in barley ***

1932 1931
13.92000+ thru 22.64667 13 2
22.64667+ thru 31.37334 18 20
31.37334+ thru 40.10002 17 17
40.10002+ thru 48.82669 10 13
48.82669+ thru 57.55336 1 4
57.55336+ thru 66.28003 1 4

The yield has been divided into six “bins.” Note how the yield tends
to be higher in year 1931 than in year 1932.

More than two variables can be selected in the Tabulate dialog. For
example, try selecting yield, year, and variety (in that order) to
further subdivide the table into the ten varieties of barley.
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COMPARE SAMPLES

One-Sample
Tests

One-Sample
t Test

Spotfire S+ supports a variety of statistical tests for testing a
hypothesis about a single population. Most of these tests involve
testing a parameter against a hypothesized value. That is, the null

hypothesis has the form Hjy: © = © , where © is the parameter of

interest and @O is the hypothesized value of our parameter.

* One-sample { test: a test for the population mean L. We test

if the population mean is a certain value. For small data sets,
we require that the population have a normal distribution.

* One-sample Wilcoxon signed-rank test: a nonparametric

test for the population mean [L. As with the t test, we test if
the population mean is a certain value, but we make no
distributional assumptions.

* One-sample Kolmogorov-Smirnov goodness-of-fit test: a
test to determine if the data come from a hypothesized
distribution. This is the preferred goodness-of-fit test for a
continuous variable.

* One-sample chi-square goodness-of-fit test: a test to see if
the data come from a hypothesized distribution. This is the
preferred goodness-of-fit test for a discrete variable.

A one-sample t test is used to test whether the mean for a variable has a
particular value. The main assumption in a t test is that the data come
from a Gaussian (normal) distribution. If this is not the case, then a
nonparametric test, such as the Wilcoxon signed-rank test, may be a
more appropriate test of location.

Performing a one-sample t test

From the main menu, choose Statistics » Compare Samples »
One Sample » t Test. The One-sample t Test dialog opens, as
shown in Figure 6.8.
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One-zample t Test = ]

—Data Confidence Interval
Data Set: Iexmichel VI (Eonfidence Lewvel: ID.SE
Wariable: Ispeed - l Fiesult

— Hypothese: s I
Mean Under Mull Hypothesis: V' Print Results

ISSD
Alternative Hppothesis:
Itwo.sided 'l

ak. I Eancell Applyl I<| >| cLment

Figure 6.8: The One-sample t Test dialog.

Help |

Example

In 1876, the French physicist Cornu reported a value of 299,990 km/
sec for C, the speed of light. In 1879, the American physicist A.A.

Michelson carried out several experiments to verify and improve

Cornu’s value. Michelson obtained the following 20 measurements of
the speed of light:

850 740 900
1000 980 930

1070
650

930 850 950 980
760 810 1000 1000

980
960

880
960

To obtain Michelson’s actual measurements, add 299,000 km/sec to
each of the above values. In Chapter 3, Exploring Data, we created
an exmichel data set containing the Michelson data.

The 20 observations can be thought of as observed values of 20
random variables with a common but unknown mean-value location

L. If the experimental setup for measuring the speed of light is free of

bias, then it is reasonable to assume that Ll is the true speed of light.
In evaluating these data, we seek answers to at least four questions:

1. What is the speed of light 1 ?

2. Has the speed of light changed relative to our best previous
value 1, = 299, 990 km/sec?

3. What is the uncertainty associated with our answers to (1) and
(2)?

4. What is the shape of the distribution of the data?
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The first three questions were probably in Michelson’s mind when he
gathered his data. The last two must be answered to determine which
techniques can be used to obtain valid statistical inferences from the
data. For example, if the shape of the distribution indicates a nearly
normal distribution without outliers, we can use the Student’s t tests
to assist in answering question (2). If the data contain outliers or are
far from normal, we should use a robust method or a nonparametric
method, such as the Wilcoxon signed-rank test. In this section, we use
Spotfire S+ to carefully analyze the Michelson data. Identical
techniques can be used to explore and analyze any set of one-sample
data.

Exploratory data analysis

To obtain a useful exploratory view of the Michelson data, create the
following four plots: a boxplot, a histogram, a density plot, and a QQ
normal plot. In Chapter 3, we created plots similar to the ones shown
in Figure 6.9 to graphically analyze the Michelson data.

1100 7

1000 7

900

speed

800

700 ’7
[

0 T
600 700 800 900 1000 1100
600 speed

Figure 6.9: Exploratory data analysis plots for the Michelson data.
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Figure 6.9: Exploratory data analysis plots for the Michelson data. (Continued)
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We want to evaluate the shape of the distribution to see if our data are
normally distributed. These plots reveal a distinctly skewed
distribution toward the left (that is, toward smaller values). The
distribution is thus not normal and probably not even “nearly”
normal. We should therefore not use Student’s t test for our statistical
inference, since it requires normality for small samples.

The solid horizontal line in the box plot is located at the median of the
data, and the upper and lower ends of the box are located at the upper
and lower quartiles of the data, respectively. To obtain precise values
for the median and quartiles, use the Summary Statistics dialog.

1. Open the Summary Statistics dialog.
2. Enter exmichel as the Data Set.

3. Click on the Statistics tab, and deselect all options except
Mean, Minimum, First Quartile, Median, Third Quartile,
and Maximum.

4. Click OK. The output appears in the Report window.

***  Summary Statistics for data in: exmichel ***

speed

Min: 650.000

1st Qu.: 850.000
Mean: 909.000
Median: 940.000
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3rd Qu.: 980.000
Max: 1070.000

The summary shows, from top to bottom, the smallest observation,
the first quartile, the mean, the median, the third quartile, and the
largest observation. From this summary, you can compute the
interquartile range, IOR = 3Q - 1Q. The interquartile range provides a
useful criterion for identifying outliers: any observation that is more
than 1.5 3 IQR above the third quartile or below the first quartile is a
suspected outlier.

Statistical inference

Because the Michelson data are probably not normal, you should use
the Wilcoxon signed-rank test for statistical inference, rather than the

Student’s t test. For illustrative purposes, we use both.

To compute Student’s t confidence intervals for the population
mean-value location parameter |1, we use the One-sample t Test
dialog. This dialog also computes Student’s t significance test p values

for the parameter L, = 299, 990.

1. Open the One-sample t Test dialog.
2. Type exmichel in the Data Set field.
3. Select speed as the Variable.
4

Suppose you want to test the null hypothesis value n, = 990

(plus 299,000) against a two-sided alternative, and you want to
construct 95% confidence intervals. Enter 990 as the Mean
Under Null Hypothesis.

5. Click OK.

The results of the one-sample t-test appear in the Report window.

One-sample t-Test

data: speed in exmichel
t = -3.4524, df =19, p-value = 0.0027
alternative hypothesis: true mean is not equal to 990
95 percent confidence interval:
859.8931 958.1069
sample estimates:
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One-Sample
Wilcoxon Signed-
Rank Test
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mean of x
909

The computed mean of the Michelson data is 909, and the p value is
0.0027, which is highly significant. Clearly, Michelson’s average value
of 299,909 km/sec for the speed of light is significantly different from
Cornu’s value of 299,990 km/sec.

Spotfire S+ returns other useful information besides the p value,
including the t statistic value, the degrees of freedom, the sample
mean, and the confidence interval.

The Wilcoxon signed-rank test is used to test whether the median for a
variable has a particular value. Unlike the one-sample t test, it does

not assume that the observations come from a Gaussian (normal)
distribution.

Performing a one-sample Wilcoxon signed-rank test

From the main menu, choose Statistics » Compare Samples »
One Sample » Wilcoxon Signed Rank Test. The One-sample
Wilcoxon Test dialog opens, as shown in Figure 6.10.

One-zample Wilcoxon Test M= EI
—Data — Optio:
Data Set: Iexmichel 'l ¥ Use Exact Distribution
Wariable: Ispeed 'l V' Contirwity Comection
— Hypothese: — Result
Mean Under Mull Hypothesis: Save Az I
ISSD V' Print Results
Alternative Hppothesis:
Itwo.sided 'l
ak. I Cancel | Apply | I<| >| cLment Help |

Figure 6.10: The One-sample Wilcoxon Test dialog.

Example

In One-Sample t Test on page 213, we performed a t test on the
Michelson data. The test concludes that Michelson’s average value
for the speed of light (299,909 km/sec) is significantly different from
Cornu’s value of 299,990 km/sec. However, we have noted that the
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data may not be normal, so the results of the t test are suspect. We
now conduct a Wilcoxon signed-rank test to see if the two values for
the speed of light differ significantly from each other.

1. Open the One-sample Wilcoxon Test dialog.
2. Type exmichel in the Data Set field.
3. Select speed as the Variable.
4. Enter 990 as the Mean Under Null Hypothesis.
5. Click OK.
The Report window shows:

WiTcoxon signed-rank test

data: speed in exmichel

signed-rank normal statistic with correction Z = -3.0715,
p-value = 0.0021

alternative hypothesis: true mu is not equal to 990

You may also receive a warning message that there are duplicate
values in the variable speed. You can ignore this message. The
p value of 0.0021 is close to the t test p value of 0.0027 for testing the
same null hypothesis with a two-sided alternative. Thus, the
Wilcoxon signed-rank test confirms that Michelson’s average value

for the speed of light of 299,909 km/sec is significantly different from
Cornu’s value of 299,990 km/sec.

The Kolmogorov-Smirnov goodness-of-fit test is used to test whether the
empirical distribution of a set of observations is consistent with a
random sample drawn from a specific theoretical distribution. It is
generally more powerful than the chi-square goodness-of-fit test for
continuous variables. For discrete variables, the chi-square test is
generally preferable.

If parameter values for the theoretical distribution are not available,
they may be estimated from the observations automatically as part of
the test for normal (Gaussian) or exponential distributions. For other
distributions, the chi-square test must be used if parameters are to be
estimated. In this case, the parameters are estimated from the data
separately from the test, and then entered into the dialog.
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Performing a one-sample Kolmogorov-Smirnov goodness-of-fit test

From the main menu, choose Statistics » Compare Samples »
One Sample » Kolmogorov-Smirnov GOF. The One-sample
Kolmogorov-Smirnov Goodness-of-Fit Test dialog opens, as
shown in Figure 6.11.

One-zample Kolmogoroy-Smirnoy Goodness-of-Fit Test ==

—Data — Distribution Parameters

Data Set: chc.process VI I i I
Wariable: |>< VI I B I

— Hypothese: Mean: I
Alternative Hppothesis: it ol l—
Itwo.sided 'l
Lacation: I
Diistribution: I normal = l
Sealer I
— Result
Save Az l— Stipe: I
V' Print Results SHEEE 2 I
[eq, af Freedem 1:|
[eq, af Freedem g:|
I, ofiSuceesses: I
Eratatiit: I
Sample Size; I
Total Suecesses: I
Tiatal Eailures: I

QK I Eancell Applyl I<| >| current Help |

Figure 6.11: The One-sample Kolmogorov-Smirnov Goodness-of-Fit Test
dialog.

Example

We create a data set called qcc.process that contains a simulated
process with 200 measurements. Ten measurements per day were
taken for a total of twenty days. We use the Random Numbers
dialog to generate the data set from a Gaussian distribution. For more
details on this dialog, see Random Numbers and Distributions on
page 366.

1. Open an empty data set by clicking the New Data Set button
[3 on the Standard toolbar.
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2. Select Data » Random Numbers from the main menu.
Verify that the name of the blank data set is in the Data Set
field. Note that the Distribution is normal by default. Type
10 for the Mean and leave the Std. Deviation as 1.

3. Type X for the Target Column and 200 for the Sample Size.
For reproducibility, we want to set the random number
generator seed: type 21 in the Set Seed with field. Click OK.
This step creates a column named X containing 200 elements
that are randomly sampled from a Gaussian distribution.

4. Select Data » Fill from the main menu. Verify that the name
of the data set appears in the Data Set field. Type Day for the
Columns, 20 as the Length, and 10 as the number of
Replications. Select Grouped Sequence from the Content
list and click OK. This step creates a column named Day
containing the integers 1 through 20, each repeated 10 times.
The Day column represents the day on which the simulated
measurements were taken.

5. Rename the data set by double-clicking in the upper left
corner of the Data window. In the dialog that appears, type
gcc.process in the Name field and click OK.

We can use the Kolmogorov-Smirnov goodness-of-fit test to confirm
that gcc.process is Gaussian:

1. Open the One-sample Kolmogorov-Smirnov Goodness-
of-Fit Test dialog. The Distribution is normal by default.

2. Select gcc.process as the Data Set.
3. Select X as the Variable.
4. Click OK.

A summary of the goodness-of-fit test appears in the Report window.
The p value of 0.5 indicates that we do not reject the hypothesis that
the data are normally distributed. The summary also contains
estimates of the mean and standard deviation for the distribution.

The Message window contains a warning indicating that the Dallal-
Wilkinson approximation used in this test is most accurate for
extreme p values (pvalues < 0.1). Our actual calculated p value is
0.776, which is set to 0.5 in the summary to indicate that the null
hypothesis is not rejected, but our estimate of the p value is not highly
accurate.
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Chi-Square
Goodness-of-Fit
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The chi-square goodness-of-fit test uses Pearson’s chi-square statistic to
test whether the empirical distribution of a set of observations is
consistent with a random sample drawn from a specific theoretical
distribution.

Chi-square tests apply to any type of variable: continuous, discrete, or
a combination of these. If the hypothesized distribution is discrete

and the sample size is large (N> 50), the chi-square is the only valid
test. In addition, the chi-square test easily adapts to the situation in
which parameters of a distribution are estimated. However, for
continuous variables, information is lost by grouping the data.

When the hypothesized distribution is continuous, the Kolmogorov-
Smirnov test is more likely than the chi-square test to reject the null
hypothesis when it should be rejected. The Kolmogorov-Smirnov test
is more powerful than the chi-square test, and hence is preferred for
continuous distributions.

Performing Pearson’s chi-square test

From the main menu, choose Statistics » Compare Samples »
One Sample » Chi-square GOF. The One-sample Chi-Square
Goodness-of-Fit Test dialog opens, as shown in Figure 6.12.
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One-zample Chi-Square Goodness-of-Fit Test = ]
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Figure 6.12: The One-sample Chi-Square Goodness-of-Fit Test dialog.

Example

In the previous section, we created a data set called gcc.process that
contains a simulated process with 200 measurements. Ten
measurements per day were taken for a total of twenty days. We can
use the chi-square goodness-of-fit test to confirm that qcc.process is
Gauss